aboutsummaryrefslogtreecommitdiff
path: root/audio/ccaudio/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-03 22:31:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-03 22:31:54 +0000
commitbb06060423cc08610153442f353714f71f3aad90 (patch)
tree2b842fe7811f321ddff016f661119a599bffb252 /audio/ccaudio/Makefile
parent404d7fdd2b7df5c8b2d8cdf36cebe1f5b1287dbe (diff)
Notes
Diffstat (limited to 'audio/ccaudio/Makefile')
-rw-r--r--audio/ccaudio/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index b7167e530637..d8c3c90b824c 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -6,22 +6,19 @@
#
PORTNAME= ccaudio
-PORTVERSION= 1.1.1
-PORTREVISION= 0
+PORTVERSION= 1.1.3
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
- ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
-MASTER_SITE_SUBDIR= ccaudio/:gnu \
- bayonne/:sf
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu,sf
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnutelephony
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class framework for manipulating audio files
-LIB_DEPENDS= ccgnu2-1.1.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccgnu2-1.2.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -29,4 +26,8 @@ MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
LinearSample.3cc
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+
.include <bsd.port.mk>