aboutsummaryrefslogtreecommitdiff
path: root/audio/cdparanoia/Makefile
diff options
context:
space:
mode:
authorMatthew N. Dodd <mdodd@FreeBSD.org>2003-01-10 01:06:33 +0000
committerMatthew N. Dodd <mdodd@FreeBSD.org>2003-01-10 01:06:33 +0000
commit249b77d019d33e453072af20b5e1e6717e50bde1 (patch)
treef047940bcdd332211498cbd98b9c3e4066571f08 /audio/cdparanoia/Makefile
parent92fdd64a1deeeb96340ff215316114f7f00b41b8 (diff)
Notes
Diffstat (limited to 'audio/cdparanoia/Makefile')
-rw-r--r--audio/cdparanoia/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/cdparanoia/Makefile b/audio/cdparanoia/Makefile
new file mode 100644
index 000000000000..9fe60385f50d
--- /dev/null
+++ b/audio/cdparanoia/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cdparanoia
+# Date created: 5 Jan 2003
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdparanoia
+PORTVERSION= 3.9.8
+CATEGORIES= audio sysutils
+MASTER_SITES= http://www.xiph.org/paranoia/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/^3\./III-alpha/}
+EXTRACT_SUFX= .src.tgz
+
+MAINTAINER= corecode@corecode.ath.cx
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500041
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.endif
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.post.mk>