aboutsummaryrefslogtreecommitdiff
path: root/audio/chromaprint
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-09-25 01:29:24 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-09-25 01:29:24 +0000
commit449f2064cb7fb57ea78998e0a02737a945008686 (patch)
treebbbadf3cf065f93013b5dbfc345627337c8dc4cc /audio/chromaprint
parent20ca9274d541ba19b7c0b2ad9ad1a6414d0091fc (diff)
downloadports-449f2064cb7fb57ea78998e0a02737a945008686.tar.gz
ports-449f2064cb7fb57ea78998e0a02737a945008686.zip
Notes
Diffstat (limited to 'audio/chromaprint')
-rw-r--r--audio/chromaprint/Makefile15
-rw-r--r--audio/chromaprint/distinfo4
-rw-r--r--audio/chromaprint/files/patch-src__utils.h10
-rw-r--r--audio/chromaprint/pkg-plist2
4 files changed, 23 insertions, 8 deletions
diff --git a/audio/chromaprint/Makefile b/audio/chromaprint/Makefile
index e5c8e195ce5c..233aa6ffe215 100644
--- a/audio/chromaprint/Makefile
+++ b/audio/chromaprint/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= chromaprint
-PORTVERSION= 0.7
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= audio
-MASTER_SITES= http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
+MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/
MAINTAINER= jhale@FreeBSD.org
COMMENT= AcoustID audio fingerprinting library
@@ -14,9 +13,9 @@ LICENSE= LGPL21
LIB_DEPENDS= avcodec${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX}
USES= cmake:outsource
-NO_STAGE= yes
USE_LDCONFIG= yes
+FETCH_ARGS= -Fpr
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=ON \
-DWITH_AVFFT:BOOL=ON \
-DFFMPEG_SUFFIX:STRING=${FFMPEG_SUFFIX}
@@ -26,4 +25,10 @@ post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
${WRKSRC}/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if (${CXX:T} == "clang++" && ${OSVERSION} > 902000) || ${OSVERSION} > 1000054
+CXXFLAGS+= -stdlib=libc++ -std=c++11
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/chromaprint/distinfo b/audio/chromaprint/distinfo
index 019e3e70ea03..e2905579e193 100644
--- a/audio/chromaprint/distinfo
+++ b/audio/chromaprint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chromaprint-0.7.tar.gz) = 4e52c3fd443c91a5c429557753d4ba3f9d31d183810412c0d8600892f3975501
-SIZE (chromaprint-0.7.tar.gz) = 543811
+SHA256 (chromaprint-1.0.tar.gz) = af4f780e587ebd7e61a8d175db3bbd63ee644a960bd75e52407a28fd83089f1e
+SIZE (chromaprint-1.0.tar.gz) = 541381
diff --git a/audio/chromaprint/files/patch-src__utils.h b/audio/chromaprint/files/patch-src__utils.h
new file mode 100644
index 000000000000..0653e2d7c289
--- /dev/null
+++ b/audio/chromaprint/files/patch-src__utils.h
@@ -0,0 +1,10 @@
+--- src/utils.h.orig 2013-09-21 17:20:43.538723086 +0000
++++ src/utils.h 2013-09-21 17:21:02.622721058 +0000
+@@ -30,6 +30,7 @@
+ #include <stdint.h>
+ #include <limits>
+ #include <iterator>
++#include <algorithm> // std::fill
+
+ #ifndef HAVE_ROUND
+ static inline double round(double x)
diff --git a/audio/chromaprint/pkg-plist b/audio/chromaprint/pkg-plist
index 13edddd072e4..acc9425daa93 100644
--- a/audio/chromaprint/pkg-plist
+++ b/audio/chromaprint/pkg-plist
@@ -2,5 +2,5 @@ bin/fpcalc
include/chromaprint.h
lib/libchromaprint.so
lib/libchromaprint.so.0
-lib/libchromaprint.so.0.2.0
+lib/libchromaprint.so.0.2.1
libdata/pkgconfig/libchromaprint.pc