aboutsummaryrefslogtreecommitdiff
path: root/audio/clementine-player
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
commit5978476c353873821167189c3e7e7d3ce7b9909a (patch)
tree5c7b83e7642fc29f698d59a6bc145001dbd04783 /audio/clementine-player
parent95ab3035bfc8b040822f80592efa7b9f2b7a51b6 (diff)
downloadports-5978476c353873821167189c3e7e7d3ce7b9909a.tar.gz
ports-5978476c353873821167189c3e7e7d3ce7b9909a.zip
Notes
Diffstat (limited to 'audio/clementine-player')
-rw-r--r--audio/clementine-player/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 8e40dabc1bfb..45c269b01f62 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -13,12 +13,12 @@ COMMENT= Cross-platform music player based on Amarok 1.4
LICENSE= GPLv3
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- tag:${PORTSDIR}/audio/taglib \
- chromaprint:${PORTSDIR}/audio/chromaprint \
- protobuf:${PORTSDIR}/devel/protobuf \
- qjson:${PORTSDIR}/devel/qjson \
- fftw3:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libtag.so:${PORTSDIR}/audio/taglib \
+ libchromaprint.so:${PORTSDIR}/audio/chromaprint \
+ libprotobuf.so:${PORTSDIR}/devel/protobuf \
+ libqjson.so:${PORTSDIR}/devel/qjson \
+ libfftw3.so:${PORTSDIR}/math/fftw3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
@@ -79,7 +79,7 @@ CMAKE_ARGS+= -DENABLE_USE_BUILTIN_TAGLIB=OFF
.if ${PORT_OPTIONS:MAUDIOCD}
CMAKE_ARGS+= -DENABLE_AUDIOCD=ON
-LIB_DEPENDS+= cdio:${PORTSDIR}/sysutils/libcdio
+LIB_DEPENDS+= libcdio.so:${PORTSDIR}/sysutils/libcdio
.else
CMAKE_ARGS+= -DENABLE_AUDIOCD=OFF
.endif
@@ -112,28 +112,28 @@ CMAKE_ARGS+= -DENABLE_GOOGLE_DRIVE=OFF
.if ${PORT_OPTIONS:MGPOD}
CMAKE_ARGS+= -DENABLE_LIBGPOD=ON
-LIB_DEPENDS+= gpod:${PORTSDIR}/audio/libgpod
+LIB_DEPENDS+= libgpod.so:${PORTSDIR}/audio/libgpod
.else
CMAKE_ARGS+= -DENABLE_LIBGPOD=OFF
.endif
.if ${PORT_OPTIONS:MLASTFM}
CMAKE_ARGS+= -DENABLE_LIBLASTFM=ON
-LIB_DEPENDS+= lastfm:${PORTSDIR}/audio/liblastfm
+LIB_DEPENDS+= liblastfm.so:${PORTSDIR}/audio/liblastfm
.else
CMAKE_ARGS+= -DENABLE_LIBLASTFM=OFF
.endif
.if ${PORT_OPTIONS:MMTP}
CMAKE_ARGS+= -DENABLE_LIBMTP=ON
-LIB_DEPENDS+= mtp:${PORTSDIR}/audio/libmtp
+LIB_DEPENDS+= libmtp.so:${PORTSDIR}/audio/libmtp
.else
CMAKE_ARGS+= -DENABLE_LIBMTP=OFF
.endif
.if ${PORT_OPTIONS:MSPOTIFY}
CMAKE_ARGS+= -DENABLE_SPOTIFY=ON
-LIB_DEPENDS+= qca:${PORTSDIR}/devel/qca
+LIB_DEPENDS+= libqca.so:${PORTSDIR}/devel/qca
.else
CMAKE_ARGS+= -DENABLE_SPOTIFY=OFF -DENABLE_SPOTIFY_BLOB=OFF
.endif