aboutsummaryrefslogtreecommitdiff
path: root/audio/clunk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-24 14:46:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-24 14:46:48 +0000
commitedb37aae89c2519748c848ebe003b097371619e1 (patch)
tree5f3ed30d6c2837125463235dccd7741fea8769f3 /audio/clunk
parentccac602da47bfa5e835178e7361bea5a701c846b (diff)
downloadports-edb37aae89c2519748c848ebe003b097371619e1.tar.gz
ports-edb37aae89c2519748c848ebe003b097371619e1.zip
Notes
Diffstat (limited to 'audio/clunk')
-rw-r--r--audio/clunk/Makefile25
-rw-r--r--audio/clunk/distinfo4
-rw-r--r--audio/clunk/files/patch-SConstruct36
-rw-r--r--audio/clunk/files/patch-sse_fft_context.cpp30
-rw-r--r--audio/clunk/pkg-plist4
5 files changed, 9 insertions, 90 deletions
diff --git a/audio/clunk/Makefile b/audio/clunk/Makefile
index bddee6bf4514..8c07d99af3b8 100644
--- a/audio/clunk/Makefile
+++ b/audio/clunk/Makefile
@@ -6,38 +6,25 @@
#
PORTNAME= clunk
-DISTVERSION= r20100412
+PORTVERSION= 1.2.130
CATEGORIES= audio
-MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= SF/clunk
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Real-time 3D sound generation library
USE_BZIP2= yes
+USE_CMAKE= yes
USE_SDL= sdl
-MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-
-USE_SCONS= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
OPTIONS= SIMD "Enable SIMD support (SSE)" off
.include <bsd.port.options.mk>
-.if !defined(WITH_SIMD)
-post-patch:
- @${REINPLACE_CMD} -e '/^have_sse/ s|True|False|' ${WRKSRC}/SConstruct
+.if defined(WITH_SIMD)
+CMAKE_ARGS+= -DWITH_SSE:BOOL=TRUE
.endif
-.if ${OSVERSION} < 700000
-BROKEN= Requires posix_memalign()
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/libclunk.so ${PREFIX}/lib/
- ${MKDIR} ${PREFIX}/include/clunk
- ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/clunk/
-
.include <bsd.port.mk>
diff --git a/audio/clunk/distinfo b/audio/clunk/distinfo
index 39e0fab55852..b4b7a5f046e4 100644
--- a/audio/clunk/distinfo
+++ b/audio/clunk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clunk-r20100412.tar.bz2) = 13accf3764ca4ae3018d112aa92dd55b5681b5113c8a1973cc58ab9b4cdf596b
-SIZE (clunk-r20100412.tar.bz2) = 1378603
+SHA256 (clunk-1.2.130.tar.bz2) = e35130b03d6602e93f813cb50f05ea0f8b9296199ca1f3548f87e559a1c038d2
+SIZE (clunk-1.2.130.tar.bz2) = 1381073
diff --git a/audio/clunk/files/patch-SConstruct b/audio/clunk/files/patch-SConstruct
deleted file mode 100644
index f50d4a5a605a..000000000000
--- a/audio/clunk/files/patch-SConstruct
+++ /dev/null
@@ -1,36 +0,0 @@
---- SConstruct.orig 2009-07-16 16:14:29.000000000 +0400
-+++ SConstruct 2009-08-06 04:24:21.000000000 +0400
-@@ -1,6 +1,6 @@
- import os, sys
-
--env = Environment()
-+env = Environment(ENV=os.environ, **dict((k, v.split()) for k, v in ARGUMENTS.iteritems()))
- debug = False
-
- sdl_cflags = env.ParseFlags('!pkg-config --cflags sdl')
-@@ -29,13 +29,6 @@
- if have_sse:
- env.Append(CPPDEFINES=['USE_SIMD'])
-
--if debug:
-- buildmode = 'debug'
-- env.Append(CXXFLAGS=['-ggdb'])
--else:
-- buildmode = 'release'
-- env.Append(CXXFLAGS=['-O3', '-mtune=native', '-march=native'])
--
- clunk_src = [
- 'context.cpp', 'sample.cpp', 'object.cpp', 'source.cpp', 'sdl_ex.cpp', 'stream.cpp',
- 'kemar.c', 'buffer.cpp', 'distance_model.cpp', 'logger.cpp', 'clunk_ex.cpp',
-@@ -49,9 +42,7 @@
-
-
- if sys.platform != 'win32':
-- env.Append(CFLAGS=['-Wall', '-pedantic'])
-- env.Append(CXXFLAGS=['-Wall', '-pedantic'])
-- env.Append(LINKFLAGS=['-Wl,-rpath,'+ lib_dir])
-- env.Append(LINKFLAGS=['-Wl,-rpath-link,.'])
-+ env.Append(CFLAGS=['-Wall'])
-+ env.Append(CXXFLAGS=['-Wall'])
-
- env.Program('clunk_test', ['test.cpp'], LIBS=['clunk'])
diff --git a/audio/clunk/files/patch-sse_fft_context.cpp b/audio/clunk/files/patch-sse_fft_context.cpp
deleted file mode 100644
index 6734d4264902..000000000000
--- a/audio/clunk/files/patch-sse_fft_context.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- sse_fft_context.cpp.orig 2009-08-05 01:28:34.000000000 +0400
-+++ sse_fft_context.cpp 2010-04-13 04:16:03.000000000 +0400
-@@ -1,5 +1,4 @@
- #include <stdlib.h>
--#include <malloc.h>
- #include <stdio.h>
- #include <new>
- #include "fft_context.h"
-@@ -9,20 +8,11 @@
-
- void * aligned_allocator::allocate(size_t size, size_t alignment) {
- void * ptr;
--#ifdef _WINDOWS
-- ptr = _aligned_malloc(size, alignment);
--#else
-- ptr = memalign(alignment, size);
--#endif
-- if (ptr == NULL)
-+ if (posix_memalign(&ptr, alignment, size) != 0)
- throw std::bad_alloc();
- return ptr;
- }
-
- void aligned_allocator::deallocate(void *ptr) {
--#ifdef _WINDOWS
-- _aligned_free(ptr);
--#else
- free(ptr);
--#endif
- }
diff --git a/audio/clunk/pkg-plist b/audio/clunk/pkg-plist
index e3839fe34a88..800980941903 100644
--- a/audio/clunk/pkg-plist
+++ b/audio/clunk/pkg-plist
@@ -1,18 +1,16 @@
include/clunk/buffer.h
include/clunk/clunk.h
include/clunk/clunk_assert.h
-include/clunk/clunk_ex.h
+include/clunk/clunk_c.h
include/clunk/context.h
include/clunk/distance_model.h
include/clunk/export_clunk.h
include/clunk/fft_context.h
-include/clunk/kemar.h
include/clunk/locker.h
include/clunk/logger.h
include/clunk/mdct_context.h
include/clunk/object.h
include/clunk/sample.h
-include/clunk/sdl_ex.h
include/clunk/source.h
include/clunk/sse_fft_context.h
include/clunk/stream.h