aboutsummaryrefslogtreecommitdiff
path: root/audio/cmus
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-29 20:20:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-29 20:20:58 +0000
commit796b5ef2df07167cd7564e4b152508e3a8da35bd (patch)
treeb9b9edf021ae0da8d3381c825769be1293e305ed /audio/cmus
parent4fdc5322c6e78fe3612cda3bb2d9228477182631 (diff)
downloadports-796b5ef2df07167cd7564e4b152508e3a8da35bd.tar.gz
ports-796b5ef2df07167cd7564e4b152508e3a8da35bd.zip
Notes
Diffstat (limited to 'audio/cmus')
-rw-r--r--audio/cmus/Makefile19
-rw-r--r--audio/cmus/distinfo6
-rw-r--r--audio/cmus/pkg-plist2
3 files changed, 19 insertions, 8 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 8646a344fba9..d8723b350e77 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cmus
-PORTVERSION= 2.1.0
-PORTREVISION= 2
+PORTVERSION= 2.2.0
CATEGORIES= audio
MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
http://mirror.greaterscope.net/cmus/
@@ -16,11 +15,11 @@ MAINTAINER= simon@olofsson.de
COMMENT= Console-based music player with really cool features
USE_BZIP2= yes
-USE_GCC= 3.2+
USE_GMAKE= yes
USE_ICONV= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=prefix=${TARGETDIR} mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+=prefix=${TARGETDIR} mandir=${MANPREFIX}/man \
+ exampledir=${EXAMPLESDIR}
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -33,13 +32,14 @@ OPTIONS= FLAC "FLAC (Free Lossless Audio Codec) support" Off \
TREMOR "Use Tremor as Ogg/Vorbis input plugin" Off \
MP4 "MPEG-4 AAC support" Off \
AAC "AAC support" Off \
+ WAVPACK "Wavpack support" Off \
LIBAO "Libao cross-platform audio library" Off \
ARTS "ARTS support" Off
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
-LIB_DEPENDS= ncursesw.5:${PORTSDIR}/devel/ncurses
+LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
.endif
.if defined(WITH_FLAC)
@@ -119,6 +119,15 @@ CONFIGURE_ARGS+=CONFIG_AAC=n
PLIST_SUB+= AAC="@comment "
.endif
+.if defined(WITH_WAVPACK)
+LIB_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
+CONFIGURE_ARGS+=CONFIG_WAVPACK=y
+PLIST_SUB+= WAVPACK=""
+.else
+CONFIGURE_ARGS+=CONFIG_WAVPACK=n
+PLIST_SUB+= WAVPACK="@comment "
+.endif
+
.if defined(WITH_LIBAO)
LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=CONFIG_AO=y
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
index a85f257a26d8..a5fcded755ff 100644
--- a/audio/cmus/distinfo
+++ b/audio/cmus/distinfo
@@ -1,3 +1,3 @@
-MD5 (cmus-2.1.0.tar.bz2) = 11ca53a05442ee073b6e790e957b1433
-SHA256 (cmus-2.1.0.tar.bz2) = fe47e258918526b9e1b2cd7081d73654af8c326f0f3b0fabe450b805b78423c0
-SIZE (cmus-2.1.0.tar.bz2) = 146956
+MD5 (cmus-2.2.0.tar.bz2) = 7a9895ecfc10cd16577c73051436962f
+SHA256 (cmus-2.2.0.tar.bz2) = f18ffafc7161a383ddc79b34cc16a5a38f675454c49799dac5d172bf22d12005
+SIZE (cmus-2.2.0.tar.bz2) = 155448
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index 13b94ffe7a9e..2623c65221c9 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -9,6 +9,7 @@ lib/cmus/ip/wav.so
%%VORBIS%%lib/cmus/ip/vorbis.so
%%MP4%%lib/cmus/ip/mp4.so
%%AAC%%lib/cmus/ip/aac.so
+%%WAVPACK%%lib/cmus/ip/wavpack.so
lib/cmus/op/oss.so
%%AO%%lib/cmus/op/ao.so
%%ARTS%%lib/cmus/op/arts.so
@@ -16,6 +17,7 @@ lib/cmus/op/oss.so
%%DATADIR%%/default.theme
%%DATADIR%%/gray-88.theme
%%DATADIR%%/green-mono-88.theme
+%%DATADIR%%/green.theme
%%DATADIR%%/rc
%%DATADIR%%/xterm-white.theme
%%EXAMPLESDIR%%/cmus-status-display