aboutsummaryrefslogtreecommitdiff
path: root/audio/cmus
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2006-08-10 16:45:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2006-08-10 16:45:49 +0000
commit63fde99c0a23aae6fc7f5fe57bfa14a867afc24e (patch)
tree81cb4bc8535e4d8a1a08435209effbee9b140e92 /audio/cmus
parentfbefb9edeae53f13be2cf2dbc035c517874fb729 (diff)
downloadports-63fde99c0a23aae6fc7f5fe57bfa14a867afc24e.tar.gz
ports-63fde99c0a23aae6fc7f5fe57bfa14a867afc24e.zip
Notes
Diffstat (limited to 'audio/cmus')
-rw-r--r--audio/cmus/Makefile106
-rw-r--r--audio/cmus/distinfo6
-rw-r--r--audio/cmus/pkg-descr3
-rw-r--r--audio/cmus/pkg-plist19
4 files changed, 62 insertions, 72 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index bef7da1da337..9fe829258198 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cmus
-PORTVERSION= 2.0.2
+PORTVERSION= 2.0.3
CATEGORIES= audio
MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
http://mirror.greaterscope.net/cmus/
@@ -14,108 +14,102 @@ MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
MAINTAINER= simon@olofsson.de
COMMENT= Console-based music player with really cool features
-BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac \
- mad:${PORTSDIR}/audio/libmad
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}
+CONFIGURE_ARGS+=prefix=${TARGETDIR} mandir=${TARGETDIR}/man
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+OPTIONS= FLAC "FLAC (Free Lossless Audio Codec) support" Off \
+ MAD "MPEG Audio Decoder (libmad) support" On \
+ MODPLUG "libmodplug (mod, x3m, ...) support" Off \
+ MUSEPACK "libmpcdec (Musepack .mpc) support" Off \
+ VORBIS "Ogg/Vorbis support" On \
+ LIBAO "Libao cross-platform audio library" On \
+ ARTS "ARTS support" Off \
+ TREMOR "Use Tremor as Ogg/Vorbis input plugin" Off
+
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libvorbisfile.so)
-WITH_VORBIS= yes
-.endif
-.if exists(${LOCALBASE}/lib/libmodplug.so)
-WITH_MODPLUG= yes
-.endif
-.if exists(${LOCALBASE}/lib/libvorbisidec.so)
-WITH_TREMOR= yes
-.endif
-.if exists(${LOCALBASE}/lib/libmpcdec.so)
-WITH_MUSEPACK= yes
-.endif
-.if exists(${LOCALBASE}/lib/libao.so)
-WITH_LIBAO= yes
-.endif
-.if exists(${LOCALBASE}/lib/libartsc.so)
-WITH_ARTS= yes
+.if defined(WITH_FLAC)
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+=CONFIG_FLAC=y
+PLIST_SUB+= FLAC=""
+.else
+CONFIGURE_ARGS+=CONFIG_FLAC=n
+PLIST_SUB+= FLAC="@comment "
.endif
-PREMSG= \n
-
-.if defined(WITH_VORBIS)
-LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
-PLIST_SUB+= VORBIS=""
+.if !defined(WITHOUT_MAD)
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
+CONFIGURE_ARGS+=CONFIG_MAD=y
+PLIST_SUB+= MAD=""
.else
-PLIST_SUB+= VORBIS="@comment "
-PREMSG+= Define WITH_VORBIS=yes to enable OGG/Vorbis support.\n
+CONFIGURE_ARGS+=CONFIG_MAD=n
+PLIST_SUB+= MAD="@comment "
.endif
.if defined(WITH_MODPLUG)
LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
+CONFIGURE_ARGS+=CONFIG_MODPLUG=y
PLIST_SUB+= MODPLUG=""
.else
+CONFIGURE_ARGS+=CONFIG_MODPLUG=n
PLIST_SUB+= MODPLUG="@comment "
-PREMSG+= Define WITH_MODPLUG=yes to enable module music files.\n
-.endif
-
-.if defined(WITH_TREMOR)
-LIB_DEPENDS+= vorbisidec:${PORTSDIR}/audio/libtremor
-CONFIGURE_ARGS+=--with-tremor
-.else
-PREMSG+= Define WITH_TREMOR=yes to enable libtremor support.\n
.endif
.if defined(WITH_MUSEPACK)
LIB_DEPENDS+= mpcdec:${PORTSDIR}/audio/libmpcdec
+CONFIGURE_ARGS+=CONFIG_MPC=y
PLIST_SUB+= MPC=""
.else
+CONFIGURE_ARGS+=CONFIG_MPC=n
PLIST_SUB+= MPC="@comment "
-PREMSG+= Define WITH_MUSEPACK=yes to enable musepack support.\n
.endif
-.if defined(WITH_LIBAO)
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+=CONFIG_VORBIS=y
+PLIST_SUB+= VORBIS=""
+.else
+CONFIGURE_ARGS+=CONFIG_VORBIS=n
+PLIST_SUB+= VORBIS="@comment "
+.endif
+
+.if !defined(WITHOUT_LIBAO)
LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+CONFIGURE_ARGS+=CONFIG_AO=y
PLIST_SUB+= AO=""
.else
+CONFIGURE_ARGS+=CONFIG_AO=n
PLIST_SUB+= AO="@comment "
-PREMSG+= Define WITH_LIBAO=yes to enable the libao output library.\n
.endif
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
+CONFIGURE_ARGS+=CONFIG_ARTS=y
PLIST_SUB+= ARTS=""
.else
+CONFIGURE_ARGS+=CONFIG_ARTS=n
PLIST_SUB+= ARTS="@comment "
-PREMSG+= Define WITH_ARTS=yes to enable arts output support.\n
.endif
-MAN1= cmus.1 cmus-remote.1
+.if defined(WITH_TREMOR)
+LIB_DEPENDS+= vorbisidec:${PORTSDIR}/audio/libtremor
+CONFIGURE_ARGS+=CONFIG_TREMOR=y
+.endif
-pre-everything::
- @${PRINTF} "${PREMSG}"
- @${ECHO_CMD}
+MAN1= cmus.1 cmus-remote.1
post-extract:
- @${REINPLACE_CMD} -e 's, -Wno-pointer-sign,,' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's,$$(mandir)/man1,${PREFIX}/man/man1,' \
- ${WRKSRC}/Doc/Makefile
-
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
- "s|/bin/bash|${LOCALBASE}/bin/bash|; \
- s|-lncursesw|-lncurses|g"
+ @${REINPLACE_CMD} -e 's,-lncursesw,-lncurses,g' ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/examples
- ${INSTALL} ${WRKSRC}/cmus-status-display ${DOCSDIR}/examples
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} ${WRKSRC}/cmus-status-display ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
index 807e8c7bccd7..d0e323b8f27a 100644
--- a/audio/cmus/distinfo
+++ b/audio/cmus/distinfo
@@ -1,3 +1,3 @@
-MD5 (cmus-2.0.2.tar.bz2) = b2779489fef402def3162dc3fad29151
-SHA256 (cmus-2.0.2.tar.bz2) = b33340f22a29e5bd709beebd3ed11f1229f8aad7a64e8e0455f09353c4b99eef
-SIZE (cmus-2.0.2.tar.bz2) = 145345
+MD5 (cmus-2.0.3.tar.bz2) = 0d7438dfa6ed5cd83eda0ab183ba43fc
+SHA256 (cmus-2.0.3.tar.bz2) = 76feab351bd7b4c735689bde5e47aaa74a7f2b2454b2dd339a3b8293b3f86d8f
+SIZE (cmus-2.0.3.tar.bz2) = 134703
diff --git a/audio/cmus/pkg-descr b/audio/cmus/pkg-descr
index b3c63b82d60f..4a1afcc7204c 100644
--- a/audio/cmus/pkg-descr
+++ b/audio/cmus/pkg-descr
@@ -16,4 +16,5 @@ CMus has vi-style command interface, e.g. searching using '/' or
* Directory browser
* Supports 256 colors
-WWW: http://onion.dynserv.net/~timo/cmus.html
+Author: Timo Hirvonen <tihirvon@gmail.com>
+WWW: http://onion.dynserv.net/~timo/cmus.html
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index f89b11bf4c11..d6b6d97528a8 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -1,27 +1,22 @@
bin/cmus
bin/cmus-remote
-lib/cmus/ip/flac.so
-lib/cmus/ip/mad.so
+lib/cmus/ip/wav.so
+%%FLAC%%lib/cmus/ip/flac.so
+%%MAD%%lib/cmus/ip/mad.so
%%MODPLUG%%lib/cmus/ip/modplug.so
%%MPC%%lib/cmus/ip/mpc.so
%%VORBIS%%lib/cmus/ip/vorbis.so
-lib/cmus/ip/wav.so
+lib/cmus/op/oss.so
%%AO%%lib/cmus/op/ao.so
%%ARTS%%lib/cmus/op/arts.so
-lib/cmus/op/oss.so
%%DATADIR%%/cyan.theme
-%%DATADIR%%/cyan.theme.bak
%%DATADIR%%/default.theme
-%%DATADIR%%/default.theme.bak
%%DATADIR%%/gray-88.theme
-%%DATADIR%%/gray-88.theme.bak
%%DATADIR%%/green-mono-88.theme
-%%DATADIR%%/green-mono-88.theme.bak
%%DATADIR%%/rc
-%%DATADIR%%/rc.bak
-%%DOCSDIR%%/examples/cmus-status-display
-@dirrm %%DOCSDIR%%/examples
-@dirrm %%DOCSDIR%%
+%%DATADIR%%/xterm-white.theme
+%%PORTDOCS%%%%EXAMPLESDIR%%/cmus-status-display
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%
@dirrm lib/cmus/op
@dirrm lib/cmus/ip