aboutsummaryrefslogtreecommitdiff
path: root/audio/cowbell
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2005-11-13 02:43:07 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2005-11-13 02:43:07 +0000
commitdbdbfba7c76ee09dc823dffc134367400d70f771 (patch)
tree574f350426787471d1bcfa450c01290faad1b0f9 /audio/cowbell
parent4496dba4630ffd2e3e0ea3221ff0d29ad526549d (diff)
downloadports-dbdbfba7c76ee09dc823dffc134367400d70f771.tar.gz
ports-dbdbfba7c76ee09dc823dffc134367400d70f771.zip
Notes
Diffstat (limited to 'audio/cowbell')
-rw-r--r--audio/cowbell/Makefile34
-rw-r--r--audio/cowbell/distinfo3
-rw-r--r--audio/cowbell/pkg-descr9
-rw-r--r--audio/cowbell/pkg-plist6
4 files changed, 52 insertions, 0 deletions
diff --git a/audio/cowbell/Makefile b/audio/cowbell/Makefile
new file mode 100644
index 000000000000..5b4ecce1f9c2
--- /dev/null
+++ b/audio/cowbell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cowbell
+# Date created: 2005-08-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cowbell
+PORTVERSION= 0.2.4
+CATEGORIES= audio gnome
+MASTER_SITES= http://more-cowbell.org/releases/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= An elegant music organizer
+
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
+BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ mono:${PORTSDIR}/lang/mono
+
+USE_GNOME= gnomehack gnomeprefix gnometarget intltool
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|.so.*"|.so"|g' ${WRKSRC}/cowbell.exe.config
+
+.include "${PORTSDIR}/lang/mono/bsd.mono.mk"
+.include <bsd.port.post.mk>
diff --git a/audio/cowbell/distinfo b/audio/cowbell/distinfo
new file mode 100644
index 000000000000..34b1ef62dad5
--- /dev/null
+++ b/audio/cowbell/distinfo
@@ -0,0 +1,3 @@
+MD5 (cowbell-0.2.4.tar.gz) = 3581a049b1bab7d4e0dde7bc9260417e
+SHA256 (cowbell-0.2.4.tar.gz) = 9456562633da196e0aa1c970c3b9fcaffc5a1917d472564c09556533ed2bb250
+SIZE (cowbell-0.2.4.tar.gz) = 250755
diff --git a/audio/cowbell/pkg-descr b/audio/cowbell/pkg-descr
new file mode 100644
index 000000000000..48eeaab6998c
--- /dev/null
+++ b/audio/cowbell/pkg-descr
@@ -0,0 +1,9 @@
+Cowbell is an elegant music organizer intended to make keeping your collection
+tidy both fun and easy.
+
+Infused with Amazon Web Services SOAP-fu, Cowbell can whip your music platoon
+into shape without even getting your boots muddy. And, if that isn't enough
+to make you want to rush to the Download link, Cowbell can also snatch album
+art and rename your music files like a pro.
+
+WWW: http://more-cowbell.org
diff --git a/audio/cowbell/pkg-plist b/audio/cowbell/pkg-plist
new file mode 100644
index 000000000000..cc14fc986e71
--- /dev/null
+++ b/audio/cowbell/pkg-plist
@@ -0,0 +1,6 @@
+bin/cowbell
+lib/cowbell/cowbell.exe
+lib/cowbell/cowbell.exe.config
+share/gnome/applications/cowbell.desktop
+share/gnome/pixmaps/cowbell.png
+@dirrm lib/cowbell