aboutsummaryrefslogtreecommitdiff
path: root/audio/crip/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-07-13 00:36:54 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-07-13 00:36:54 +0000
commitea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4 (patch)
tree133e33b29eb0bb457b8362268b1be5f521eda0fc /audio/crip/Makefile
parent17a313983a9629cefb35fa2c8d3b628a4729bc84 (diff)
downloadports-ea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4.tar.gz
ports-ea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4.zip
Notes
Diffstat (limited to 'audio/crip/Makefile')
-rw-r--r--audio/crip/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/crip/Makefile b/audio/crip/Makefile
new file mode 100644
index 000000000000..19ccf97c4209
--- /dev/null
+++ b/audio/crip/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: crip
+# Date created: 30 June 2003
+# Whom: Philip Paeps <philip@paeps.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crip
+PORTVERSION= 3.4
+CATEGORIES= audio
+MASTER_SITES= http://bach.dynet.com/crip/src/
+
+MAINTAINER= philip@paeps.cx
+COMMENT= Terminal-based ripper/encoder/tagger
+
+RUN_DEPENDS= ${SITE_PERL}/CDDB_get.pm:${PORTSDIR}/audio/p5-CDDB_get \
+ cdparanoia:${PORTSDIR}/audio/cdparanoia \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ vorbisgain:${PORTSDIR}/audio/vorbisgain
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/wav_find_beginning ${WRKSRC}/wav_find_beginning.c
+ ${CC} ${CFLAGS} -o ${WRKSRC}/wav_find_end ${WRKSRC}/wav_find_end.c
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/crip ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/editcomment ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wav_find_beginning ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wav_find_end ${PREFIX}/bin
+
+.include <bsd.port.mk>