aboutsummaryrefslogtreecommitdiff
path: root/audio/csound/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-01-22 12:50:08 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-01-22 12:50:08 +0000
commitcb29bc88b054616c4347864f1da2c08fb539cf0d (patch)
tree827322b9ddfac8cde006015de22267be471f0537 /audio/csound/Makefile
parent10d923b4506170255f56b09125851d970e483eb0 (diff)
Update math/gmm++ to 5.1
Due to it requiring c++11 features now, the consumers audio/csound and audio/csound6 we're version bumped, and set USE_CXXSTD. * http://download.gna.org/getfem/html/homepage/whatsnew/5.0.html * http://download.gna.org/getfem/html/homepage/whatsnew/5.1.html Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7730
Notes
Notes: svn path=/head/; revision=432126
Diffstat (limited to 'audio/csound/Makefile')
-rw-r--r--audio/csound/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index a7e6f6af6356..883b8fc95629 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 5.19.01
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
@@ -28,6 +28,8 @@ CONFLICTS_INSTALL= outguess-* csound6
WRKSRC= ${WRKDIR}/${PORTNAME:S/c/C/}${PORTVERSION}
USES= bison cpe gettext scons compiler:openmp python
+# math/gmm++ requires c++11
+USE_CXXSTD= c++11
CPE_VENDOR= csounds
MAKE_ARGS= instdir="${STAGEDIR}" prefix="${PREFIX}" \
CC="${CC}" CXX="${CXX}" \