aboutsummaryrefslogtreecommitdiff
path: root/audio/csound6
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-10 18:05:29 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-10 18:05:29 +0000
commit411bac0c65ee297ed74d2335f68b9b57f7772ec6 (patch)
treefc19fceeac5f61f74eefcc55ab4163bcc9eeb99b /audio/csound6
parent4a80fa287d33f87949215e20c3fcd80138f493f3 (diff)
downloadports-411bac0c65ee297ed74d2335f68b9b57f7772ec6.tar.gz
ports-411bac0c65ee297ed74d2335f68b9b57f7772ec6.zip
Notes
Diffstat (limited to 'audio/csound6')
-rw-r--r--audio/csound6/Makefile132
-rw-r--r--audio/csound6/distinfo2
-rw-r--r--audio/csound6/files/custom.py.in12
-rw-r--r--audio/csound6/files/patch-InOut-rtalsa.c27
-rw-r--r--audio/csound6/files/patch-Opcodes-urandom.c10
-rw-r--r--audio/csound6/files/patch-Top-csound.c64
-rw-r--r--audio/csound6/files/patch-frontends__CsoundAC__ChordSpace.hpp19
-rw-r--r--audio/csound6/files/patch-frontends__CsoundAC__Composition.cpp37
-rw-r--r--audio/csound6/files/pkg-message.in4
-rw-r--r--audio/csound6/pkg-descr21
-rw-r--r--audio/csound6/pkg-plist120
11 files changed, 448 insertions, 0 deletions
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
new file mode 100644
index 000000000000..783afa38346d
--- /dev/null
+++ b/audio/csound6/Makefile
@@ -0,0 +1,132 @@
+# Created by: trevor
+# $FreeBSD$
+
+PORTNAME= csound
+PORTVERSION= 6.02
+CATEGORIES= audio lang
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
+DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}
+DIST_SUBDIR= csound
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Sound synthesizer
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
+ swig>2:${PORTSDIR}/devel/swig20 \
+ eigen>0:${PORTSDIR}/math/eigen3 \
+ gmm++>0:${PORTSDIR}/math/gmm++
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
+
+OPTIONS_DEFINE= ALSA DSSI FLTK FLUIDSYNTH JACK LUA NLS OPENMP OSC PNG \
+ PORTAUDIO PULSEAUDIO
+OPTIONS_DEFAULT=FLTK OPENMP
+OPTIONS_SUB= yes
+ALSA_DESC= Build ALSA I/O module
+DSSI_DESC= Build DSSI/LADSPA host opcodes
+FLTK_DESC= Build FLTK plugin and GUI
+FLUIDSYNTH_DESC=Building FluidSynth opcodes
+JACK_DESC= Build Jack I/O module and opcodes
+LUA_DESC= Build Lua Interface and opcodes
+OSC_DESC= Build OSC opcodes
+PNG_DESC= Build Image opcodes
+PORTAUDIO_DESC= Build PortAudio I/O module
+PULSEAUDIO_DESC=Build PulseAudio I/O module
+
+CONFLICTS_INSTALL= outguess-*
+
+USES= bison cmake gettext
+USE_PYTHON= 2
+CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
+ -DBUILD_JAVA_INTERFACE:BOOL=OFF \
+ -DBUILD_PD_CLASS:BOOL=OFF \
+ -DBUILD_STK_OPCODES:BOOL=OFF \
+ -DBUILD_TESTS:BOOL=OFF \
+ -DPYTHON_MODULE_INSTALL_DIR:STRING="${PYTHONPREFIX_SITELIBDIR}"
+USE_LDCONFIG= yes
+SSP_UNSAFE= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+SUB_FILES= pkg-message
+
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_CMAKE_OFF= -DUSE_ALSA:BOOL=OFF
+DSSI_BUILD_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
+DSSI_RUN_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
+DSSI_CMAKE_OFF= -DBUILD_DSSI_OPCODES:BOOL=OFF
+FLTK_LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
+FLTK_CMAKE_ON= -DBUILD_WINSOUND:BOOL=ON
+FLTK_CMAKE_OFF= -DUSE_FLTK:BOOL=OFF
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
+FLUIDSYNTH_CMAKE_OFF= -DBUILD_FLUID_OPCODES:BOOL=OFF
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CMAKE_OFF= -DBUILD_JACK_OPCODES:BOOL=OFF \
+ -DUSE_JACK:BOOL=OFF
+LUA_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+LUA_CMAKE_OFF= -DBUILD_CSOUND_AC_LUA_INTERFACE:BOOL=OFF \
+ -DBUILD_LUA_INTERFACE:BOOL=OFF \
+ -DBUILD_LUA_OPCODES:BOOL=OFF
+NLS_USES= gettext
+NLS_CMAKE_OFF= -DUSE_GETTEXT:BOOL=OFF
+OPENMP_USES= compiler:openmp
+OPENMP_CMAKE_OFF= -DUSE_OPEN_MP:BOOL=OFF
+OSC_LIB_DEPENDS= liblo.so:${PORTSDIR}/audio/liblo
+OSC_CMAKE_OFF= -DBUILD_OSC_OPCODES:BOOL=OFF
+PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+PNG_CMAKE_OFF= -DBUILD_IMAGE_OPCODES:BOOL=OFF
+PORTAUDIO_BUILD_DEPENDS=portaudio2>0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= portaudio2>0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_CMAKE_OFF= -DUSE_PORTAUDIO:BOOL=OFF
+PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CMAKE_OFF= -DUSE_PULSEAUDIO:BOOL=OFF
+
+.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING="${LOCALBASE}/bin/flex"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/-O3/s|^|#| ; \
+ /PYTHON_MODULE_INSTALL_DIR/s|^|#| ; \
+ /CMAKE_SYSTEM_NAME/s|"Linux"|"${OPSYS}"| ; \
+ s|(LIBINTL_LIBRARY OR LINUX)|(LIBINTL_LIBRARY)| ; \
+ s|(NOT LINUX)|(LINUX)| ; \
+ s|-D_GNU_SOURCE|| ; \
+ s| dl)|)|' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/InOut/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's|<portaudio.h>|<portaudio2/portaudio.h>|' \
+ ${WRKSRC}/InOut/rtpa.c
+ @${REINPLACE_CMD} -e \
+ 's|/usr/include/Python2.7|${PYTHON_INCLUDEDIR}| ; \
+ s|/usr/local|${LOCALBASE}| ; \
+ /linuxjoystick/s|^|#| ; \
+ s| dl)|)|' \
+ ${WRKSRC}/Opcodes/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ '/CMAKE_SYSTEM_NAME/s|"Linux"|"${OPSYS}"| ; \
+ s|--{WINSOUND_H}|$${WINSOUND_H}|' \
+ ${WRKSRC}/frontends/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's| mixer)| csmixer)|' \
+ ${WRKSRC}/util/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's|_IS_GNUCC)|_IS_GNUCC OR __COMPILER_CLANG)|' \
+ ${WRKSRC}/util1/CMakeLists.txt
+
+post-install:
+.for i in libCsoundAC.so libcsnd6.so libcsound64.so
+ @${LN} -sf ${i}.6.0 ${STAGEDIR}${PREFIX}/lib/${i}.6
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/audio/csound6/distinfo b/audio/csound6/distinfo
new file mode 100644
index 000000000000..289ae45f0c16
--- /dev/null
+++ b/audio/csound6/distinfo
@@ -0,0 +1,2 @@
+SHA256 (csound/Csound6.02.tar.gz) = b964199642b1141d4e3253a86996c613c2420c4e2cc39cad347ad7115768c0a5
+SIZE (csound/Csound6.02.tar.gz) = 23459796
diff --git a/audio/csound6/files/custom.py.in b/audio/csound6/files/custom.py.in
new file mode 100644
index 000000000000..3e5fbf1a5856
--- /dev/null
+++ b/audio/csound6/files/custom.py.in
@@ -0,0 +1,12 @@
+# Order is important: place local paths ahead of system paths.
+
+import sys
+
+customCPPPATH = [ '%%LOCALBASE%%/include', '%%PYTHON_INCLUDEDIR%%' ]
+customCCFLAGS = [ ]
+customCXXFLAGS = [ ]
+customLIBS = [ 'intl' ]
+customLIBPATH = [ '%%PORTAUDIO_L%%', '%%LOCALBASE%%/lib' ]
+customSHLINKFLAGS = [ '%%PORTAUDIO_R%%', '%%PTHREAD_LIBS%%' ]
+customSWIGFLAGS = []
+platform = 'linux'
diff --git a/audio/csound6/files/patch-InOut-rtalsa.c b/audio/csound6/files/patch-InOut-rtalsa.c
new file mode 100644
index 000000000000..952a11f4267d
--- /dev/null
+++ b/audio/csound6/files/patch-InOut-rtalsa.c
@@ -0,0 +1,27 @@
+--- InOut/rtalsa.c.orig 2011-12-22 19:41:53.000000000 +0900
++++ InOut/rtalsa.c 2011-12-27 23:53:00.000000000 +0900
+@@ -23,6 +23,7 @@
+ 02111-1307 USA
+ */
+
++/*
+ #ifndef _ISOC99_SOURCE
+ #define _ISOC99_SOURCE 1
+ #endif
+@@ -39,6 +40,7 @@
+ #ifndef _POSIX_C_SOURCE
+ #define _POSIX_C_SOURCE 1
+ #endif
++*/
+
+ #include "csdl.h"
+
+@@ -57,6 +59,8 @@
+ #include <signal.h>
+ #include <sys/mman.h>
+ #include <sys/resource.h>
++#include <stdlib.h>
++#include <sys/fcntl.h>
+
+
+ #include "soundio.h"
diff --git a/audio/csound6/files/patch-Opcodes-urandom.c b/audio/csound6/files/patch-Opcodes-urandom.c
new file mode 100644
index 000000000000..7d19cb045fdd
--- /dev/null
+++ b/audio/csound6/files/patch-Opcodes-urandom.c
@@ -0,0 +1,10 @@
+--- Opcodes/urandom.c.old 2011-01-30 02:14:59.000000000 -0600
++++ Opcodes/urandom.c 2011-01-30 02:15:08.000000000 -0600
+@@ -22,7 +22,6 @@
+ */
+
+ #include "csdl.h"
+-#include <ieee754.h>
+
+ typedef struct {
+ OPDS h;
diff --git a/audio/csound6/files/patch-Top-csound.c b/audio/csound6/files/patch-Top-csound.c
new file mode 100644
index 000000000000..08609d0b47b3
--- /dev/null
+++ b/audio/csound6/files/patch-Top-csound.c
@@ -0,0 +1,64 @@
+--- Top/csound.c.orig 2011-10-16 22:59:03.000000000 +0900
++++ Top/csound.c 2011-12-07 01:15:33.000000000 +0900
+@@ -60,10 +60,13 @@
+ #include "cs_par_dispatch.h"
+ #include "csound_orc_semantics.h"
+
+-#if defined(linux) || defined(__HAIKU__)
++#if defined(linux) || defined(__HAIKU__) || defined(__FreeBSD__)
+ #define PTHREAD_SPINLOCK_INITIALIZER 0
+ #endif
+
++#if defined(__FreeBSD__)
++#include <sys/sysctl.h>
++#endif
+ #if defined(USE_OPENMP)
+ #include <omp.h>
+ #endif /* USE_OPENMP */
+@@ -899,7 +902,7 @@
+
+ #if defined(ANDROID) || (!defined(LINUX) && !defined(SGI) && \
+ !defined(__HAIKU__) && !defined(__BEOS__) && \
+- !defined(__MACH__))
++ !defined(__MACH__) && !defined(__FreeBSD__))
+ static char *signal_to_string(int sig)
+ {
+ switch(sig) {
+@@ -3172,7 +3175,7 @@
+ /* ------------------------------------ */
+
+ #if defined(HAVE_RDTSC)
+-#if !(defined(LINUX) && defined(__GNUC__) && defined(__i386__))
++#if !(defined(LINUX) && defined(__GNUC__) && defined(__i386__)) || !(defined(__FreeBSD__) && defined(__i386__))
+ #undef HAVE_RDTSC
+ #endif
+ #endif
+@@ -3185,6 +3188,13 @@
+ static int getTimeResolution(void)
+ {
+ #if defined(HAVE_RDTSC)
++#if defined(__FreeBSD__)
++ size_t size;
++ int timeResolutionSeconds;
++ size = sizeof timeResolutionSeconds;
++ sysctlbyname("hw.clockrate", &timeResolutionSeconds, &size, NULL, 0);
++
++#else
+ FILE *f;
+ char buf[256];
+
+@@ -3220,9 +3230,14 @@
+ }
+ }
+ fclose(f);
++#endif /* __FreeBSD__ */
+ if (UNLIKELY(timeResolutionSeconds <= 0.0)) {
+ fprintf(stderr, Str("No valid CPU frequency entry "
++#if defined(__FreeBSD__)
++ "was found.\n"));
++#else
+ "was found in /proc/cpuinfo.\n"));
++#endif /* __FreeBSD__ */
+ return -1;
+ }
+ /* MHz -> seconds */
diff --git a/audio/csound6/files/patch-frontends__CsoundAC__ChordSpace.hpp b/audio/csound6/files/patch-frontends__CsoundAC__ChordSpace.hpp
new file mode 100644
index 000000000000..68c76b77f5eb
--- /dev/null
+++ b/audio/csound6/files/patch-frontends__CsoundAC__ChordSpace.hpp
@@ -0,0 +1,19 @@
+--- frontends/CsoundAC/ChordSpace.hpp.orig
++++ frontends/CsoundAC/ChordSpace.hpp
+@@ -29,6 +29,7 @@
+ #include <climits>
+ #include <cmath>
+ #include <cstdarg>
++#include <cstdio>
+ #include <eigen3/Eigen/Dense>
+ #include "Event.hpp"
+ #include <iostream>
+@@ -545,7 +546,7 @@
+ char buffer[0x1000];
+ std::stringstream stream;
+ for (size_t voice = 0; voice < voices(); ++voice) {
+- std::snprintf(buffer, 0x100, "%12.7f", getPitch(voice));
++ snprintf(buffer, 0x100, "%12.7f", getPitch(voice));
+ if (voice > 0) {
+ stream << " ";
+ }
diff --git a/audio/csound6/files/patch-frontends__CsoundAC__Composition.cpp b/audio/csound6/files/patch-frontends__CsoundAC__Composition.cpp
new file mode 100644
index 000000000000..fd03d322285e
--- /dev/null
+++ b/audio/csound6/files/patch-frontends__CsoundAC__Composition.cpp
@@ -0,0 +1,37 @@
+--- frontends/CsoundAC/Composition.cpp.orig
++++ frontends/CsoundAC/Composition.cpp
+@@ -22,6 +22,7 @@
+ #endif
+ #include "Composition.hpp"
+ #include "System.hpp"
++#include <cstdio>
+ #include <cstdlib>
+ #include <map>
+
+@@ -289,7 +290,7 @@
+ int Composition::normalizeOutputSoundfile(double levelDb)
+ {
+ char buffer[0x100];
+- std::snprintf(buffer,
++ snprintf(buffer,
+ 0x100,
+ "sox %s -V3 -b 32 -e floating-point %s gain -n %f\n",
+ getOutputSoundfileName().c_str(),
+@@ -307,7 +308,7 @@
+ int Composition::translateToCdAudio(double levelDb)
+ {
+ char buffer[0x100];
+- std::snprintf(buffer, 0x100, "sox %s -V3 -b 16 %s gain -n %f rate 44100\n",
++ snprintf(buffer, 0x100, "sox %s -V3 -b 16 %s gain -n %f rate 44100\n",
+ getOutputSoundfileName().c_str(),
+ getCdSoundfileName().c_str(),
+ levelDb);
+@@ -323,7 +324,7 @@
+ int Composition::translateToMp3(double bitrate, double levelDb)
+ {
+ char buffer[0x100];
+- std::snprintf(buffer,
++ snprintf(buffer,
+ 0x100,
+ "lame --verbose --disptime 2 --nohist --preset cd --tt %s --ta %s --tl %s --tc %s %s %s\n",
+ getTitle().c_str(),
diff --git a/audio/csound6/files/pkg-message.in b/audio/csound6/files/pkg-message.in
new file mode 100644
index 000000000000..94fe1c601a87
--- /dev/null
+++ b/audio/csound6/files/pkg-message.in
@@ -0,0 +1,4 @@
+===================-Please Note:-====================================
+%%PREFIX%%/bin/mixer has been renamed to %%PREFIX%%/bin/csmixer so it
+won't conflict with /usr/bin/mixer
+=====================================================================
diff --git a/audio/csound6/pkg-descr b/audio/csound6/pkg-descr
new file mode 100644
index 000000000000..368e0552a97a
--- /dev/null
+++ b/audio/csound6/pkg-descr
@@ -0,0 +1,21 @@
+Csound is a programming language designed and optimized for sound
+rendering and signal processing. The language consists of over 450
+opcodes - the operational codes that the sound designer uses to build
+"instruments" or patches.
+
+Although there are an increasing number of graphical "front-ends" for
+the language, you typically design and modify your patches using a word
+processor. Usually, you create two text files - a .orc (orchestra) file
+containing the "instruments," and a .sco (score) file containing the
+"notes."
+
+In Csound, the complexity of your patches is limited by your knowledge,
+interest, and need, but never by the language itself. For instance, a
+22,050 oscillator additive synthesizer with 1024 stage envelope
+generators on each is merely a copy-and-paste operation. The same goes
+for a 1 million voice granular texture!
+
+Have you ever dreamed of sounds such as these? Well in Csound you can.
+And in Csound these dreams can come true!
+
+WWW: http://www.csounds.com/
diff --git a/audio/csound6/pkg-plist b/audio/csound6/pkg-plist
new file mode 100644
index 000000000000..81723ed11c6c
--- /dev/null
+++ b/audio/csound6/pkg-plist
@@ -0,0 +1,120 @@
+bin/atsa
+bin/cs
+bin/csanalyze
+bin/csb64enc
+bin/csbeats
+bin/csmixer
+bin/csound
+bin/cvanal
+bin/dnoise
+bin/envext
+bin/extract
+bin/extractor
+bin/het_export
+bin/het_import
+bin/hetro
+bin/lpanal
+bin/lpc_export
+bin/lpc_import
+bin/makecsd
+bin/pv_export
+bin/pv_import
+bin/pvanal
+bin/pvlook
+bin/scale
+bin/scope
+bin/scot
+bin/scsort
+bin/sdif2ad
+bin/sndinfo
+bin/srconv
+%%FLTK%%bin/winsound
+include/csound/CppSound.hpp
+include/csound/CsoundFile.hpp
+include/csound/OpcodeBase.hpp
+include/csound/cfgvar.h
+include/csound/csPerfThread.hpp
+include/csound/cs_par_structs.h
+include/csound/cscore.h
+include/csound/csdl.h
+include/csound/csound.h
+include/csound/csound.hpp
+include/csound/csoundCore.h
+include/csound/csound_data_structures.h
+include/csound/csound_standard_types.h
+include/csound/csound_type_system.h
+include/csound/cwindow.h
+include/csound/filebuilding.h
+include/csound/float-version-double.h
+include/csound/float-version.h
+include/csound/interlocks.h
+include/csound/msg_attr.h
+include/csound/pools.h
+include/csound/pstream.h
+include/csound/pvfileio.h
+include/csound/soundio.h
+include/csound/sysdep.h
+include/csound/text.h
+include/csound/version.h
+lib/csound/plugins-6.0/csladspa.so
+%%LUA%%lib/csound/plugins-6.0/libLuaCsound.so
+lib/csound/plugins-6.0/libampmidid.so
+lib/csound/plugins-6.0/libcellular.so
+lib/csound/plugins-6.0/libchua.so
+lib/csound/plugins-6.0/libcontrol.so
+lib/csound/plugins-6.0/libcs_date.so
+lib/csound/plugins-6.0/libdoppler.so
+%%DSSI%%lib/csound/plugins-6.0/libdssi4cs.so
+lib/csound/plugins-6.0/libfareygen.so
+%%FLUIDSYNTH%%lib/csound/plugins-6.0/libfluidOpcodes.so
+lib/csound/plugins-6.0/libfractalnoise.so
+%%PNG%%lib/csound/plugins-6.0/libimage.so
+lib/csound/plugins-6.0/libipmidi.so
+%%JACK%%lib/csound/plugins-6.0/libjackTransport.so
+%%JACK%%lib/csound/plugins-6.0/libjacko.so
+lib/csound/plugins-6.0/liblinear_algebra.so
+lib/csound/plugins-6.0/libmixer.so
+%%OSC%%lib/csound/plugins-6.0/libosc.so
+lib/csound/plugins-6.0/libplaterev.so
+lib/csound/plugins-6.0/libpy.so
+%%ALSA%%lib/csound/plugins-6.0/librtalsa.so
+%%JACK%%lib/csound/plugins-6.0/librtjack.so
+%%PORTAUDIO%%lib/csound/plugins-6.0/librtpa.so
+%%PULSEAUDIO%%lib/csound/plugins-6.0/librtpulse.so
+lib/csound/plugins-6.0/libscansyn.so
+lib/csound/plugins-6.0/libserial.so
+lib/csound/plugins-6.0/libsignalflowgraph.so
+lib/csound/plugins-6.0/libstdutil.so
+lib/csound/plugins-6.0/libsystem_call.so
+lib/csound/plugins-6.0/liburandom.so
+lib/csound/plugins-6.0/libvirtual.so
+%%FLTK%%lib/csound/plugins-6.0/libwidgets.so
+lib/libCsoundAC.so
+lib/libCsoundAC.so.6
+lib/libCsoundAC.so.6.0
+lib/libcsnd6.so
+lib/libcsnd6.so.6
+lib/libcsnd6.so.6.0
+lib/libcsound64.so
+lib/libcsound64.so.6
+lib/libcsound64.so.6.0
+%%LUA%%lib/luaCsnd6.so
+%%LUA%%lib/luaCsoundAC.so
+%%PYTHON_SITELIBDIR%%/CsoundAC.py
+%%PYTHON_SITELIBDIR%%/_CsoundAC.so
+%%PYTHON_SITELIBDIR%%/_csnd6.so
+%%PYTHON_SITELIBDIR%%/csnd6.py
+%%NLS%%share/locale/de/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/en_US/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/es_CO/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/it/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/csound6.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/csound6.mo
+%%NLS%%@dirrmtry share/locale/es_CO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_CO
+%%NLS%%@dirrmtry share/locale/en_US/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/en_US
+@dirrm lib/csound/plugins-6.0
+@dirrm lib/csound
+@dirrm include/csound