aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-12 01:58:05 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-12 01:58:05 +0000
commitd5001a3969ade0c6f87cbc082c1493ea0bc836cf (patch)
tree9f6de289cfc2604799a880ced4b5f59bef5d08c8 /audio/csound
parentdbbf489035234e65894a3ceb2dc1c4bc337d2b50 (diff)
downloadports-d5001a3969ade0c6f87cbc082c1493ea0bc836cf.tar.gz
ports-d5001a3969ade0c6f87cbc082c1493ea0bc836cf.zip
Notes
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile58
-rw-r--r--audio/csound/distinfo2
-rw-r--r--audio/csound/files/patch-Makefile86
-rw-r--r--audio/csound/files/patch-getstring_c49
-rw-r--r--audio/csound/files/patch-main_c13
-rw-r--r--audio/csound/files/patch-midirecv_c11
-rw-r--r--audio/csound/pkg-comment1
-rw-r--r--audio/csound/pkg-descr24
8 files changed, 244 insertions, 0 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
new file mode 100644
index 000000000000..c2ee9580ba7f
--- /dev/null
+++ b/audio/csound/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: csound
+# Date created: 2000-10-11
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= csound
+PORTVERSION= 4.08
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.maths.bath.ac.uk/pub/dream/newest/
+DISTFILES= Csound.tar.gz
+.if !defined(NOPORTDOCS)
+DISTFILES+= Version${PORTVERSION:S/./_/}.Notes
+.endif
+DIST_SUBDIR= csound
+EXTRACT_ONLY= Csound.tar.gz
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
+ tk83:${PORTSDIR}/x11-toolkits/tk83
+
+RESTRICTED= "no redistribution; no commercial use except to make music (see http://mitpress.mit.edu/e-books/csound/fpage/FAQml/faq/faq.html#THE CSOUND COPYRIGHT ISSUES)"
+
+MAKE_ENV= CPPFLAGS="-I${PREFIX}/include" \
+ LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
+NO_WRKSUBDIR= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ ${RM} -f ${PLIST}
+.for i in bin/csound share/csound/csound.dat
+ ${ECHO} ${i} >> ${PLIST}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${ECHO} share/doc/csound/Version${PORTVERSION:S/./_/}.Notes >> ${PLIST}
+ ${ECHO} "@dirrm share/doc/csound" >> ${PLIST}
+.endif
+ ${ECHO} "@dirrm share/csound" >> ${PLIST}
+
+post-patch:
+ ${PERL} -pi -e "s:PREFIX:${PREFIX}:g" ${WRKSRC}/getstring.c
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/csound
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/csound
+ ${INSTALL_DATA} ${_DISTDIR}/Version${PORTVERSION:S/./_/}.Notes \
+ ${PREFIX}/share/doc/csound
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/csound ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/csound.txt ${PREFIX}/share/csound/csound.dat
+
+post-clean:
+ ${RM} -f ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
new file mode 100644
index 000000000000..455ec939b55f
--- /dev/null
+++ b/audio/csound/distinfo
@@ -0,0 +1,2 @@
+MD5 (csound/Csound.tar.gz) = 79995aa525d2b3ce6c21d148de5a660a
+MD5 (csound/Version4_08.Notes) = 8d60c60237f2142f28ce5304ee7bd81a
diff --git a/audio/csound/files/patch-Makefile b/audio/csound/files/patch-Makefile
new file mode 100644
index 000000000000..162ae80e8285
--- /dev/null
+++ b/audio/csound/files/patch-Makefile
@@ -0,0 +1,86 @@
+--- Makefile.orig Wed Sep 20 09:29:02 2000
++++ Makefile Wed Oct 11 18:17:37 2000
+@@ -1,17 +1,17 @@
+ # Csound Makefile
+ # edit the following definitions according to need:
+
+-INCLUDE = /usr/local/include
+-LIB = /usr/local/lib
+-DEST = /usr/local/bin
+-MAN = /usr/local/man
++INCLUDE = $(PREFIX)/include
++LIB = $(PREFIX)/lib
++DEST = $(PREFIX)/bin
++MAN = $(PREFIX)/man
+ MAN1 = $(MAN)/man1
+ CAT1 = $(MAN)/cat1
+ # these directories must exist for stages beyond 'make csound'
+
+ CDEP =
+ COBS = $(COBJS)
+-CC = cc
++CC ?= cc
+ # choose either -
+ # CDEP = for UNIX
+ # COBS = $(COBJS)
+@@ -23,7 +23,7 @@
+ # .c.o:
+ # $(CC) $(CFLAGS) -c $*.c -o $@
+
+-DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DSGI -DPIPES -DMACROS
++DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DPIPES -DMACROS -DLINUX -DFREE_BSD
+ # choose any of -
+ # -DSYS5 invoke System 5 headers (e.g. 'string.h' for 'strings.h')
+ # -DWINDOWS include window system calls (X11, SGI, or FG graphics)
+@@ -53,7 +53,7 @@
+ # Be sure to include 'LINUXaudio.o' under 'AUDOBJ' below as well.
+ # -- Jonathan Mohr 1995 Oct 17
+
+-CFLAGS = -O2 $(DEFINES)
++CFLAGS += $(CPPFLAGS) $(DEFINES) $(LDFLAGS)
+ # -O Simple optimisation
+ # -O2 to be more specific about the optimization level
+ # -f compile single-precision floats (4.3,VAX,DEC-RISC)
+@@ -74,7 +74,7 @@
+ # -I/usr/openwin/include Solaris openwin interface
+ # -I/usr/demo/SOUND/include Solaris sound interface
+
+-LIBS = -lX11 -laudio -lm
++LIBS = -lX11 -lXt -laudio -lm -ltcl83 -ltk83
+ # -lefence
+ # -lm required
+ # -lX11 for X window calls
+@@ -99,8 +99,9 @@
+ # winfg.o for PC Flash Graphics
+
+
+-AUDSRC = rtSGI.c SGIplay.c
+-AUDOBJ = rtSGI.o SGIplay.o
++AUDSRC = rtlinux.c LINUXaudio.c
++AUDOBJ = rtlinux.o LINUXaudio.o
++
+ # ;if RTAUDIO enabled in DEFINES, include one of
+ # rtaudio.o general interface to audio handlers & libraries
+ # rtDEC.c rtSGI.c rtHP.c rtSUN.c
+@@ -235,7 +236,7 @@
+ all: $(PROGS) $(SUBDIRS) #must be run in this order
+
+ csound: $(COBJS) $(CSUM) $(CDEP) csound.txt
+- $(CC) $(CFLAGS) -o csound $(COBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o csound $(COBJS) $(LIBS)
+
+ TAGS: $(CSRCS) $(HDRS)
+ etags $(CSRCS) $(HDRS)
+@@ -261,10 +262,10 @@
+ $(CC) -o makedb makedb.c
+
+ entry.o:
+- $(CC) -Wf,-XNp8000 $(CFLAGS) -c entry.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c entry.c
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $*.c
+
+ ADSYNS = hetro #targets in anal/adsyn
+ LPCS = lpanal #targets in anal/lpc
diff --git a/audio/csound/files/patch-getstring_c b/audio/csound/files/patch-getstring_c
new file mode 100644
index 000000000000..ae1e6e6ec8b7
--- /dev/null
+++ b/audio/csound/files/patch-getstring_c
@@ -0,0 +1,49 @@
+--- getstring.c.orig Sat May 13 15:52:27 2000
++++ getstring.c Wed Oct 11 18:21:07 2000
+@@ -75,37 +75,37 @@
+ #endif
+ if (db==NULL)
+ {
+- strcpy(name, "csound.txt");
+- db = fopen("csound.txt", "rb");
++ strcpy(name, "csound.dat");
++ db = fopen("csound.dat", "rb");
+ }
+ if (db == NULL && argv[0] != NULL) {
+ strcpy(name, argv[0]);
+ if ((path = strrchr(name, '/')) != NULL
+ || (path = strrchr(name, '\\')) != NULL) {
+- strcpy(path+1, "csound.txt");
++ strcpy(path+1, "csound.dat");
+ db = fopen(name, "rb");
+ }
+ }
+ if (db == NULL && (path=getenv("SSDIR")) != NULL) {
+- sprintf(name, "%s/csound.txt", path);
++ sprintf(name, "%s/csound.dat", path);
+ db = fopen(name, "rb");
+ }
+ if (db == NULL && (path=getenv("SFDIR")) != NULL) {
+- sprintf(name, "%s/csound.txt", path);
++ sprintf(name, "%s/csound.dat", path);
+ db = fopen(name, "rb");
+ }
+ if (db == NULL && (path=getenv("SADIR")) != NULL) {
+- sprintf(name, "%s/csound.txt", path);
++ sprintf(name, "%s/csound.dat", path);
+ db = fopen(name, "rb");
+ }
+ if (db == NULL) {
+- strcpy(name, "/usr/local/lib/csound.txt");
+- db = fopen("/usr/local/lib/csound.txt", "rb");
++ strcpy(name, "PREFIX/share/csound/csound.dat");
++ db = fopen("PREFIX/share/csound/csound.dat", "rb");
+ }
+ if (db == NULL) {
+ fprintf(stderr, "failed to find Strings DataBase file.\n"
+ "Use the CSSTRNGS environment variable or you must put the \n"
+- "file \"csound.txt\" in your local, SFDIR, SADIR, SSDIR or \n"
++ "file \"csound.dat\" in your local, SFDIR, SADIR, SSDIR or \n"
+ "system directories for csound to work\n");
+ exit(1);
+ }
diff --git a/audio/csound/files/patch-main_c b/audio/csound/files/patch-main_c
new file mode 100644
index 000000000000..e9790315f4e1
--- /dev/null
+++ b/audio/csound/files/patch-main_c
@@ -0,0 +1,13 @@
+--- main.c.orig Wed Sep 20 10:06:29 2000
++++ main.c Wed Oct 11 16:16:56 2000
+@@ -150,10 +150,6 @@
+ }
+ }
+
+-void psignal(int sig, char *str)
+-{
+- fprintf(stderr, "%s: %s\n", str, sig2str(sig));
+-}
+ #endif
+
+ static void signal_handler(int sig)
diff --git a/audio/csound/files/patch-midirecv_c b/audio/csound/files/patch-midirecv_c
new file mode 100644
index 000000000000..0ebee1e959d4
--- /dev/null
+++ b/audio/csound/files/patch-midirecv_c
@@ -0,0 +1,11 @@
+--- midirecv.c.orig Fri Aug 18 19:09:11 2000
++++ midirecv.c Wed Oct 11 16:00:18 2000
+@@ -3,6 +3,8 @@
+ #include "midiops.h"
+ #include "oload.h"
+
++#include <sys/ioctl_compat.h>
++#undef SGI
+ #ifdef SGI
+ # include <sys/termio.h>
+ # include <sys/stropts.h>
diff --git a/audio/csound/pkg-comment b/audio/csound/pkg-comment
new file mode 100644
index 000000000000..6ef5c847a157
--- /dev/null
+++ b/audio/csound/pkg-comment
@@ -0,0 +1 @@
+Sound synthesizer
diff --git a/audio/csound/pkg-descr b/audio/csound/pkg-descr
new file mode 100644
index 000000000000..6928b966e007
--- /dev/null
+++ b/audio/csound/pkg-descr
@@ -0,0 +1,24 @@
+from Martin Dupras' FAQ:
+ Csound is a software synthesis package in the tradition of so-called
+music-N languages, among which the best-known is Music V. It consists of an
+orchestra- and score-driven executable, written in C for portability. Since
+Csound is a computational language, it is highly flexible and efficient;
+complexity is gained only at the expense of computation time. Basically Csound
+reads some files and creates the result as a file on disk or, on faster
+machines, through a DAC in real time.
+ Csound needs at least two files to read from: the score, which is a
+kind of event list for scheduling events, and an orchestra which defines how
+Csound will synthesize those events. An orchestra is composed of instruments,
+which are basically processes triggered by the notes (events) in the score.
+
+WWW: http://mitpress.mit.edu/e-books/csound/frontpage.html
+ http://mitpress.mit.edu/e-books/csound/fpage/FAQml/faq/faq.html
+ http://music.dartmouth.edu/~dupras/wCsound/Csound.faq.html
+ http://music.dartmouth.edu/~dupras/wCsound/csoundpage.html
+ http://csounds.com/faq/index.html
+ http://csounds.com/ezine/
+ http://arcana.dartmouth.edu/~eric/
+ http://www.werewolf.net/~hljmm/csound/articles/intro.html
+ ftp://ftp.maths.bath.ac.uk/pub/dream/documentation/
+
+Trevor Johnson <trevor@FreeBSD.org>