aboutsummaryrefslogtreecommitdiff
path: root/audio/cuberok
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-13 06:05:30 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-13 06:05:30 +0000
commitcaa20fc5a099e5a21b2b6663ecd49fda1bbbe8cf (patch)
treefe47e629c25aba8446b74523a417022bb448b85b /audio/cuberok
parent77a00d143150f2ffdbf28be5b48afe1ba1d71237 (diff)
Notes
Diffstat (limited to 'audio/cuberok')
-rw-r--r--audio/cuberok/Makefile41
-rw-r--r--audio/cuberok/distinfo3
-rw-r--r--audio/cuberok/files/patch-src-player_ffmpeg.h13
-rw-r--r--audio/cuberok/pkg-descr21
-rw-r--r--audio/cuberok/pkg-plist13
5 files changed, 91 insertions, 0 deletions
diff --git a/audio/cuberok/Makefile b/audio/cuberok/Makefile
new file mode 100644
index 000000000000..f4dfaede0289
--- /dev/null
+++ b/audio/cuberok/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: cuberok
+# Date created: 2010-05-09
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuberok
+PORTVERSION= 0.0.11
+CATEGORIES= audio
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= A music player and a collection manager based on Qt4
+
+BUILD_DEPENDS= audiere-config:${PORTSDIR}/audio/audiere \
+ ${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
+LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ avformat.1:${PORTSDIR}/multimedia/ffmpeg \
+ avutil.1:${PORTSDIR}/multimedia/ffmpeg \
+ tag.1:${PORTSDIR}/audio/taglib
+
+USE_QT_VER= 4
+USE_LDCONFIG= yes
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build \
+ network phonon-gst sql
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_SDL= sdl
+QMAKEFLAGS+= "CONFIG+=player_phonon"
+MAKE_ENV+= INSTALL_ROOT=${PREFIX}
+QMAKEPRO= Cuberok.pro
+
+do-configure:
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e 's/lib64/lib/g' \
+ plugins/plugins_path-x86*
+
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
+
+.include <bsd.port.mk>
diff --git a/audio/cuberok/distinfo b/audio/cuberok/distinfo
new file mode 100644
index 000000000000..f2436731e02b
--- /dev/null
+++ b/audio/cuberok/distinfo
@@ -0,0 +1,3 @@
+MD5 (cuberok-0.0.11.tar.gz) = 0b09935acbf8e94645680b5a51081820
+SHA256 (cuberok-0.0.11.tar.gz) = 33f4e4c9dbc3b4ede506ce58363d19a2fe9481d7bb3d64858c3ab28bc5039bad
+SIZE (cuberok-0.0.11.tar.gz) = 492013
diff --git a/audio/cuberok/files/patch-src-player_ffmpeg.h b/audio/cuberok/files/patch-src-player_ffmpeg.h
new file mode 100644
index 000000000000..6443831faeac
--- /dev/null
+++ b/audio/cuberok/files/patch-src-player_ffmpeg.h
@@ -0,0 +1,13 @@
+--- src/player_ffmpeg.h.orig 2009-07-10 14:14:03.000000000 +0800
++++ src/player_ffmpeg.h 2010-05-10 21:49:51.000000000 +0800
+@@ -27,8 +27,8 @@
+ #include <libavcodec/avcodec.h>
+ #include <libavformat/avformat.h>
+ #else
+-#include <avcodec.h>
+-#include <avformat.h>
++#include <ffmpeg/avcodec.h>
++#include <ffmpeg/avformat.h>
+ #endif
+ }
+
diff --git a/audio/cuberok/pkg-descr b/audio/cuberok/pkg-descr
new file mode 100644
index 000000000000..c6c476dd9f08
--- /dev/null
+++ b/audio/cuberok/pkg-descr
@@ -0,0 +1,21 @@
+Cuberok is a music player and a collection manager based on Qt4. It has
+lightweight interface, music collection support and many features, e.g.
+music autorating and Last.FM scrobbler.
+
+Features:
+-CUE support. Codepage selection for CUE sheets
+-Shoutcast/icecast support (for GStreamer and Phonon)
+-Support internet services Jamendo and MagnaTune (New in v.0.0.9)
+-Last.FM and Libre.FM scrobblers
+-Downloading images for albums and artists from Last.FM
+-Loading artist and album info from Last.FM, loading lyrics from LyricWiki.org
+-Auto rating for songs. Rating for albums, artists and genres automatically
+calculated from rating of songs.
+-Easy collection browsing. Just double click on genre to view all artist in
+this genre.
+-Smart playlists (custom SQL requests)
+-Support for AlbumArt as separate file on disk. Art can be assinged to genre
+and atrist too.
+-And etc...
+
+WWW: http://code.google.com/p/cuberok/
diff --git a/audio/cuberok/pkg-plist b/audio/cuberok/pkg-plist
new file mode 100644
index 000000000000..aa6d5440e55d
--- /dev/null
+++ b/audio/cuberok/pkg-plist
@@ -0,0 +1,13 @@
+bin/cuberok
+lib/cuberok/libcuberok_style.so
+lib/cuberok/libplayer_ffmpeg.so
+lib/cuberok/libplayer_gst.so
+lib/cuberok/libplayer_phonon.so
+lib/cuberok/libplayer_audiere.so
+share/applications/cuberok.desktop
+%%DATADIR%%/locale/cuberok_ru.qm
+share/pixmaps/cuberok.xpm
+@dirrm share/cuberok/locale
+@dirrm share/cuberok
+@dirrm lib/cuberok
+@dirrmtry share/applications