aboutsummaryrefslogtreecommitdiff
path: root/audio/cuetools
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-10-25 01:55:19 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-10-25 01:55:19 +0000
commitfc438b947f6f5955e0cd56f894d2b3b15d29e9e0 (patch)
tree1d5e401b544bb47adebeb955d82cf12eaa56b743 /audio/cuetools
parent253f7da96265be97161cf3d18b99eea68ebb53c1 (diff)
downloadports-fc438b947f6f5955e0cd56f894d2b3b15d29e9e0.tar.gz
ports-fc438b947f6f5955e0cd56f894d2b3b15d29e9e0.zip
Notes
Diffstat (limited to 'audio/cuetools')
-rw-r--r--audio/cuetools/Makefile2
-rw-r--r--audio/cuetools/files/patch-extras_cuetag.sh48
2 files changed, 47 insertions, 3 deletions
diff --git a/audio/cuetools/Makefile b/audio/cuetools/Makefile
index 2b3a00f8861d..2f357d65f696 100644
--- a/audio/cuetools/Makefile
+++ b/audio/cuetools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cuetools
PORTVERSION= 1.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://download.berlios.de/cuetools/
diff --git a/audio/cuetools/files/patch-extras_cuetag.sh b/audio/cuetools/files/patch-extras_cuetag.sh
index 65456bec62da..4540f54ecd36 100644
--- a/audio/cuetools/files/patch-extras_cuetag.sh
+++ b/audio/cuetools/files/patch-extras_cuetag.sh
@@ -1,5 +1,5 @@
---- extras/cuetag.sh.orig 2008-11-28 00:41:26.000000000 +0300
-+++ extras/cuetag.sh 2008-11-28 00:41:32.000000000 +0300
+--- extras/cuetag.sh.orig 2006-02-14 19:10:02.000000000 -0500
++++ extras/cuetag.sh 2010-10-24 03:20:01.349578391 -0400
@@ -18,7 +18,7 @@
{
# FLAC tagging
@@ -9,3 +9,47 @@
# Ogg Vorbis tagging
# -w overwrites existing comments
+@@ -63,7 +63,7 @@
+ (for field in $fields; do
+ value=""
+ for conv in `eval echo \\$$field`; do
+- value=`$CUEPRINT -n $1 -t "$conv\n" $cue_file`
++ value=`$CUEPRINT -n $1 -t "$conv\n" "$cue_file"`
+
+ if [ -n "$value" ]; then
+ echo "$field=$value"
+@@ -96,7 +96,7 @@
+ for field in $fields; do
+ value=""
+ for conv in `eval echo \\$$field`; do
+- value=`$CUEPRINT -n $1 -t "$conv\n" $cue_file`
++ value=`$CUEPRINT -n $1 -t "$conv\n" "$cue_file"`
+
+ if [ -n "$value" ]; then
+ break
+@@ -141,14 +141,14 @@
+ cue_file=$1
+ shift
+
+- ntrack=`cueprint -d '%N' $cue_file`
++ ntrack=`cueprint -d '%N' "$cue_file"`
+ trackno=1
+
+ if [ $# -ne $ntrack ]; then
+ echo "warning: number of files does not match number of tracks"
+ fi
+
+- for file in $@; do
++ for file in "$@"; do
+ case $file in
+ *.[Ff][Ll][Aa][Cc])
+ vorbis $trackno "$file"
+@@ -160,7 +160,7 @@
+ id3 $trackno "$file"
+ ;;
+ *)
+- echo "$file: uknown file type"
++ echo "$file: unknown file type"
+ ;;
+ esac
+ trackno=$(($trackno + 1))