aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:39:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:39:57 +0000
commit99019b3299a2d411091d38e3680dc57b808d7bfb (patch)
treed778b6671089b76f7e56723d8bf544c156e1a7ab /audio/denemo/Makefile
parent232ac32ead8f5bad0967a522cb0fd1fa45f3c291 (diff)
downloadports-99019b3299a2d411091d38e3680dc57b808d7bfb.tar.gz
ports-99019b3299a2d411091d38e3680dc57b808d7bfb.zip
Notes
Diffstat (limited to 'audio/denemo/Makefile')
-rw-r--r--audio/denemo/Makefile60
1 files changed, 28 insertions, 32 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index dac4b2e13bb6..43e844752811 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= denemo
-PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTVERSION= 0.9.6
CATEGORIES= audio
MASTER_SITES= GNU
@@ -11,53 +10,50 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Graphical score editor
BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
-LIB_DEPENDS= aubio.3:${PORTSDIR}/audio/aubio \
- fluidsynth.1:${PORTSDIR}/audio/fluidsynth \
- jack.0:${PORTSDIR}/audio/jack \
- guile.21:${PORTSDIR}/lang/guile \
- fftw3:${PORTSDIR}/math/fftw3 \
- smf.0:${PORTSDIR}/audio/libsmf
+LIB_DEPENDS= aubio:${PORTSDIR}/audio/aubio \
+ fluidsynth:${PORTSDIR}/audio/fluidsynth \
+ jack:${PORTSDIR}/audio/jack \
+ smf:${PORTSDIR}/audio/libsmf \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ evview:${PORTSDIR}/graphics/evince \
+ guile:${PORTSDIR}/lang/guile \
+ fftw3:${PORTSDIR}/math/fftw3
RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
-OPTIONS+= LILYPOND "Install LilyPond (Printing)" off
+LICENSE= GPLv3
+
+OPTIONS_DEFINE= LILYPOND DOCS EXAMPLES
+LILYPOND_DESC= Install LilyPond (Printing)
USE_GNOME= gtk20 gtksourceview2 librsvg2 libxml2
USE_BISON= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-jack \
+ --disable-portmidi \
--sysconfdir=${PREFIX}/etc
+MAKE_JOBS_SAFE= yes
-PORTDOCS= *
-PORTEXAMPLES= *
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 \
+ -I${LOCALBASE}/include
+LDFLAGS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so \
+ -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-.if defined(WITH_LILYPOND)
+.if ${PORT_OPTIONS:MLILYPOND}
RUN_DEPENDS+= lilypond:${PORTSDIR}/print/lilypond
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|m4 doc actions|m4 actions| ; \
- s|examples templates|templates|' \
- -e "/\/examples/d" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/<malloc.h>/d' ${WRKSRC}/ltmain.sh
+ @${REINPLACE_CMD} -e \
+ 's|evince-view-2.30|evince-view-2.32|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|doc|| ; \
+ /\/examples/d' ${WRKSRC}/Makefile.in
post-install:
@${LN} -sf ${DOCSDIR}/manual ${DATADIR}/manual
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in AUTHORS ChangeLog NEWS README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@@ -70,9 +66,9 @@ post-install:
@${MKDIR} ${DOCSDIR}/manual/images
${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}/manual/images
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.denemo ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>