aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-01-10 04:12:16 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-01-10 04:12:16 +0000
commit04639a04b029ca0a3f2e5d984b90d73ab64fefe1 (patch)
treef0881edb8a4fb99fe18dc6b1b966cda6c9e6d407 /audio/denemo
parent9057b2f8ed18987f024f734c2a7b3610448a84ab (diff)
downloadports-04639a04b029ca0a3f2e5d984b90d73ab64fefe1.tar.gz
ports-04639a04b029ca0a3f2e5d984b90d73ab64fefe1.zip
Notes
Diffstat (limited to 'audio/denemo')
-rw-r--r--audio/denemo/Makefile6
-rw-r--r--audio/denemo/distinfo2
-rw-r--r--audio/denemo/files/patch-playback.c19
3 files changed, 14 insertions, 13 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 2ec3c4aa52ed..81aa6663bf5d 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= denemo
-PORTVERSION= 0.5.5
+PORTVERSION= 0.5.8
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= trevor@FreeBSD.org
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- intl.1:${PORTSDIR}/devel/gettext
+ intl.1:${PORTSDIR}/devel/gettext \
+ xml.5:${PORTSDIR}/textproc/libxml
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
@@ -26,6 +27,7 @@ USE_X_PREFIX= yes
post-configure:
${PERL} -pi -e "s:module12:module12 -lgnugetopt:g" ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s:<wait.h:<sys/wait.h:g" ${WRKSRC}/*.c
pre-install:
${ECHO} bin/${PORTNAME} > ${PLIST}
diff --git a/audio/denemo/distinfo b/audio/denemo/distinfo
index 8e5c39cc7525..cbbeccb9a235 100644
--- a/audio/denemo/distinfo
+++ b/audio/denemo/distinfo
@@ -1 +1 @@
-MD5 (denemo-0.5.5.tar.gz) = a3289c6fbebc9179d16f9c9f617f4b27
+MD5 (denemo-0.5.8.tar.gz) = f7b4f53f5f27c2d1e74f5eeb43042e9e
diff --git a/audio/denemo/files/patch-playback.c b/audio/denemo/files/patch-playback.c
index 3a02a73334cf..1675df8cbc59 100644
--- a/audio/denemo/files/patch-playback.c
+++ b/audio/denemo/files/patch-playback.c
@@ -1,11 +1,10 @@
---- playback.c.orig Tue Jun 27 22:13:08 2000
-+++ playback.c Sat Feb 10 19:34:55 2001
-@@ -18,7 +18,7 @@
- #include <stdlib.h>
- #include <unistd.h>
- #include <sys/types.h>
--#include <wait.h>
-+#include <sys/wait.h>
- #include <errno.h>
+--- playback.c.old Wed Nov 14 11:13:02 2001
++++ playback.c Wed Jan 9 19:38:16 2002
+@@ -7,6 +7,7 @@
- extern char **environ; /* I don't know why this is here. Hiller 19 Apr 2000 */
+
+ #include "datastructures.h"
++#include "exportmidi.h"
+ #include "exportmudela.h"
+ #include "staffops.h"
+ #include "scoreops.h"