aboutsummaryrefslogtreecommitdiff
path: root/audio/dream
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-06 18:53:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-06 18:53:34 +0000
commitbe2311de951725e93a0c936fca90dc053840495d (patch)
treeba867c1cdc28e638b558cc55dfc83546d7fe8ecd /audio/dream
parentddd84960c786d13841d6bfc20c4729bb7be4e8ca (diff)
downloadports-be2311de951725e93a0c936fca90dc053840495d.tar.gz
ports-be2311de951725e93a0c936fca90dc053840495d.zip
Notes
Diffstat (limited to 'audio/dream')
-rw-r--r--audio/dream/Makefile38
-rw-r--r--audio/dream/distinfo3
-rw-r--r--audio/dream/files/patch-common_GUI-QT_MultimediaDlg.cpp12
-rw-r--r--audio/dream/files/patch-common_MDI_PacketSocketQT.h11
-rw-r--r--audio/dream/files/patch-linux_source_soundcommon.cpp23
-rw-r--r--audio/dream/pkg-descr5
6 files changed, 0 insertions, 92 deletions
diff --git a/audio/dream/Makefile b/audio/dream/Makefile
deleted file mode 100644
index 8a8cd4774a71..000000000000
--- a/audio/dream/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# New ports collection makefile for: Dream DRM Receiver
-# Date created: 1st september 2006
-# Whom: Soeren Straaarup <xride@x12.dk>
-#
-# $FreeBSD$
-
-PORTNAME= dream
-PORTVERSION= 1.6.25
-PORTREVISION= 4
-CATEGORIES= audio hamradio
-MASTER_SITES= SF/drm
-DISTNAME= drm-${PORTVERSION}
-
-MAINTAINER= xride@FreeBSD.org
-COMMENT= Digital Radio Mondiale (DRM) software receiver
-
-LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
- qwt4.4:${PORTSDIR}/x11-toolkits/qwt4 \
- faad.0:${PORTSDIR}/audio/faad
-
-DEPRECATED= Needs DRM enabled in FAAD
-EXPIRATION_DATE= 2009-01-06
-
-USE_QT_VER= 3
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include \
- ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-
-PLIST_FILES= bin/drm
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/include/qwt|${LOCALBASE}/include/qwt4|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lqwt|-lqwt4|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|neaacdec.h|faad.h|g' ${WRKSRC}/common/sourcedecoders/AudioSourceDecoder.cpp
- @${REINPLACE_CMD} -e 's|DRMCH_SBR_PS_STEREO|DRMCH_SBR_STEREO|g' ${WRKSRC}/common/sourcedecoders/AudioSourceDecoder.cpp
-
-.include <bsd.port.mk>
diff --git a/audio/dream/distinfo b/audio/dream/distinfo
deleted file mode 100644
index c52061479d18..000000000000
--- a/audio/dream/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (drm-1.6.25.tar.gz) = 56d217db9c29a20799f2a340e8a67895
-SHA256 (drm-1.6.25.tar.gz) = def8a4db1eeb4ab46f4fd716ef21d9332d2ff553eff32f099c47779f4687fea6
-SIZE (drm-1.6.25.tar.gz) = 827306
diff --git a/audio/dream/files/patch-common_GUI-QT_MultimediaDlg.cpp b/audio/dream/files/patch-common_GUI-QT_MultimediaDlg.cpp
deleted file mode 100644
index 309e719e93e2..000000000000
--- a/audio/dream/files/patch-common_GUI-QT_MultimediaDlg.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- common/GUI-QT/MultimediaDlg.cpp.orig Wed Sep 6 18:57:47 2006
-+++ common/GUI-QT/MultimediaDlg.cpp Wed Sep 6 18:56:33 2006
-@@ -34,6 +34,9 @@
-
- #include "MultimediaDlg.h"
-
-+int WEXITSTATUS(int ret) {
-+ return ret;
-+}
-
- /* Implementation *************************************************************/
- MultimediaDlg::MultimediaDlg(CDRMReceiver* pNDRMR, QWidget* parent,
diff --git a/audio/dream/files/patch-common_MDI_PacketSocketQT.h b/audio/dream/files/patch-common_MDI_PacketSocketQT.h
deleted file mode 100644
index 2e4a7d1d1b58..000000000000
--- a/audio/dream/files/patch-common_MDI_PacketSocketQT.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- common/MDI/PacketSocketQT.h.orig Wed Sep 6 15:40:23 2006
-+++ common/MDI/PacketSocketQT.h Wed Sep 6 15:40:51 2006
-@@ -41,6 +41,8 @@
- #else
- # include <netinet/in.h>
- # include <arpa/inet.h>
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #endif
-
- /* Some defines needed for compatibility when using Linux */
diff --git a/audio/dream/files/patch-linux_source_soundcommon.cpp b/audio/dream/files/patch-linux_source_soundcommon.cpp
deleted file mode 100644
index 3ae134dc9ebc..000000000000
--- a/audio/dream/files/patch-linux_source_soundcommon.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- linux/source/soundcommon.cpp.orig Wed Sep 13 11:06:20 2006
-+++ linux/source/soundcommon.cpp Wed Sep 13 11:25:45 2006
-@@ -154,9 +154,10 @@
- vector<string> tmp;
- names.clear();
- devices.clear();
-+/*
- ifstream sndstat("/dev/sndstat");
- if(!sndstat.is_open())
-- sndstat.open("/proc/asound/oss/sndstat");
-+ sndstat.open("/dev/sndstat");
- if(sndstat.is_open())
- {
- while(!sndstat.eof())
-@@ -176,6 +177,8 @@
- }
- sndstat.close();
- }
-+*/
-+ tmp.push_back("0");
- /* if there is more than one device, let the user chose */
- if(tmp.size()>1)
- {
diff --git a/audio/dream/pkg-descr b/audio/dream/pkg-descr
deleted file mode 100644
index e74a5bcdd839..000000000000
--- a/audio/dream/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Dream is a software implementation of a Digital Radio Mondiale (DRM) receiver.
-All you need to receive DRM transmissions is a PC with a sound card and a
-modified analog short-wave (MW, LW) receiver.
-
-WWW: http://drm.sourceforge.net/