aboutsummaryrefslogtreecommitdiff
path: root/audio/dsbmixer/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 14:41:44 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 14:41:44 +0000
commit92ee5504dc3ef188a5a335fd2e1291969b1660b1 (patch)
tree036499a3ba68f6da770c2232bbeb8f7a5c906aff /audio/dsbmixer/Makefile
parent9c7743c915cabf5b0c870e5cf6af44207c2be9d7 (diff)
downloadports-92ee5504dc3ef188a5a335fd2e1291969b1660b1.tar.gz
ports-92ee5504dc3ef188a5a335fd2e1291969b1660b1.zip
Notes
Diffstat (limited to 'audio/dsbmixer/Makefile')
-rw-r--r--audio/dsbmixer/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/dsbmixer/Makefile b/audio/dsbmixer/Makefile
new file mode 100644
index 000000000000..7a3ab69f6228
--- /dev/null
+++ b/audio/dsbmixer/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= dsbmixer
+PORTVERSION= 0.2.5
+CATEGORIES= audio
+MASTER_SITES= http://freeshell.de/~mk/download/
+
+MAINTAINER= mk@nic-nac-project.org
+COMMENT= Tabbed GTK+ mixer for FreeBSD
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= dsbwrtsysctl:${PORTSDIR}/sysutils/dsbwrtsysctl
+
+USES= tar:tgz pkgconfig
+USE_GNOME= gtk20
+
+OPTIONS_DEFINE= DEVD NLS
+OPTIONS_DEFAULT=DEVD NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+DEVD_DESC= Add new USB audio devices at runtime
+NLS_MAKE_ARGS_OFF= -DWITHOUT_GETTEXT
+DEVD_MAKE_ARGS_OFF= -DWITHOUT_DEVD
+
+MAKE_ARGS+= INSTALL_BACKEND="${INSTALL_PROGRAM}"
+
+.include <bsd.port.mk>