aboutsummaryrefslogtreecommitdiff
path: root/audio/dssi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-13 21:38:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-13 21:38:30 +0000
commit326bac6d8753bac939ca9f40a1dad49b06ce8065 (patch)
tree3727df3d712451071fdb06f265a954dffdb0b12c /audio/dssi
parentf382c01c4b281518b791b83941e49fd6d5eb8cec (diff)
downloadports-326bac6d8753bac939ca9f40a1dad49b06ce8065.tar.gz
ports-326bac6d8753bac939ca9f40a1dad49b06ce8065.zip
Notes
Diffstat (limited to 'audio/dssi')
-rw-r--r--audio/dssi/Makefile37
-rw-r--r--audio/dssi/distinfo3
-rw-r--r--audio/dssi/pkg-descr17
-rw-r--r--audio/dssi/pkg-plist20
4 files changed, 77 insertions, 0 deletions
diff --git a/audio/dssi/Makefile b/audio/dssi/Makefile
new file mode 100644
index 000000000000..acb872db8499
--- /dev/null
+++ b/audio/dssi/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: dssi
+# Date created: 2007-01-12
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dssi
+PORTVERSION= 0.9.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dssi
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= API for audio processing plugins
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+
+.if defined(WITH_QT)
+USE_QT_VER= 3
+PLIST_SUB= WITH_QT=""
+.else
+PLIST_SUB= WITH_QT="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/dssi/distinfo b/audio/dssi/distinfo
new file mode 100644
index 000000000000..8d38d976a440
--- /dev/null
+++ b/audio/dssi/distinfo
@@ -0,0 +1,3 @@
+MD5 (dssi-0.9.1.tar.gz) = 1a353c3ae80328cded838853ddf52164
+SHA256 (dssi-0.9.1.tar.gz) = 87ec77de27992bf4710dae8efaaefde1c9bd4ccd2ebe3a56e589587cdef0e851
+SIZE (dssi-0.9.1.tar.gz) = 390757
diff --git a/audio/dssi/pkg-descr b/audio/dssi/pkg-descr
new file mode 100644
index 000000000000..b80e5f869396
--- /dev/null
+++ b/audio/dssi/pkg-descr
@@ -0,0 +1,17 @@
+DSSI (pronounced "dizzy") is an API for audio processing plugins,
+particularly useful for software synthesis plugins with user
+interfaces.
+
+DSSI is an open and well-documented specification developed for use
+in Linux audio applications, although portable to other platforms.
+It may be thought of as LADSPA-for-instruments, or something
+comparable to VSTi.
+
+DSSI consists of a C language API for use by plugins and hosts,
+based on the LADSPA API, and an OSC (Open Sound Control) API for
+use in user interface to host communications. The DSSI specification
+consists of an RFC which describes the background for the proposal
+and defines the OSC part of the specification, and a documented
+header file which defines the C API.
+
+WWW: http://dssi.sourceforge.net/
diff --git a/audio/dssi/pkg-plist b/audio/dssi/pkg-plist
new file mode 100644
index 000000000000..fa5c77bec442
--- /dev/null
+++ b/audio/dssi/pkg-plist
@@ -0,0 +1,20 @@
+bin/jack-dssi-host
+bin/dssi_osc_send
+bin/dssi_osc_update
+bin/trivial_synth
+bin/less_trivial_synth
+bin/trivial_sampler
+include/dssi.h
+lib/dssi/trivial_synth.so
+lib/dssi/trivial_synth.la
+lib/dssi/less_trivial_synth.so
+lib/dssi/less_trivial_synth.la
+%%WITH_QT%%lib/dssi/less_trivial_synth/LTS_qt
+lib/dssi/trivial_sampler.so
+lib/dssi/trivial_sampler.la
+%%WITH_QT%%lib/dssi/trivial_sampler/trivial_sampler_qt
+libdata/pkgconfig/dssi.pc
+@dirrm libdata/pkgconfig
+@dirrm lib/dssi/trivial_sampler
+@dirrm lib/dssi/less_trivial_synth
+@dirrm lib/dssi