aboutsummaryrefslogtreecommitdiff
path: root/audio/dtmfdial
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-31 02:53:24 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-31 02:53:24 +0000
commit143b70acd847db82357385b48e5b796034942485 (patch)
tree555a9088481b17cb0c36a0cbfcdea55d193bd4f9 /audio/dtmfdial
parent0dd31003fd42730b58cc596537b7bbee1d70b9f0 (diff)
downloadports-143b70acd847db82357385b48e5b796034942485.tar.gz
ports-143b70acd847db82357385b48e5b796034942485.zip
Notes
Diffstat (limited to 'audio/dtmfdial')
-rw-r--r--audio/dtmfdial/Makefile29
-rw-r--r--audio/dtmfdial/distinfo3
-rw-r--r--audio/dtmfdial/files/patch-dial.c24
-rw-r--r--audio/dtmfdial/pkg-descr2
-rw-r--r--audio/dtmfdial/pkg-plist1
5 files changed, 59 insertions, 0 deletions
diff --git a/audio/dtmfdial/Makefile b/audio/dtmfdial/Makefile
new file mode 100644
index 000000000000..dfbfd64b8a19
--- /dev/null
+++ b/audio/dtmfdial/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dtmfdial
+# Date created: 26 March 2006
+# Whom: David Bushong <david@bushong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtmfdial
+PORTVERSION= 0.2
+CATEGORIES= audio comms
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/misc
+DISTNAME= dtmf-dial-${PORTVERSION}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Generate DTMF dial tones from the command line
+
+WRKSRC= ${WRKDIR}/dial
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+PORTDOCS= README TODO
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dial ${PREFIX}/bin/dtmfdial
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/dtmfdial/distinfo b/audio/dtmfdial/distinfo
new file mode 100644
index 000000000000..0d4d5ba506f8
--- /dev/null
+++ b/audio/dtmfdial/distinfo
@@ -0,0 +1,3 @@
+MD5 (dtmf-dial-0.2.tar.gz) = 7e67715b6a114f612f71477b7144aa7f
+SHA256 (dtmf-dial-0.2.tar.gz) = 4714878832bfeaa387d57eb5cb52c9c2816c460023198c98cb714f8ef2414c27
+SIZE (dtmf-dial-0.2.tar.gz) = 4136
diff --git a/audio/dtmfdial/files/patch-dial.c b/audio/dtmfdial/files/patch-dial.c
new file mode 100644
index 000000000000..4530d6a3327c
--- /dev/null
+++ b/audio/dtmfdial/files/patch-dial.c
@@ -0,0 +1,24 @@
+--- dial.c.orig Fri Mar 31 04:44:07 2006
++++ dial.c Fri Mar 31 04:44:23 2006
+@@ -7,10 +7,10 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+
+ #define DEBUG(x)
+
+@@ -130,7 +130,7 @@
+ ++*index;
+ }
+
+-void
++int
+ main(int argc, char **argv)
+ {
+ char *cp;
diff --git a/audio/dtmfdial/pkg-descr b/audio/dtmfdial/pkg-descr
new file mode 100644
index 000000000000..9431b33e9be6
--- /dev/null
+++ b/audio/dtmfdial/pkg-descr
@@ -0,0 +1,2 @@
+dtmfdial generates DTMF (touch tone) signals and sends them to the sound card
+or stores them as a raw sound file.
diff --git a/audio/dtmfdial/pkg-plist b/audio/dtmfdial/pkg-plist
new file mode 100644
index 000000000000..965eadb5f74f
--- /dev/null
+++ b/audio/dtmfdial/pkg-plist
@@ -0,0 +1 @@
+bin/dtmfdial