aboutsummaryrefslogtreecommitdiff
path: root/audio/dvda-author
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-20 20:03:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-20 20:03:42 +0000
commit87cc77474c2e1a24e7400610d16b4ebb2167ed38 (patch)
tree3463a1dfe7a0bb7d73064367691a936748ed5bba /audio/dvda-author
parentcfa0759ee12a182a65c1dba3ff284e81e40d1ecb (diff)
downloadports-87cc77474c2e1a24e7400610d16b4ebb2167ed38.tar.gz
ports-87cc77474c2e1a24e7400610d16b4ebb2167ed38.zip
Notes
Diffstat (limited to 'audio/dvda-author')
-rw-r--r--audio/dvda-author/Makefile13
-rw-r--r--audio/dvda-author/files/patch-libsoxconvert.c11
2 files changed, 16 insertions, 8 deletions
diff --git a/audio/dvda-author/Makefile b/audio/dvda-author/Makefile
index 7e645403888d..e2ae39b27d10 100644
--- a/audio/dvda-author/Makefile
+++ b/audio/dvda-author/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvda-author
PORTVERSION= 09.05
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF/dvd-audio/${PORTNAME}-core/${PORTNAME}-${PORTVERSION}-core
@@ -22,24 +22,21 @@ LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
png.5:${PORTSDIR}/graphics/png
-BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/gnulibiberty
-
MAN1= dvda-author.1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/FLAC
-USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= libltdl
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-flac=${LOCALBASE}/lib/libFLAC.so \
--with-ogg=${LOCALBASE}/lib/libogg.so \
--enable-glibc
.if defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${WRKDIR}/doc
+CONFIGURE_ARGS+= --docdir=${WRKDIR}/doc
.endif
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
.include <bsd.port.mk>
diff --git a/audio/dvda-author/files/patch-libsoxconvert.c b/audio/dvda-author/files/patch-libsoxconvert.c
new file mode 100644
index 000000000000..17cc5fdf2dc8
--- /dev/null
+++ b/audio/dvda-author/files/patch-libsoxconvert.c
@@ -0,0 +1,11 @@
+--- libsoxconvert/src/libsoxconvert.c.orig 2009-06-03 22:35:58.000000000 +0200
++++ libsoxconvert/src/libsoxconvert.c 2009-09-20 21:38:42.000000000 +0200
+@@ -83,7 +83,7 @@
+ assert(sox_add_effect(chain, e, &in->signal, &in->signal) == SOX_SUCCESS);
+
+ /* Flow samples through the effects processing chain until EOF is reached */
+- sox_flow_effects(chain, NULL);
++ sox_flow_effects(chain, NULL, NULL);
+
+ foutput("%s\n", "[INF] Exiting SoX...");
+ /* All done; tidy up: */