aboutsummaryrefslogtreecommitdiff
path: root/audio/ecasound
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2006-01-31 16:11:45 +0000
committerSimon Barner <barner@FreeBSD.org>2006-01-31 16:11:45 +0000
commit0fb6df4d57cfec1db762de8bf7be963a260843ec (patch)
tree8d7b26fde293557bf0d0d3326305098eedd7627d /audio/ecasound
parent97f3ddb8ddea4f2deb9fa9cdd67f6badf491c2af (diff)
downloadports-0fb6df4d57cfec1db762de8bf7be963a260843ec.tar.gz
ports-0fb6df4d57cfec1db762de8bf7be963a260843ec.zip
Notes
Diffstat (limited to 'audio/ecasound')
-rw-r--r--audio/ecasound/Makefile8
-rw-r--r--audio/ecasound/distinfo6
-rw-r--r--audio/ecasound/files/patch-ecatools__ecaplay.c14
3 files changed, 22 insertions, 6 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 55634314817c..7735f2ce6772 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ecasound
-PORTVERSION= 2.4.3
+PORTVERSION= 2.4.4
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/
@@ -18,7 +18,8 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile
+CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile \
+ --enable-sys-readline
INSTALLS_SHLIB= yes
MAN1= ecasound-iam.1 ecasound.1 ecatools.1 ecaconvert.1 \
@@ -32,6 +33,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
CFLAGS+= -fpermissive
.endif
@@ -54,7 +56,7 @@ CONFIGURE_ARGS+= --disable-jack
.endif
.if defined(WITH_SAMPLERATE)
-LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+= --disable-libsamplerate --disable-sndfile
.endif
diff --git a/audio/ecasound/distinfo b/audio/ecasound/distinfo
index 7855294ef654..f64beb96bc98 100644
--- a/audio/ecasound/distinfo
+++ b/audio/ecasound/distinfo
@@ -1,3 +1,3 @@
-MD5 (ecasound-2.4.3.tar.gz) = ea4af6ffa9f00743270151927f7b4584
-SHA256 (ecasound-2.4.3.tar.gz) = 18e198993d4fe696ffc495b2229d99c75583015b4b2429349fab2d5219057945
-SIZE (ecasound-2.4.3.tar.gz) = 1112995
+MD5 (ecasound-2.4.4.tar.gz) = 3032a157f736bb38426b2ebcc92c6513
+SHA256 (ecasound-2.4.4.tar.gz) = dd6afb770f97894763310d4435c1ab4ceb6529f0c0c9c790d126f22ea6f8bf77
+SIZE (ecasound-2.4.4.tar.gz) = 1128867
diff --git a/audio/ecasound/files/patch-ecatools__ecaplay.c b/audio/ecasound/files/patch-ecatools__ecaplay.c
new file mode 100644
index 000000000000..9c65ee084d89
--- /dev/null
+++ b/audio/ecasound/files/patch-ecatools__ecaplay.c
@@ -0,0 +1,14 @@
+--- ecatools/ecaplay.c.orig Mon Oct 3 06:44:57 2005
++++ ecatools/ecaplay.c Sun Jan 29 21:54:01 2006
+@@ -211,9 +211,10 @@
+ else {
+ static int once = 1;
+ if (once) {
++ char *tmpstr;
+ eci_command_r(eci, "ao-iselect 1");
+ eci_command_r(eci, "ao-describe");
+- char *tmpstr = (char*)eci_last_string_r(eci);
++ tmpstr = (char*)eci_last_string_r(eci);
+ /* skip the "-x:" prefix where x is one of [io] */
+ while(*tmpstr && *tmpstr++ != ':')
+ ;