aboutsummaryrefslogtreecommitdiff
path: root/audio/emu10kx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-01 10:23:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-01 10:23:56 +0000
commitc820b2fae5bd2f3c40731c29755c25cb7f56cc2a (patch)
tree998ad45bb00c4d338696780743ae18ea7cd1c3e9 /audio/emu10kx
parentf0bee8c787de88ae5d3d7486a277ef77912e5cbf (diff)
Notes
Diffstat (limited to 'audio/emu10kx')
-rw-r--r--audio/emu10kx/Makefile34
-rw-r--r--audio/emu10kx/distinfo2
-rw-r--r--audio/emu10kx/files/patch-emu10kx-pcm.c11
-rw-r--r--audio/emu10kx/files/patch-emu10kx.c11
-rw-r--r--audio/emu10kx/pkg-deinstall34
-rw-r--r--audio/emu10kx/pkg-descr9
-rw-r--r--audio/emu10kx/pkg-install46
-rw-r--r--audio/emu10kx/pkg-message15
8 files changed, 0 insertions, 162 deletions
diff --git a/audio/emu10kx/Makefile b/audio/emu10kx/Makefile
deleted file mode 100644
index dbb5c29bab0b..000000000000
--- a/audio/emu10kx/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# Created by: michaels@sdf.lonestar.org
-# $FreeBSD$
-
-PORTNAME= emu10kx
-PORTVERSION= 20051021
-CATEGORIES= audio kld
-MASTER_SITES= http://chibis.persons.gfk.ru/audigy/emu10kx/
-DISTNAME= ${PORTNAME}-2005-10-21
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= SBLive!, Audigy, and Audigy2 driver for FreeBSD
-
-USES= tar:bzip2
-NO_STAGE= yes
-
-NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-SSP_UNSAFE= kernel module does not support ssp
-
-MAN8= emuctrl.8
-PLIST_FILES= sbin/emuctrl etc/rc.d/emuctrl.sh
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-.include <bsd.port.pre.mk>
-
-do-install:
- @${SETENV} ${MAKE_ENV} ${MAKE} -C ${WRKSRC} -DMODULES_WITH_WORLD install
-
-post-install:
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
- @${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/audio/emu10kx/distinfo b/audio/emu10kx/distinfo
deleted file mode 100644
index 0028fad61e27..000000000000
--- a/audio/emu10kx/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (emu10kx-2005-10-21.tar.bz2) = 2f52892e27bd1402914d1701716930577d3d79a4fe710f5d0d789b6715ac2fed
-SIZE (emu10kx-2005-10-21.tar.bz2) = 70555
diff --git a/audio/emu10kx/files/patch-emu10kx-pcm.c b/audio/emu10kx/files/patch-emu10kx-pcm.c
deleted file mode 100644
index f17c84ccb872..000000000000
--- a/audio/emu10kx/files/patch-emu10kx-pcm.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- emu10kx-pcm.c.orig 2011-01-16 20:06:25.000000000 +0100
-+++ emu10kx-pcm.c 2011-01-16 20:10:06.000000000 +0100
-@@ -977,7 +977,7 @@
- break;
- }
- sc->rnum++;
-- if (sndbuf_alloc(ch->buffer, sc->card->parent_dmat, sc->card->bufsz) != 0)
-+ if (sndbuf_alloc(ch->buffer, sc->card->parent_dmat, NULL, sc->card->bufsz) != 0)
- return NULL;
- else {
- snd_mtxlock(sc->lock);
diff --git a/audio/emu10kx/files/patch-emu10kx.c b/audio/emu10kx/files/patch-emu10kx.c
deleted file mode 100644
index 32b34187592b..000000000000
--- a/audio/emu10kx/files/patch-emu10kx.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- emu10kx.c.orig 2011-01-16 20:03:30.000000000 +0100
-+++ emu10kx.c 2011-01-16 20:03:54.000000000 +0100
-@@ -892,7 +892,7 @@
- #else
- sc->irq = bus_alloc_resource(dev, SYS_RES_IRQ, &i, 0, ~0, 1, RF_ACTIVE | RF_SHAREABLE);
- #endif
-- if ((!(sc->irq)) || bus_setup_intr(dev, sc->irq, INTR_MPSAFE | INTR_TYPE_AV, emu_intr, sc, &sc->ih)) {
-+ if ((!(sc->irq)) || bus_setup_intr(dev, sc->irq, INTR_MPSAFE | INTR_TYPE_AV, NULL, emu_intr, sc, &sc->ih)) {
- device_printf(dev, "unable to map interrupt\n");
- goto bad;
- }
diff --git a/audio/emu10kx/pkg-deinstall b/audio/emu10kx/pkg-deinstall
deleted file mode 100644
index 351b8469a536..000000000000
--- a/audio/emu10kx/pkg-deinstall
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-
-[ "$2" != "DEINSTALL" ] && exit 0
-
-#============================================================
-# DEINSTALL
-#============================================================
-DRIVERNAME=snd_emu10kx
-
-# Unload the driver
-kldstat -n $DRIVERNAME > /dev/null 2>&1; RESULT=$?
-if [ ${RESULT} -eq 0 ]; then
- kldunload -n $DRIVERNAME > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -ne 0 ]; then
- echo "ERROR: Failed to unload the $DRIVERNAME module!"
- echo "ERROR: Is $DRIVERNAME.ko in use?"
- exit 1;
- fi
-fi
-
-# Remove the driver
-rm /boot/modules/$DRIVERNAME.ko
-
-# Remove the driver from loader.conf
-grep ${DRIVERNAME}_load /boot/loader.conf > /dev/null 2>&1; RESULT=$?
-if [ ${RESULT} -eq 0 ]; then
- sed -e /${DRIVERNAME}_load.*/d -i.orig /boot/loader.conf
-fi
-
-# Tell the user about the state files
-if [ -f /var/db/emu10kx0-state ]; then
-echo "If you will not be using this port anymore, please remove " /var/db/emu10kx[0-9]-state " manually."
-fi
-#============================================================
diff --git a/audio/emu10kx/pkg-descr b/audio/emu10kx/pkg-descr
deleted file mode 100644
index cfaa361b0d1b..000000000000
--- a/audio/emu10kx/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-This is a port of the snd_emu10kx sound driver. This driver works for
-SBLive!, Audigy, and Audigy2 based cards.
-
-This is an alternate driver that you may use instead of the snd_emu10k1
-driver in the FreeBSD kernel.
-
-This driver was written by Yuriy Tsibizov.
-
-WWW: http://chibis.persons.gfk.ru/audigy/
diff --git a/audio/emu10kx/pkg-install b/audio/emu10kx/pkg-install
deleted file mode 100644
index 1eb82b4a0108..000000000000
--- a/audio/emu10kx/pkg-install
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-
-[ "$2" != "POST-INSTALL" ] && exit 0
-
-#============================================================
-# POST-INSTALL
-#============================================================
-DRIVERNAME=snd_emu10kx
-
-# Ask user about installing driver
-echo -n "Do you want to install $DRIVERNAME driver and load it on boot time? [y/n]: "
-read RES
-echo
-
-if [ x"$RES" = x"y" ] ; then
-
-# Unload the driver
-kldstat -n $DRIVERNAME > /dev/null 2>&1; RESULT=$?
-if [ ${RESULT} -eq 0 ]; then
- kldunload -n $DRIVERNAME > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -ne 0 ]; then
- echo "ERROR: Failed to unload the $DRIVERNAME module!"
- echo "ERROR: Is $DRIVERNAME.ko in use?"
- exit 1;
- fi
-fi
-
-# Load the driver
-kldload $DRIVERNAME > /dev/null 2>&1 ; RESULT=$?
-if [ ${RESULT} -ne 0 ]; then
- echo "ERROR: Failed to load the $DRIVERNAME module!"
- exit 1;
-fi
-
-# Have the driver load at boot
-grep ${DRIVERNAME}_load /boot/loader.conf > /dev/null 2>&1; RESULT=$?
-if [ ${RESULT} -eq 0 ]; then
- # Present.
- sed -e "s/${DRIVERNAME}_load.*/${DRIVERNAME}_load=\"YES\"/g" -i.orig /boot/loader.conf
-else
- # Not present.
- echo "${DRIVERNAME}_load=\"YES\"" >> /boot/loader.conf
-fi
-
-fi
-#============================================================
diff --git a/audio/emu10kx/pkg-message b/audio/emu10kx/pkg-message
deleted file mode 100644
index 233c00ca1dda..000000000000
--- a/audio/emu10kx/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
-
-To use these drivers, make sure that you have loaded the emu10kx kernel
-module, by doing
-
- # kldload snd_emu10kx
-
-or adding
-
- snd_emu10kx_load="YES"
-
-to your /boot/loader.conf (normally done automatically when installing
-the port).
-
-Note you should disable loading of the emu10k1 driver (this driver is for
-the same hardware).