aboutsummaryrefslogtreecommitdiff
path: root/audio/esound
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-07 06:42:25 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-07 06:42:25 +0000
commit00d4f1915eaf8a507165377170f5c9189f90a4fe (patch)
treeca7eb0f2f5dab1a57945bd159da8fb4028069fac /audio/esound
parent3d934ab5b09008c1bb68414f32e7ae2392c62af7 (diff)
downloadports-00d4f1915eaf8a507165377170f5c9189f90a4fe.tar.gz
ports-00d4f1915eaf8a507165377170f5c9189f90a4fe.zip
Notes
Diffstat (limited to 'audio/esound')
-rw-r--r--audio/esound/Makefile4
-rw-r--r--audio/esound/distinfo2
-rw-r--r--audio/esound/files/patch-configure13
-rw-r--r--audio/esound/files/patch-ltmain.sh45
4 files changed, 16 insertions, 48 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 790446a4dc0c..f1b1e97e03c1 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= esound
-PORTVERSION= 0.2.25
+PORTVERSION= 0.2.26
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/esound
@@ -19,7 +19,7 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
USE_BZIP2= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/audio/esound/distinfo b/audio/esound/distinfo
index a793a4fe1387..8dfd1725cd53 100644
--- a/audio/esound/distinfo
+++ b/audio/esound/distinfo
@@ -1 +1 @@
-MD5 (gnome/esound-0.2.25.tar.bz2) = 9f21f84a8d4ab27fcd0ce55130e66d72
+MD5 (gnome/esound-0.2.26.tar.bz2) = 2892f7ef9af6c6c1ce5bcb88165dda4f
diff --git a/audio/esound/files/patch-configure b/audio/esound/files/patch-configure
new file mode 100644
index 000000000000..31b690366f87
--- /dev/null
+++ b/audio/esound/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/05/07 06:39:43 1.1
++++ configure 2002/05/07 06:39:55
+@@ -5308,6 +5308,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/esound/files/patch-ltmain.sh b/audio/esound/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/audio/esound/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"