aboutsummaryrefslogtreecommitdiff
path: root/audio/espeak
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-03 00:16:56 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-03 00:16:56 +0000
commita02ab8ffe228b0f5eaf2ce9ffa6ab427d74781ed (patch)
tree852b5205f66e0f497571aee2d961a2f3faec3b0b /audio/espeak
parent257b9b932665fde1bbb8319e339373c26e4d2221 (diff)
downloadports-a02ab8ffe228b0f5eaf2ce9ffa6ab427d74781ed.tar.gz
ports-a02ab8ffe228b0f5eaf2ce9ffa6ab427d74781ed.zip
Notes
Diffstat (limited to 'audio/espeak')
-rw-r--r--audio/espeak/Makefile14
-rw-r--r--audio/espeak/distinfo6
-rw-r--r--audio/espeak/files/patch-src-Makefile11
-rw-r--r--audio/espeak/pkg-plist81
4 files changed, 63 insertions, 49 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index 3ba11da3c85f..9ab42f1324ad 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= espeak
-PORTVERSION= 1.07
+PORTVERSION= 1.13
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,7 +30,7 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
BUILD_WRKSRC= ${WRKSRC}/src
-FIND_DIRS= data espeak-data
+FIND_DIRS= espeak-data
FIND_DOCS= docs
REPLACE_FILES= ${BUILD_WRKSRC}/Makefile ${BUILD_WRKSRC}/speak.cpp
@@ -51,8 +51,16 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/${FIND_DOCS} && ${FIND} . -type d -exec ${MKDIR} \
+ ${DOCSDIR}/{} \;
cd ${WRKSRC}/${FIND_DOCS} && ${FIND} . -type f \
-exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= requires iswdigit(3)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 000fb192aaa7..713aff8fea8d 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,3 +1,3 @@
-MD5 (speak-1.07-source.zip) = a1f1b22033215d95737dec66419149a9
-SHA256 (speak-1.07-source.zip) = d6ed37360c98f59140550a1ba3bfe3d97eda6caabbdba621322a5379e7b64372
-SIZE (speak-1.07-source.zip) = 325880
+MD5 (speak-1.13-source.zip) = 1cd76ad278fa134eced57b865b72175b
+SHA256 (speak-1.13-source.zip) = 373de2952e46e7470aa3a8cb111ed9df2904cf87e637d3aaaad21af0f2700b85
+SIZE (speak-1.13-source.zip) = 481980
diff --git a/audio/espeak/files/patch-src-Makefile b/audio/espeak/files/patch-src-Makefile
index 7992b9f433b0..c1f4d2a54844 100644
--- a/audio/espeak/files/patch-src-Makefile
+++ b/audio/espeak/files/patch-src-Makefile
@@ -1,6 +1,5 @@
-$FreeBSD$
---- src/Makefile Sat Feb 18 11:58:02 2006
-+++ src/Makefile.port Sat Mar 25 13:29:06 2006
+--- src/Makefile Thu Apr 6 17:40:54 2006
++++ src/Makefile.port Sat Sep 2 12:03:47 2006
@@ -1,13 +1,13 @@
SRCS=$(wildcard *.cpp)
OBJS=$(patsubst %.cpp,%.o,$(SRCS))
@@ -9,12 +8,12 @@ $FreeBSD$
all: speak
.cpp.o:
-- $(CXX) $(CXXFLAGS) -I. -c $<
-+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -I. -c $<
+- $(CXX) $(CXXFLAGS) -O2 -Wall -pedantic -I. -c -fno-exceptions $<
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -Wall -pedantic -I. -c -fno-exceptions $<
speak: $(OBJS)
- $(CXX) -o $@ $(OBJS) $(LIBS)
+ $(CXX) $(PTHREAD_LIBS) -o $@ $(OBJS) $(LIBS)
clean:
- rm -f *.o
+ rm -f *.o *~
diff --git a/audio/espeak/pkg-plist b/audio/espeak/pkg-plist
index 97828eefe605..e386ae6288ba 100644
--- a/audio/espeak/pkg-plist
+++ b/audio/espeak/pkg-plist
@@ -1,51 +1,58 @@
@comment $FreeBSD$
bin/speak
+%%PORTDOCS%%%%DOCSDIR%%/add_language.html
%%PORTDOCS%%%%DOCSDIR%%/commands.html
%%PORTDOCS%%%%DOCSDIR%%/dictionary.html
+%%PORTDOCS%%%%DOCSDIR%%/docindex.html
+%%PORTDOCS%%%%DOCSDIR%%/editor.html
+%%PORTDOCS%%%%DOCSDIR%%/editor_if.html
+%%PORTDOCS%%%%DOCSDIR%%/images/lips.png
+%%PORTDOCS%%%%DOCSDIR%%/images/sand-light.jpg
+%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/phonemes.html
+%%PORTDOCS%%%%DOCSDIR%%/phontab.html
+%%PORTDOCS%%%%DOCSDIR%%/speak_lib.h
%%PORTDOCS%%%%DOCSDIR%%/voices.html
-%%DATADIR%%/data/english_extra
-%%DATADIR%%/data/english_list
-%%DATADIR%%/data/english_rules
-%%DATADIR%%/data/esperanto_list
-%%DATADIR%%/data/esperanto_rules
-%%DATADIR%%/data/german_list
-%%DATADIR%%/data/german_rules
-%%DATADIR%%/espeak-data/english_1
-%%DATADIR%%/espeak-data/english_2
-%%DATADIR%%/espeak-data/esperanto_1
-%%DATADIR%%/espeak-data/esperanto_2
-%%DATADIR%%/espeak-data/german_1
-%%DATADIR%%/espeak-data/german_2
+%%DATADIR%%/espeak-data/af_dict
+%%DATADIR%%/espeak-data/config
+%%DATADIR%%/espeak-data/de_dict
+%%DATADIR%%/espeak-data/el_dict
+%%DATADIR%%/espeak-data/en_dict
+%%DATADIR%%/espeak-data/eo_dict
+%%DATADIR%%/espeak-data/es_dict
+%%DATADIR%%/espeak-data/it_dict
%%DATADIR%%/espeak-data/phondata
%%DATADIR%%/espeak-data/phonindex
%%DATADIR%%/espeak-data/phontab
+%%DATADIR%%/espeak-data/pl_dict
+%%DATADIR%%/espeak-data/voices/af
+%%DATADIR%%/espeak-data/voices/de
%%DATADIR%%/espeak-data/voices/default
-%%DATADIR%%/espeak-data/voices/en
-%%DATADIR%%/espeak-data/voices/en-b
-%%DATADIR%%/espeak-data/voices/en-c
-%%DATADIR%%/espeak-data/voices/en-c2
-%%DATADIR%%/espeak-data/voices/en-c3
-%%DATADIR%%/espeak-data/voices/en-d
-%%DATADIR%%/espeak-data/voices/en-f
-%%DATADIR%%/espeak-data/voices/en-fb
-%%DATADIR%%/espeak-data/voices/en-fc
-%%DATADIR%%/espeak-data/voices/en-fd
-%%DATADIR%%/espeak-data/voices/en1
-%%DATADIR%%/espeak-data/voices/en1a
-%%DATADIR%%/espeak-data/voices/en2
-%%DATADIR%%/espeak-data/voices/en3
-%%DATADIR%%/espeak-data/voices/en4
-%%DATADIR%%/espeak-data/voices/en5
-%%DATADIR%%/espeak-data/voices/en6
-%%DATADIR%%/espeak-data/voices/en7
-%%DATADIR%%/espeak-data/voices/en8
-%%DATADIR%%/espeak-data/voices/esperanto
-%%DATADIR%%/espeak-data/voices/german
-%%DATADIR%%/espeak-data/voices/test
-%%DATADIR%%/espeak-data/voices/testtone
+%%DATADIR%%/espeak-data/voices/el
+%%DATADIR%%/espeak-data/voices/en/en
+%%DATADIR%%/espeak-data/voices/en/en-croak
+%%DATADIR%%/espeak-data/voices/en/en-f
+%%DATADIR%%/espeak-data/voices/en/en-n
+%%DATADIR%%/espeak-data/voices/en/en-n-f
+%%DATADIR%%/espeak-data/voices/en/en-rp
+%%DATADIR%%/espeak-data/voices/en/en-rp-f
+%%DATADIR%%/espeak-data/voices/en/en-wm
+%%DATADIR%%/espeak-data/voices/en/en-wm-f
+%%DATADIR%%/espeak-data/voices/en/en1
+%%DATADIR%%/espeak-data/voices/en/en2
+%%DATADIR%%/espeak-data/voices/en/en3
+%%DATADIR%%/espeak-data/voices/en/en4
+%%DATADIR%%/espeak-data/voices/en/en6
+%%DATADIR%%/espeak-data/voices/en/en7
+%%DATADIR%%/espeak-data/voices/en/en8
+%%DATADIR%%/espeak-data/voices/eo
+%%DATADIR%%/espeak-data/voices/es
+%%DATADIR%%/espeak-data/voices/it
+%%DATADIR%%/espeak-data/voices/pl
+@dirrm %%PORTDOCS%%%%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/espeak-data/soundicons
+@dirrm %%DATADIR%%/espeak-data/voices/en
@dirrm %%DATADIR%%/espeak-data/voices
@dirrm %%DATADIR%%/espeak-data
@dirrm %%DATADIR%%