aboutsummaryrefslogtreecommitdiff
path: root/audio/exaile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-12-19 08:06:33 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-12-19 08:06:33 +0000
commit8f53b0b3e82f2ad4376379d64825a7989e26d426 (patch)
tree821802fc4cfe03922f2d40a34109c53e6ff2b0ab /audio/exaile
parent9bf5a669ab6d81426c69fedef04fe02a92a4f106 (diff)
downloadports-8f53b0b3e82f2ad4376379d64825a7989e26d426.tar.gz
ports-8f53b0b3e82f2ad4376379d64825a7989e26d426.zip
Notes
Diffstat (limited to 'audio/exaile')
-rw-r--r--audio/exaile/Makefile36
-rw-r--r--audio/exaile/distinfo3
-rw-r--r--audio/exaile/pkg-descr9
-rw-r--r--audio/exaile/pkg-plist78
4 files changed, 126 insertions, 0 deletions
diff --git a/audio/exaile/Makefile b/audio/exaile/Makefile
new file mode 100644
index 000000000000..dd95267882c3
--- /dev/null
+++ b/audio/exaile/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: exaile
+# Date created: 19 December 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exaile
+DISTVERSION= 0.2.7b2
+CATEGORIES= audio
+MASTER_SITES= http://www.exaile.org/files/ CSME
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= AmaroK replacement for GTK+
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
+
+USE_GNOME= pygtk2
+USE_GSTREAMER= python
+USE_PYTHON= yes
+PLIST_FILES= share/applications/${PORTNAME}.desktop share/pixmaps/${PORTNAME}.png bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^PREFIX/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^PYTHON_DIR/s|=.*|=${PYTHON_INCLUDEDIR}|' ${WRKSRC}/mmkeys/Makefile
+
+create-plist:
+ ${FIND} -s ${DATADIR} -not -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' > ${PLIST}
+ ${FIND} -ds ${DATADIR} -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' \
+ -e 's|^|@dirrm |' >> ${PLIST}
+ @${ECHO_CMD} '@dirrmtry share/applications' >> ${PLIST}
+ @${ECHO_CMD} '@dirrmtry share/pixmaps' >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/audio/exaile/distinfo b/audio/exaile/distinfo
new file mode 100644
index 000000000000..bff14e7f5777
--- /dev/null
+++ b/audio/exaile/distinfo
@@ -0,0 +1,3 @@
+MD5 (exaile_0.2.7b2.tar.gz) = 750750807de9861a4c41ad4a5598d46b
+SHA256 (exaile_0.2.7b2.tar.gz) = fcb55028b415db26dd5cf1ddf63bd9f443539eb156eb274817e748d7b02d775c
+SIZE (exaile_0.2.7b2.tar.gz) = 362973
diff --git a/audio/exaile/pkg-descr b/audio/exaile/pkg-descr
new file mode 100644
index 000000000000..86c661b4f8ff
--- /dev/null
+++ b/audio/exaile/pkg-descr
@@ -0,0 +1,9 @@
+Exaile is a media player aiming to be similar to KDE's AmaroK, but for
+GTK+. It incorporates many of the cool things from AmaroK (and other
+media players) like automatic fetching of album art, handling of large
+libraries, lyrics fetching, artist/album information via the wikipedia,
+last.fm support, optional iPod support (assuming you have python-gpod
+installed).
+
+WWW: http://www.exaile.org/
+Author: Adam Olsen <arolsen@gmail.com>
diff --git a/audio/exaile/pkg-plist b/audio/exaile/pkg-plist
new file mode 100644
index 000000000000..e45870be2a0b
--- /dev/null
+++ b/audio/exaile/pkg-plist
@@ -0,0 +1,78 @@
+%%DATADIR%%/exaile.glade
+%%DATADIR%%/exaile.py
+%%DATADIR%%/images/artist.png
+%%DATADIR%%/images/close.png
+%%DATADIR%%/images/default_theme/add.png
+%%DATADIR%%/images/default_theme/clear.png
+%%DATADIR%%/images/default_theme/gnome-dev-cdrom-audio.png
+%%DATADIR%%/images/default_theme/gnome-dev-ipod.png
+%%DATADIR%%/images/default_theme/gnome-fs-directory-accept.png
+%%DATADIR%%/images/default_theme/gnome-fs-directory.png
+%%DATADIR%%/images/default_theme/gnome-globe.png
+%%DATADIR%%/images/default_theme/go-back.png
+%%DATADIR%%/images/default_theme/go-forward.png
+%%DATADIR%%/images/default_theme/go-up.png
+%%DATADIR%%/images/default_theme/media-next.png
+%%DATADIR%%/images/default_theme/media-pause.png
+%%DATADIR%%/images/default_theme/media-play.png
+%%DATADIR%%/images/default_theme/media-previous.png
+%%DATADIR%%/images/default_theme/refresh.png
+%%DATADIR%%/images/default_theme/remove.png
+%%DATADIR%%/images/default_theme/stock_volume.png
+%%DATADIR%%/images/exailelogo-sml.png
+%%DATADIR%%/images/exailelogo.png
+%%DATADIR%%/images/genre.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/ipod.png
+%%DATADIR%%/images/largeicon.png
+%%DATADIR%%/images/media-audiofile.png
+%%DATADIR%%/images/nocover.png
+%%DATADIR%%/images/playlist.png
+%%DATADIR%%/images/splash.png
+%%DATADIR%%/images/track.png
+%%DATADIR%%/images/trayicon.png
+%%DATADIR%%/mmkeys.so
+%%DATADIR%%/plugins/__init__.py
+%%DATADIR%%/plugins/alarmclock.py
+%%DATADIR%%/plugins/desktopcover.py
+%%DATADIR%%/plugins/exailenotify.py
+%%DATADIR%%/plugins/gui.py
+%%DATADIR%%/plugins/manager.py
+%%DATADIR%%/plugins/minimode.py
+%%DATADIR%%/plugins/plugins.glade
+%%DATADIR%%/plugins/serp.py
+%%DATADIR%%/plugins/streamripper.py
+%%DATADIR%%/po/ca.po
+%%DATADIR%%/po/de_DE.po
+%%DATADIR%%/po/en_GB.po
+%%DATADIR%%/po/es_ES.po
+%%DATADIR%%/po/pl.po
+%%DATADIR%%/po/ru.po
+%%DATADIR%%/po/sv.po
+%%DATADIR%%/po/zh_CN.po
+%%DATADIR%%/sql/db.sql
+%%DATADIR%%/xl/__init__.py
+%%DATADIR%%/xl/audioscrobbler.py
+%%DATADIR%%/xl/common.py
+%%DATADIR%%/xl/config.py
+%%DATADIR%%/xl/covers.py
+%%DATADIR%%/xl/db.py
+%%DATADIR%%/xl/dbusinterface.py
+%%DATADIR%%/xl/filtergui.py
+%%DATADIR%%/xl/media.py
+%%DATADIR%%/xl/panels.py
+%%DATADIR%%/xl/prefs.py
+%%DATADIR%%/xl/shoutcast.py
+%%DATADIR%%/xl/track.py
+%%DATADIR%%/xl/tracks.py
+%%DATADIR%%/xl/trackslist.py
+%%DATADIR%%/xl/xlmisc.py
+@dirrm %%DATADIR%%/images/default_theme
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/po
+@dirrm %%DATADIR%%/sql
+@dirrm %%DATADIR%%/xl
+@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrmtry share/pixmaps