aboutsummaryrefslogtreecommitdiff
path: root/audio/exaile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /audio/exaile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'audio/exaile')
-rw-r--r--audio/exaile/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/exaile/Makefile b/audio/exaile/Makefile
index b49dfb729ec1..5ed5d53655ef 100644
--- a/audio/exaile/Makefile
+++ b/audio/exaile/Makefile
@@ -12,7 +12,7 @@ COMMENT= Full featured python-based music player for GTK+
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.11:audio/py-mutagen
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.11:audio/py-mutagen@${PY_FLAVOR}
MAKE_ENV+= PYTHON2_CMD=${PYTHON_CMD} XDGCONFDIR=${PREFIX}/etc/xdg
USES= desktop-file-utils gmake python:2
@@ -24,14 +24,14 @@ OPTIONS_DEFAULT= BAD CDDB DBUS HAL NOTIFY SEXY
OPTIONS_SUB= yes
BAD_DESC= Install bad GStreamer plugins
BAD_USE= GSTREAMER=bad
-CDDB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cddb>=1.4:audio/py-cddb
-DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.82.1:devel/py-dbus
+CDDB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cddb>=1.4:audio/py-cddb@${PY_FLAVOR}
+DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.82.1:devel/py-dbus@${PY_FLAVOR}
HAL_LIB_DEPENDS= libhal.so:sysutils/hal
-NOTIFY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify
+NOTIFY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify@${PY_FLAVOR}
NLS_USES= gettext
NLS_INSTALL_TARGET_OFF= install_no_locale
SEXY_DESC= UI enchancements
-SEXY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sexy>=0.1.9:x11-toolkits/py-sexy
+SEXY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sexy>=0.1.9:x11-toolkits/py-sexy@${PY_FLAVOR}
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|g' ${WRKSRC}/Makefile