aboutsummaryrefslogtreecommitdiff
path: root/audio/extace/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-05-23 09:47:27 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-05-23 09:47:27 +0000
commitd143f7e5ca5239cc7be12685b8a0231c06ceb38a (patch)
tree20d53a37b8d6866eef2e978d977a4c6fb98ecc77 /audio/extace/Makefile
parente1431f76439f6edd29d5d93ff00a749eee59fb54 (diff)
downloadports-d143f7e5ca5239cc7be12685b8a0231c06ceb38a.tar.gz
ports-d143f7e5ca5239cc7be12685b8a0231c06ceb38a.zip
Notes
Diffstat (limited to 'audio/extace/Makefile')
-rw-r--r--audio/extace/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
new file mode 100644
index 000000000000..7ab22abbddac
--- /dev/null
+++ b/audio/extace/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: extace
+# Date created: 8 April 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= extace
+PORTVERSION= 1.2.23
+CATEGORIES= audio
+MASTER_SITES= http://download.sourceforge.net/eXtace/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ esd.2:${PORTSDIR}/audio/esound \
+ fftw.2:${PORTSDIR}/math/fftw
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+ESD_CONFIG?= ${LOCALBASE}/bin/esd-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ ESD_CONFIG="${ESD_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>