aboutsummaryrefslogtreecommitdiff
path: root/audio/ezstream/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-15 19:22:41 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-15 19:22:41 +0000
commit446d8dc169a32ac6e2397ab681f84480c37365ae (patch)
treeb67f250f6cf28be0f47ff3429a94621059c11c28 /audio/ezstream/Makefile
parentaccee4c1d3f32932e7eaa290170009187e4a384b (diff)
downloadports-446d8dc169a32ac6e2397ab681f84480c37365ae.tar.gz
ports-446d8dc169a32ac6e2397ab681f84480c37365ae.zip
Notes
Diffstat (limited to 'audio/ezstream/Makefile')
-rw-r--r--audio/ezstream/Makefile33
1 files changed, 19 insertions, 14 deletions
diff --git a/audio/ezstream/Makefile b/audio/ezstream/Makefile
index a7dffcd299d2..9c11d943ef79 100644
--- a/audio/ezstream/Makefile
+++ b/audio/ezstream/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: ezstream
-# Date created: 27 Nov 2004
-# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+# New ports collection makefile for: ezstream
+# Date created: 27 Nov 2004
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
#
# $FreeBSD$
#
PORTNAME= ezstream
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.1
CATEGORIES= audio
MASTER_SITES= http://svn.xiph.org/releases/ezstream/
@@ -17,19 +17,24 @@ LIB_DEPENDS= shout.4:${PORTSDIR}/audio/libshout2 \
vorbis.3:${PORTSDIR}/audio/libvorbis \
xml2.5:${PORTSDIR}/textproc/libxml2
-CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:13
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-. for DOC in ezstream_mp3.xml ezstream_reencoding_example_vorbis.xml \
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/ezstream
+PORTDOCS= ezstream_mp3.xml ezstream_reencoding_example_vorbis.xml \
ezstream_reencoding_example_mp3.xml ezstream_vorbis.xml \
ezstream_reencoding_example_theora.xml
- ${INSTALL_DATA} ${WRKSRC}/conf/${DOC} ${DOCSDIR}
-. endfor
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>