aboutsummaryrefslogtreecommitdiff
path: root/audio/ezstream/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2004-10-16 00:13:17 +0000
committerWill Andrews <will@FreeBSD.org>2004-10-16 00:13:17 +0000
commitb6450405d7c9905e345b3ee0d5c6bbbae01b4311 (patch)
tree7d7f4a52ccebab6e0051df8947b0b700dc30eef4 /audio/ezstream/Makefile
parentca9ea1fc0e99af075f2ddc46328e30b1a6e732b3 (diff)
Notes
Diffstat (limited to 'audio/ezstream/Makefile')
-rw-r--r--audio/ezstream/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/ezstream/Makefile b/audio/ezstream/Makefile
new file mode 100644
index 000000000000..aca8427176c0
--- /dev/null
+++ b/audio/ezstream/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ezstream
+# Date created: 27 Nov 2004
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ezstream
+PORTVERSION= 0.1.2
+CATEGORIES= audio
+MASTER_SITES= http://svn.xiph.org/releases/ezstream/
+
+MAINTAINER= laszlof@vonostingroup.com
+COMMENT= A command line utility for streaming to icecast servers
+
+LIB_DEPENDS= shout.3:${PORTSDIR}/audio/libshout2 \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 13
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/ezstream_m3u.xml \
+ ${WRKSRC}/conf/ezstream_mp3.xml \
+ ${WRKSRC}/conf/ezstream_vorbis.xml \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>