aboutsummaryrefslogtreecommitdiff
path: root/audio/faad
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-24 09:10:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-24 09:10:11 +0000
commit7aae825f01e7c25fcd0ce95d8b2742ebf972e4e3 (patch)
tree4c9bf1b3492130a68838c5bc767404adf7f504cf /audio/faad
parentb882542d760e74603f0071eca4e42e508618282d (diff)
downloadports-7aae825f01e7c25fcd0ce95d8b2742ebf972e4e3.tar.gz
ports-7aae825f01e7c25fcd0ce95d8b2742ebf972e4e3.zip
Notes
Diffstat (limited to 'audio/faad')
-rw-r--r--audio/faad/Makefile20
-rw-r--r--audio/faad/files/patch-structs.h94
-rw-r--r--audio/faad/pkg-plist9
3 files changed, 108 insertions, 15 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index 8b2e0089ee15..163f1c199e46 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -7,7 +7,7 @@
PORTNAME= faad2
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= faac
@@ -38,18 +38,11 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libmp4v2.a)
-HAS_MP4V2= yes
-.endif
-
-.if defined(WITHOUT_MPEG4IP) && !defined(HAS_MP4V2)
-PLIST_FILES+= include/mp4.h include/mpeg4ip.h include/systems.h \
- lib/libmp4v2.so lib/libmp4v2.so.0 lib/libmp4v2.a
+.if defined(WITHOUT_MPEG4IP)
+PLIST_SUB+= WITHOUT_MPEG4IP="" PLUGIN="@comment "
.else
LIB_DEPENDS+= mp4.0:${PORTSDIR}/multimedia/mpeg4ip
-PLIST_FILES+= lib/mp4player_plugin/faad2_plugin.a \
- lib/mp4player_plugin/faad2_plugin.so \
- lib/mp4player_plugin/faad2_plugin.so.0
+PLIST_SUB+= WITHOUT_MPEG4IP="@comment " PLUGIN=""
.endif
pre-everything::
@@ -79,9 +72,6 @@ post-patch:
@${ECHO_CMD} "SUBDIRS = libfaad common frontend plugins" > \
${WRKSRC}/Makefile.am
.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|uint8_t|unsigned char|; \
- s|uint16_t|unsigned short|; s|uint32_t|unsigned long|; \
- s|int8_t|char|;' ${WRKSRC}/libfaad/structs.h
@${REINPLACE_CMD} -e 's|stdint.h|sys/inttypes.h|' \
${WRKSRC}/common/mp4ff/mp4ff_int_types.h
.endif
@@ -91,7 +81,7 @@ post-patch:
${REINPLACE_CMD} -e \
's|-O2|${CFLAGS}|'
post-install:
-.if defined(WITHOUT_MPEG4IP) && !defined(HAS_MP4V2)
+.if defined(WITHOUT_MPEG4IP)
@${INSTALL_DATA} ${WRKSRC}/common/mp4v2/systems.h ${PREFIX}/include
.endif
diff --git a/audio/faad/files/patch-structs.h b/audio/faad/files/patch-structs.h
new file mode 100644
index 000000000000..3a0363d9325a
--- /dev/null
+++ b/audio/faad/files/patch-structs.h
@@ -0,0 +1,94 @@
+--- libfaad/structs.h.orig Thu Jan 29 12:31:11 2004
++++ libfaad/structs.h Sun May 23 10:52:13 2004
+@@ -307,58 +307,58 @@
+ typedef struct mp4AudioSpecificConfig
+ {
+ /* Audio Specific Info */
+- uint8_t objectTypeIndex;
+- uint8_t samplingFrequencyIndex;
+- uint32_t samplingFrequency;
+- uint8_t channelsConfiguration;
++ unsigned char objectTypeIndex;
++ unsigned char samplingFrequencyIndex;
++ unsigned long samplingFrequency;
++ unsigned char channelsConfiguration;
+
+ /* GA Specific Info */
+- uint8_t frameLengthFlag;
+- uint8_t dependsOnCoreCoder;
+- uint16_t coreCoderDelay;
+- uint8_t extensionFlag;
+- uint8_t aacSectionDataResilienceFlag;
+- uint8_t aacScalefactorDataResilienceFlag;
+- uint8_t aacSpectralDataResilienceFlag;
+- uint8_t epConfig;
++ unsigned char frameLengthFlag;
++ unsigned char dependsOnCoreCoder;
++ unsigned short coreCoderDelay;
++ unsigned char extensionFlag;
++ unsigned char aacSectionDataResilienceFlag;
++ unsigned char aacScalefactorDataResilienceFlag;
++ unsigned char aacSpectralDataResilienceFlag;
++ unsigned char epConfig;
+
+- int8_t sbr_present_flag;
+- int8_t forceUpSampling;
++ char sbr_present_flag;
++ char forceUpSampling;
+ } mp4AudioSpecificConfig;
+
+ typedef struct faacDecConfiguration
+ {
+- uint8_t defObjectType;
+- uint32_t defSampleRate;
+- uint8_t outputFormat;
+- uint8_t downMatrix;
+- uint8_t useOldADTSFormat;
+- uint8_t dontUpSampleImplicitSBR;
++ unsigned char defObjectType;
++ unsigned long defSampleRate;
++ unsigned char outputFormat;
++ unsigned char downMatrix;
++ unsigned char useOldADTSFormat;
++ unsigned char dontUpSampleImplicitSBR;
+ } faacDecConfiguration, *faacDecConfigurationPtr;
+
+ typedef struct faacDecFrameInfo
+ {
+- uint32_t bytesconsumed;
+- uint32_t samples;
+- uint8_t channels;
+- uint8_t error;
+- uint32_t samplerate;
++ unsigned long bytesconsumed;
++ unsigned long samples;
++ unsigned char channels;
++ unsigned char error;
++ unsigned long samplerate;
+
+ /* SBR: 0: off, 1: on; normal, 2: on; downsampled */
+- uint8_t sbr;
++ unsigned char sbr;
+
+ /* MPEG-4 ObjectType */
+- uint8_t object_type;
++ unsigned char object_type;
+
+ /* AAC header type; MP4 will be signalled as RAW also */
+- uint8_t header_type;
++ unsigned char header_type;
+
+ /* multichannel configuration */
+- uint8_t num_front_channels;
+- uint8_t num_side_channels;
+- uint8_t num_back_channels;
+- uint8_t num_lfe_channels;
+- uint8_t channel_position[MAX_CHANNELS];
++ unsigned char num_front_channels;
++ unsigned char num_side_channels;
++ unsigned char num_back_channels;
++ unsigned char num_lfe_channels;
++ unsigned char channel_position[MAX_CHANNELS];
+ } faacDecFrameInfo;
+
+ typedef struct
diff --git a/audio/faad/pkg-plist b/audio/faad/pkg-plist
index 9063f2e76b8e..fa6cc9009150 100644
--- a/audio/faad/pkg-plist
+++ b/audio/faad/pkg-plist
@@ -7,3 +7,12 @@ lib/libfaad.so.0
lib/libmp4ff.a
lib/libmp4ff.so
lib/libmp4ff.so.0
+%%PLUGIN%%lib/mp4player_plugin/faad2_plugin.a
+%%PLUGIN%%lib/mp4player_plugin/faad2_plugin.so
+%%PLUGIN%%lib/mp4player_plugin/faad2_plugin.so.0
+%%WITHOUT_MPEG4IP%%include/mp4.h
+%%WITHOUT_MPEG4IP%%include/mpeg4ip.h
+%%WITHOUT_MPEG4IP%%include/systems.h
+%%WITHOUT_MPEG4IP%%lib/libmp4v2.a
+%%WITHOUT_MPEG4IP%%lib/libmp4v2.so
+%%WITHOUT_MPEG4IP%%lib/libmp4v2.so.0