aboutsummaryrefslogtreecommitdiff
path: root/audio/fcplay/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 07:20:01 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 07:20:01 +0000
commit9d1acc217ef3500cb39407a31f68ec7115bed34e (patch)
tree125ecffd0f0b69655ca988ce96eaf465b999688a /audio/fcplay/Makefile
parent3902c89d0805bee03f251c5b9a9f630e462bbb25 (diff)
downloadports-9d1acc217ef3500cb39407a31f68ec7115bed34e.tar.gz
ports-9d1acc217ef3500cb39407a31f68ec7115bed34e.zip
Notes
Diffstat (limited to 'audio/fcplay/Makefile')
-rw-r--r--audio/fcplay/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/audio/fcplay/Makefile b/audio/fcplay/Makefile
index 51a255a0da9c..f315648fb0f0 100644
--- a/audio/fcplay/Makefile
+++ b/audio/fcplay/Makefile
@@ -18,18 +18,13 @@ COMMENT= Future Composer Reference Player
BUILD_DEPENDS= ${LOCALBASE}/include/sidplay/compconf.h:${PORTSDIR}/audio/libsidplay
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CXXFLAGS+= -I${LOCALBASE}/include
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
+USE_GCC= 2.95
+PORTDOCS= ABOUT POINTER
+PLIST_FILES= bin/fcplay
post-patch:
.for f in configure Config.h.in
@@ -41,9 +36,8 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/fcplay
- ${INSTALL_DATA} ${WRKSRC}/ABOUT ${PREFIX}/share/doc/fcplay
- ${INSTALL_DATA} ${WRKSRC}/POINTER ${PREFIX}/share/doc/fcplay
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>