aboutsummaryrefslogtreecommitdiff
path: root/audio/festalon
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-15 21:26:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-15 21:26:56 +0000
commit97f499d1a708c7b45d7f7b1d0b4b4d49bcf2b8c2 (patch)
tree716c9ea6aebb99db05ab48d689c0c4d859fce01c /audio/festalon
parent864bf1d378da2520a8f8e0265dbff3dcec26ba94 (diff)
downloadports-97f499d1a708c7b45d7f7b1d0b4b4d49bcf2b8c2.tar.gz
ports-97f499d1a708c7b45d7f7b1d0b4b4d49bcf2b8c2.zip
Notes
Diffstat (limited to 'audio/festalon')
-rw-r--r--audio/festalon/Makefile52
-rw-r--r--audio/festalon/distinfo2
-rw-r--r--audio/festalon/pkg-descr12
-rw-r--r--audio/festalon/pkg-message4
4 files changed, 70 insertions, 0 deletions
diff --git a/audio/festalon/Makefile b/audio/festalon/Makefile
new file mode 100644
index 000000000000..4041601d28df
--- /dev/null
+++ b/audio/festalon/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: festalon
+# Date created: 13 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= festalon
+PORTVERSION= 0.5.5
+CATEGORIES= audio
+MASTER_SITES= http://projects.raphnet.net/festalon/
+PKGNAMEPREFIX?=
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT?= A command line player for .nsf and .hes audio files
+
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+
+USE_LIBTOOL_VER=13
+USE_BZIP2= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+ONLY_FOR_ARCHS= i386 ppc
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.if ${PKGNAMEPREFIX} == ""
+
+USE_SDL= yes
+
+PLIST_FILES= bin/festalon
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/audio/festalon/distinfo b/audio/festalon/distinfo
new file mode 100644
index 000000000000..f096967facef
--- /dev/null
+++ b/audio/festalon/distinfo
@@ -0,0 +1,2 @@
+MD5 (festalon-0.5.5.tar.bz2) = ac22ab665f124bee5aa96ba9571a091c
+SIZE (festalon-0.5.5.tar.bz2) = 375613
diff --git a/audio/festalon/pkg-descr b/audio/festalon/pkg-descr
new file mode 100644
index 000000000000..cb4a2db65c57
--- /dev/null
+++ b/audio/festalon/pkg-descr
@@ -0,0 +1,12 @@
+Festalon is a command line player for .nsf and .hes audio files.
+
+It supports all internal sound channels and the extra sound channels found in
+the Konami VRC6, Konami VRC7, Namco 106, Nintendo MMC5, and Sunsoft FME-07
+chips.
+
+The extra sound channel present in the Famicom Disk System is also emulated.
+
+WWW: http://projects.raphnet.net/#festalon
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/festalon/pkg-message b/audio/festalon/pkg-message
new file mode 100644
index 000000000000..36340df12903
--- /dev/null
+++ b/audio/festalon/pkg-message
@@ -0,0 +1,4 @@
+===============================================================================
+A huge .nsf file collection can be found at:
+http://www.2a03.org/browse.php/2A03
+===============================================================================