aboutsummaryrefslogtreecommitdiff
path: root/audio/festvox-aec
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-05 01:23:00 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-05 01:23:00 +0000
commit94ca47dd0095b1afd8587a4100baddd629a48afd (patch)
treebc3c7d62af593b3ac9262c6fe5844129e4ae882c /audio/festvox-aec
parentff34c859a71a11285ab5f0b098e16cc5a49cd3dd (diff)
downloadports-94ca47dd0095b1afd8587a4100baddd629a48afd.tar.gz
ports-94ca47dd0095b1afd8587a4100baddd629a48afd.zip
Notes
Diffstat (limited to 'audio/festvox-aec')
-rw-r--r--audio/festvox-aec/Makefile49
-rw-r--r--audio/festvox-aec/distinfo3
-rw-r--r--audio/festvox-aec/pkg-descr10
3 files changed, 62 insertions, 0 deletions
diff --git a/audio/festvox-aec/Makefile b/audio/festvox-aec/Makefile
new file mode 100644
index 000000000000..828f230843fd
--- /dev/null
+++ b/audio/festvox-aec/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: festvox-aec
+# Date created: 2000-06-12
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.16 2003/04/10 01:28:05 grant Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festvox_aec
+PORTVERSION= 2.0
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_FESTIVAL_OGI}
+DISTNAME= voice_aec_di-2.0
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+COMMENT= American English male voice for Festival speech synthesis system
+
+RUN_DEPENDS= festival:${PORTSDIR}/audio/festival \
+ ${LOCALBASE}/share/festival/lib/dicts/ogi_lex.out:${PORTSDIR}/audio/festlex-ogi
+
+AECDIR= share/festival/lib/voices/english/aec_diphone
+FHOME= ${PREFIX}/share/festival
+NO_BUILD= y
+PLIST= ${WRKDIR}/plist
+RESTRICTED= "no commercial use"
+WRKSRC= ${WRKDIR}/festival
+
+post-extract:
+ ${CHMOD} -R a+r ${WRKSRC}
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in _diphone.scm diph.msec gain.dat
+ ${ECHO_CMD} ${AECDIR}/festvox/aec${ii} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} ${AECDIR}/group/aec_di_resLPC.group >> ${PLIST}
+.for ii in /group /festvox /
+ ${ECHO_CMD} @dirrm ${AECDIR}${ii} >> ${PLIST}
+.endfor
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>
diff --git a/audio/festvox-aec/distinfo b/audio/festvox-aec/distinfo
new file mode 100644
index 000000000000..96e09df20de2
--- /dev/null
+++ b/audio/festvox-aec/distinfo
@@ -0,0 +1,3 @@
+$FreeBSD$
+MD5 (festival/voice_aec_di-2.0.tar.gz) = 5fccda2123d7a1bdc9a21bb212f1f13b
+MD5 (festival/voice_aec_di-2.0.tar.gz) = 700169320da8508cf6c41f0c2f82498b
diff --git a/audio/festvox-aec/pkg-descr b/audio/festvox-aec/pkg-descr
new file mode 100644
index 000000000000..aa9f884a4758
--- /dev/null
+++ b/audio/festvox-aec/pkg-descr
@@ -0,0 +1,10 @@
+from the NetBSD maintainer:
+
+ This voice provides an American English male voice using a
+ residual excited LPC diphone synthesis module, both created
+ at OGI. It uses a lexicon compiled from MOBY and CMU
+ lexicons, and other trained modules used by CSTR voices.
+
+This voice can be activated via (voice_aec_diphone) .
+
+WWW: http://cslu.cse.ogi.edu/tts