aboutsummaryrefslogtreecommitdiff
path: root/audio/festvox-mwm/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-09-16 08:39:50 +0000
committerWill Andrews <will@FreeBSD.org>2000-09-16 08:39:50 +0000
commitbab74078a9840cb4e1407279f9c4809ecc61386e (patch)
tree9f05d5fdc8471f95e066a28da1b1201dcd87a6bc /audio/festvox-mwm/Makefile
parentebf59fced2487357447b90323740ee9f4f30a7e8 (diff)
downloadports-bab74078a9840cb4e1407279f9c4809ecc61386e.tar.gz
ports-bab74078a9840cb4e1407279f9c4809ecc61386e.zip
Notes
Diffstat (limited to 'audio/festvox-mwm/Makefile')
-rw-r--r--audio/festvox-mwm/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/audio/festvox-mwm/Makefile b/audio/festvox-mwm/Makefile
new file mode 100644
index 000000000000..7d4e84d19ba5
--- /dev/null
+++ b/audio/festvox-mwm/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: festvox-mwm
+# Date created: 2000-06-20
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.10 2000/02/15 09:26:16 agc Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festvox-mwm
+PORTVERSION= 2.0
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.leb.net/pub/blinux/festival/mirror.ogi-synth_home/ \
+ ftp://ftp.mayn.de/pub/linux/BLinux/festival/mirror.ogi-synth_home/ \
+ ftp://cslu.cse.ogi.edu/pub/tts/
+DISTNAME= voice_mwm_di-2.0
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+
+RESTRICTED= no-commercial-use
+
+RUN_DEPENDS= festival:../festival \
+ ${LOCALBASE}/share/festival/lib/dicts/wsj.wp39.poslexR:../festlex-poslex \
+ ${LOCALBASE}/share/festival/lib/dicts/ogi_lex.out:../festlex-ogi
+
+WRKSRC= ${WRKDIR}/festival
+
+NO_BUILD= yes
+
+FHOME= ${PREFIX}/share/festival
+
+post-extract:
+ @ ${CHMOD} -R a+r ${WRKSRC}
+ @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+ @ find ${WRKSRC} -type d -name CVS | xargs ${RM} -fr
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+post-install:
+ ${RM} -rf ${PREFIX}/share/festival/lib/voices/english/mwm_diphone/work
+
+.include <bsd.port.mk>