aboutsummaryrefslogtreecommitdiff
path: root/audio/festvox-rab8/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-09-16 18:59:13 +0000
committerWill Andrews <will@FreeBSD.org>2000-09-16 18:59:13 +0000
commit4f40f7b14db2feafcd9858583099e917ebad3e26 (patch)
tree4f60744e247b00994fcaa2165604e81d70b75bbf /audio/festvox-rab8/Makefile
parent358b49a6005828c743d8e235f029cdfe15e1a436 (diff)
downloadports-4f40f7b14db2feafcd9858583099e917ebad3e26.tar.gz
ports-4f40f7b14db2feafcd9858583099e917ebad3e26.zip
Notes
Diffstat (limited to 'audio/festvox-rab8/Makefile')
-rw-r--r--audio/festvox-rab8/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/festvox-rab8/Makefile b/audio/festvox-rab8/Makefile
new file mode 100644
index 000000000000..deac2d8bde46
--- /dev/null
+++ b/audio/festvox-rab8/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: festvox-rab8
+# Date created: 2000-06-15
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.12 2000/02/15 09:26:17 agc Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festvox-rab8
+PORTVERSION= 1.4.1
+CATEGORIES= audio
+MASTER_SITES= http://www.speech.cs.cmu.edu/festival/cstr/festival/1.4.1/ \
+ ftp://ftp.cstr.ed.ac.uk/pub/festival/1.4.1/
+DISTNAME= festvox_rablpc8k
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+
+RUN_DEPENDS= festival:../festival \
+ ${LOCALBASE}/share/festival/lib/dicts/wsj.wp39.poslexR:../festlex-poslex \
+ ${LOCALBASE}/share/festival/lib/dicts/oald/oaldlex.scm:../festlex-oald
+
+WRKSRC= ${WRKDIR}/festival
+
+CONFLICTS= festvox-rab16
+
+NO_BUILD= yes
+
+FHOME= ${PREFIX}/share/festival
+
+post-extract:
+ @ ${CHMOD} -R a+r ${WRKSRC}
+ @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>