aboutsummaryrefslogtreecommitdiff
path: root/audio/firefly
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-12-17 20:00:53 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-12-17 20:00:53 +0000
commit5e5f13273bfb59ce14281d3eeaf7c4cff8a5161c (patch)
treec796e826953739f3e95ee742874bca87474268df /audio/firefly
parent14355efa7a38558d01d999a1b36e957f90fab7d3 (diff)
Notes
Diffstat (limited to 'audio/firefly')
-rw-r--r--audio/firefly/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index 7fdd60356ca6..fb836d2f9e77 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: mt-daapd-devel
-# Date created: 26 Nov 2007
-# Whom: Mark Foster <mark@foster.cc>
+# Created by: Mark Foster <mark@foster.cc>
# $FreeBSD$
#
@@ -22,8 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/vorbis/codec.h:${PORTSDIR}/audio/libvorbis \
RUN_DEPENDS= oggdec:${PORTSDIR}/audio/vorbis-tools \
flac:${PORTSDIR}/audio/flac
LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- id3tag.0:${PORTSDIR}/audio/libid3tag
+ sqlite3:${PORTSDIR}/databases/sqlite3 \
+ id3tag:${PORTSDIR}/audio/libid3tag
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -47,11 +45,12 @@ USE_LDCONFIG= yes
USE_GCC= any
-OPTIONS= JAPANESE "Japanese support in ID3 tags" off
+OPTIONS_DEFINE= JAPANESE
+JAPANESE_DESC= Japanese support in ID3 tags
.include <bsd.port.options.mk>
-.if defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MJAPANESE}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_scan-mp3.c
USE_ICONV= yes
CONFIGURE_ARGS+= --enable-iconv