aboutsummaryrefslogtreecommitdiff
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-01-19 16:54:57 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-01-19 16:54:57 +0000
commit32cb3f1df749afdd38c89c685defd512815c028a (patch)
tree1f6a57b0962eb5572c6a263e6246982990b26d76 /audio/flac/Makefile
parente90c4b51fa45458d4fb94159bd60dacc765092d7 (diff)
downloadports-32cb3f1df749afdd38c89c685defd512815c028a.tar.gz
ports-32cb3f1df749afdd38c89c685defd512815c028a.zip
Notes
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index a2b947f5a39e..621a1bc2fac8 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# New ports collection makefile for: flac
# Date created: Mar 18, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
@@ -7,7 +6,7 @@
#
PORTNAME= flac
-PORTVERSION= 1.0
+PORTVERSION= 1.0.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,38 +14,43 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= naddy@FreeBSD.org
+LIB_DEPENDS= ogg.3:${PORTSDIR}/audio/libogg
+
.if defined(WITH_XMMS)
BUILD_DEPENDS+= xmms-config:${PORTSDIR}/audio/xmms
-LIB_DEPENDS+= xmms.2:${PORTSDIR}/audio/xmms
+LIB_DEPENDS+= xmms.3:${PORTSDIR}/audio/xmms
PLIST_SUB= XMMS=""
.else
+CONFIGURE_ENV+= XMMS_CONFIG=/usr/bin/false # must be absolute path
PLIST_SUB= XMMS="@comment "
.endif
.if ${MACHINE_ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+CONFIGURE_ARGS+= --enable-sse --enable-3dnow
.endif
-USE_AUTOMAKE_VER=14
-AUTOMAKE_ARGS= --include-deps
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV= INCLUDES="-I${WRKSRC}/include"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALLS_SHLIB= yes
MAN1= flac.1
-post-extract:
+pre-build:
@${RM} -r ${WRKSRC}/obj
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/flac
+ cd ${WRKSRC}/doc; ${INSTALL_DATA} *.html ${PREFIX}/share/doc/flac
${MKDIR} ${PREFIX}/share/doc/flac/images
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/flac
-.for file in 1x1.gif cafebug.gif logo.jpg
- ${INSTALL_DATA} ${WRKSRC}/doc/images/${file} ${PREFIX}/share/doc/flac/images
-.endfor
+ cd ${WRKSRC}/doc/images; \
+ ${INSTALL_DATA} *.gif *.jpg ${PREFIX}/share/doc/flac/images
.endif
.include <bsd.port.mk>