aboutsummaryrefslogtreecommitdiff
path: root/audio/flacon
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-31 00:59:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-31 00:59:54 +0000
commit0fa5408489ae026991a26a29b7137ce1950b8e4d (patch)
tree1f13cfdafa625fbbab54cfdc7c5a9faada19d5e7 /audio/flacon
parentbb0d4e1cff52e6609f2090810218c5d4bcbcf0e7 (diff)
downloadports-0fa5408489ae026991a26a29b7137ce1950b8e4d.tar.gz
ports-0fa5408489ae026991a26a29b7137ce1950b8e4d.zip
Notes
Diffstat (limited to 'audio/flacon')
-rw-r--r--audio/flacon/Makefile4
-rw-r--r--audio/flacon/distinfo4
-rw-r--r--audio/flacon/files/patch-inputaudiofile.cpp22
-rw-r--r--audio/flacon/pkg-plist2
4 files changed, 28 insertions, 4 deletions
diff --git a/audio/flacon/Makefile b/audio/flacon/Makefile
index a09e15b37a0c..24173e375f7b 100644
--- a/audio/flacon/Makefile
+++ b/audio/flacon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flacon
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.0
+DISTVERSION= 2.0.0
CATEGORIES= audio
MAINTAINER= danfe@FreeBSD.org
@@ -20,7 +20,7 @@ USES= cmake desktop-file-utils pkgconfig
OPTIONS_DEFINE= QT5
QT5_DESC= Build against Qt 5 instead of Qt 4
-QT5_CMAKE_ARGS= -DUSE_QT5:BOOL=ON
+QT5_CMAKE_ON= -DUSE_QT5:BOOL=ON
# :ts, would be handy here but is not available in fmake(1)
QT5_USE= QT5=${_QT5_DEPS},${_QT5_BDEPS:C/,/_build&/g:%=_build}
QT5_USE_OFF= QT4=${_QT4_DEPS},${_QT4_BDEPS:C/,/_build&/g:%=_build}
diff --git a/audio/flacon/distinfo b/audio/flacon/distinfo
index 0e7ec5ebfe1c..0f22ece370a8 100644
--- a/audio/flacon/distinfo
+++ b/audio/flacon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flacon-flacon-v1.2.0_GH0.tar.gz) = 2ebc83d733ea6d50f2bd4ad8c20c65368be5eaf351e0195c9b4d47a54957b8f8
-SIZE (flacon-flacon-v1.2.0_GH0.tar.gz) = 283187
+SHA256 (flacon-flacon-v2.0.0_GH0.tar.gz) = abd6420d8c686bc19f148d9f4b220474939a998d9a214106b5a9c1e2058107f3
+SIZE (flacon-flacon-v2.0.0_GH0.tar.gz) = 317343
diff --git a/audio/flacon/files/patch-inputaudiofile.cpp b/audio/flacon/files/patch-inputaudiofile.cpp
new file mode 100644
index 000000000000..295bf4c9e732
--- /dev/null
+++ b/audio/flacon/files/patch-inputaudiofile.cpp
@@ -0,0 +1,22 @@
+--- inputaudiofile.cpp.orig 2016-01-29 18:07:49 UTC
++++ inputaudiofile.cpp
+@@ -135,8 +135,8 @@ bool InputAudioFile::load()
+ {
+ qWarning("------------------------------------");
+ qWarning() << "Test audio command:" << (shntool + " " + args.join(" "));
+- qWarning() << "shntool info waitForFinished faild";
+- qWarning(proc.readAllStandardError());
++ qWarning() << "shntool info waitForFinished failed";
++ qWarning() << proc.readAllStandardError();
+ qWarning("------------------------------------");
+ return false;
+ }
+@@ -147,7 +147,7 @@ bool InputAudioFile::load()
+ qWarning("------------------------------------");
+ qWarning() << "Test audio command:" << (shntool + " " + args.join(" "));
+ qWarning() << "shntool info nonzero exit code:" << proc.exitCode();
+- qWarning(proc.readAllStandardError());
++ qWarning() << proc.readAllStandardError();
+ qWarning("------------------------------------");
+ mErrorString = QObject::tr("File <b>%1</b> is not a supported audio file. <br>"
+ "<br>Verify that all required programs are installed and in your preferences.").arg(mFileName);
diff --git a/audio/flacon/pkg-plist b/audio/flacon/pkg-plist
index d75d702ad3a5..370cc6a3ff45 100644
--- a/audio/flacon/pkg-plist
+++ b/audio/flacon/pkg-plist
@@ -9,12 +9,14 @@ share/icons/hicolor/48x48/apps/flacon.png
%%DATADIR%%/translations/flacon_de.qm
%%DATADIR%%/translations/flacon_es.qm
%%DATADIR%%/translations/flacon_es_MX.qm
+%%DATADIR%%/translations/flacon_et.qm
%%DATADIR%%/translations/flacon_fr.qm
%%DATADIR%%/translations/flacon_gl.qm
%%DATADIR%%/translations/flacon_hu.qm
%%DATADIR%%/translations/flacon_it.qm
%%DATADIR%%/translations/flacon_ja_JP.qm
%%DATADIR%%/translations/flacon_lt.qm
+%%DATADIR%%/translations/flacon_nb.qm
%%DATADIR%%/translations/flacon_pl.qm
%%DATADIR%%/translations/flacon_pl_PL.qm
%%DATADIR%%/translations/flacon_pt_BR.qm