aboutsummaryrefslogtreecommitdiff
path: root/audio/fluidsynth/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:34:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-04 09:34:00 +0000
commit219658944f0e1f3e923f6f910c98bd77d552e3c4 (patch)
treef7a9b3604c2dee9123472c1d3537802b0fc2109f /audio/fluidsynth/files
parentb073432c251654846d40c4d9928c32f27da20193 (diff)
downloadports-219658944f0e1f3e923f6f910c98bd77d552e3c4.tar.gz
ports-219658944f0e1f3e923f6f910c98bd77d552e3c4.zip
Notes
Diffstat (limited to 'audio/fluidsynth/files')
-rw-r--r--audio/fluidsynth/files/patch-src__CMakeLists.txt59
-rw-r--r--audio/fluidsynth/files/patch-src__drivers__fluid_oss.c15
2 files changed, 15 insertions, 59 deletions
diff --git a/audio/fluidsynth/files/patch-src__CMakeLists.txt b/audio/fluidsynth/files/patch-src__CMakeLists.txt
deleted file mode 100644
index 9798836a1da0..000000000000
--- a/audio/fluidsynth/files/patch-src__CMakeLists.txt
+++ /dev/null
@@ -1,59 +0,0 @@
---- src/CMakeLists.txt.orig 2011-09-04 16:38:58.000000000 +0900
-+++ src/CMakeLists.txt 2011-09-05 16:30:18.000000000 +0900
-@@ -42,6 +42,11 @@
- include_directories ( ${READLINE_INCLUDE_DIR} )
- endif ( READLINE_SUPPORT )
-
-+if ( PORTAUDIO_SUPPORT )
-+ set ( fluid_portaudio_SOURCES drivers/fluid_portaudio.c )
-+ include_directories ( ${PORTAUDIO_INCLUDEDIR} ${PORTAUDIO_INCLUDE_DIRS} )
-+endif ( PORTAUDIO_SUPPORT )
-+
- if ( PULSE_SUPPORT )
- set ( fluid_pulse_SOURCES drivers/fluid_pulse.c )
- include_directories ( ${PULSE_INCLUDEDIR} ${PULSE_INCLUDE_DIRS} )
-@@ -70,11 +75,6 @@
- include_directories ( ${JACK_INCLUDEDIR} ${JACK_INCLUDE_DIRS} )
- endif ( JACK_SUPPORT )
-
--if ( PORTAUDIO_SUPPORT )
-- set ( fluid_portaudio_SOURCES drivers/fluid_portaudio.c )
-- include_directories ( ${PORTAUDIO_INCLUDEDIR} ${PORTAUDIO_INCLUDE_DIRS} )
--endif ( PORTAUDIO_SUPPORT )
--
- if ( WINDOWS_SUPPORT )
- set ( fluid_windows_SOURCES fluid_dll.c drivers/fluid_dsound.c drivers/fluid_winmidi.c )
- endif ( WINDOWS_SUPPORT )
-@@ -207,6 +207,8 @@
- )
-
- link_directories (
-+ ${PORTAUDIO_LIBDIR}
-+ ${PORTAUDIO_LIBRARY_DIRS}
- ${GLIB_LIBDIR}
- ${GLIB_LIBRARY_DIRS}
- ${LASH_LIBDIR}
-@@ -219,8 +221,6 @@
- ${ALSA_LIBRARY_DIRS}
- ${PULSE_LIBDIR}
- ${PULSE_LIBRARY_DIRS}
-- ${PORTAUDIO_LIBDIR}
-- ${PORTAUDIO_LIBRARY_DIRS}
- ${LIBSNDFILE_LIBDIR}
- ${LIBSNDFILE_LIBRARY_DIRS}
- ${DBUS_LIBDIR}
-@@ -280,13 +280,13 @@
- endif ( LIBFLUID_CPPFLAGS )
-
- target_link_libraries ( libfluidsynth
-+ ${PORTAUDIO_LIBRARIES}
- ${GLIB_LIBRARIES}
- ${LASH_LIBRARIES}
- ${LADCCA_LIBRARIES}
- ${JACK_LIBRARIES}
- ${ALSA_LIBRARIES}
- ${PULSE_LIBRARIES}
-- ${PORTAUDIO_LIBRARIES}
- ${LIBSNDFILE_LIBRARIES}
- ${DBUS_LIBRARIES}
- ${READLINE_LIBS}
diff --git a/audio/fluidsynth/files/patch-src__drivers__fluid_oss.c b/audio/fluidsynth/files/patch-src__drivers__fluid_oss.c
new file mode 100644
index 000000000000..dea1fe2b54a9
--- /dev/null
+++ b/audio/fluidsynth/files/patch-src__drivers__fluid_oss.c
@@ -0,0 +1,15 @@
+--- src/drivers/fluid_oss.c.orig 2012-08-16 13:01:13.000000000 +0900
++++ src/drivers/fluid_oss.c 2012-08-18 04:12:09.000000000 +0900
+@@ -45,9 +45,9 @@
+ #define BUFFER_LENGTH 512
+
+ // Build issue on some systems (OSS 4.0)?
+-#ifdef SNDCTL_DSP_CHANNELS
+- #define SOUND_PCM_WRITE_CHANNELS SNDCTL_DSP_CHANNELS
+-#endif
++// #ifdef SNDCTL_DSP_CHANNELS
++// #define SOUND_PCM_WRITE_CHANNELS SNDCTL_DSP_CHANNELS
++// #endif
+
+ /** fluid_oss_audio_driver_t
+ *