aboutsummaryrefslogtreecommitdiff
path: root/audio/fluidsynth
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-06-01 21:44:32 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-06-01 21:44:32 +0000
commit59c613cbf7bebbdc023bf8a991ec226bf42938b5 (patch)
tree28554f5d0ab4d63d2289b60f6991489be8beb245 /audio/fluidsynth
parent9293b362836b1d5bfd08eaf9735b6057379c496f (diff)
downloadports-59c613cbf7bebbdc023bf8a991ec226bf42938b5.tar.gz
ports-59c613cbf7bebbdc023bf8a991ec226bf42938b5.zip
Notes
Diffstat (limited to 'audio/fluidsynth')
-rw-r--r--audio/fluidsynth/Makefile15
-rw-r--r--audio/fluidsynth/distinfo5
-rw-r--r--audio/fluidsynth/files/patch-CMakeLists.txt32
-rw-r--r--audio/fluidsynth/files/patch-src_drivers_fluid__adriver.c32
-rw-r--r--audio/fluidsynth/files/patch-src_drivers_fluid__alsa.c20
-rw-r--r--audio/fluidsynth/files/patch-src_drivers_fluid__oss.c6
-rw-r--r--audio/fluidsynth/pkg-plist2
7 files changed, 47 insertions, 65 deletions
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index c9a37fd79750..67936141755c 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -2,27 +2,28 @@
# $FreeBSD$
PORTNAME= fluidsynth
-PORTVERSION= 1.1.6
-PORTREVISION= 5
+PORTVERSION= 1.1.11
+DISTVERSIONPREFIX= v
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Real-time software synthesizer based on the SoundFont 2 specifications
-LICENSE= LGPL20+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+GH_ACCOUNT= FluidSynth
OPTIONS_DEFINE= JACK ALSA DBUS LADSPA LASH PORTAUDIO PULSEAUDIO READLINE \
SNDFILE SNDIO
OPTIONS_DEFAULT= JACK READLINE
USES= cmake pkgconfig tar:bzip2
+USE_GITHUB= yes
USE_GNOME= glib20
+USE_LDCONFIG= yes
CMAKE_ARGS= -Denable-ladcca:BOOL=FALSE \
-Denable-midishare:BOOL=FALSE
-USE_LDCONFIG= yes
-
LDFLAGS+= -lpthread
JACK_LIB_DEPENDS= libjack.so:audio/jack
diff --git a/audio/fluidsynth/distinfo b/audio/fluidsynth/distinfo
index 54588ac43729..17d726a00928 100644
--- a/audio/fluidsynth/distinfo
+++ b/audio/fluidsynth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fluidsynth-1.1.6.tar.bz2) = d28b47dfbf7f8e426902ae7fa2981d821fbf84f41da9e1b85be933d2d748f601
-SIZE (fluidsynth-1.1.6.tar.bz2) = 823783
+TIMESTAMP = 1527888754
+SHA256 (FluidSynth-fluidsynth-v1.1.11_GH0.tar.gz) = da8878ff374d12392eecf87e96bad8711b8e76a154c25a571dd8614d1af80de8
+SIZE (FluidSynth-fluidsynth-v1.1.11_GH0.tar.gz) = 634566
diff --git a/audio/fluidsynth/files/patch-CMakeLists.txt b/audio/fluidsynth/files/patch-CMakeLists.txt
index 680dba236fda..4a521b894da9 100644
--- a/audio/fluidsynth/files/patch-CMakeLists.txt
+++ b/audio/fluidsynth/files/patch-CMakeLists.txt
@@ -1,22 +1,22 @@
---- CMakeLists.txt.orig 2012-08-16 04:01:13 UTC
+--- CMakeLists.txt.orig 2018-05-06 07:05:11 UTC
+++ CMakeLists.txt
-@@ -61,6 +61,7 @@ option ( enable-debug "enable debugging
- option ( enable-libsndfile "compile libsndfile support (if it is available)" on )
- option ( enable-aufile "compile support for sound file output" on )
+@@ -68,6 +68,7 @@ option ( enable-midishare "compile MidiS
+ option ( enable-oss "compile OSS support (if it is available)" on )
+ option ( enable-pkgconfig "use pkg-config to locate fluidsynth's (mostly optional) dependencies" on )
option ( enable-pulseaudio "compile PulseAudio support (if it is available)" on )
+option ( enable-sndio "compile Sndio support (if it is available)" on )
- option ( enable-jack "compile JACK support (if it is available)" on )
- option ( enable-midishare "compile MidiShare support (if it is available)" on )
option ( enable-readline "compile readline lib line editing (if it is available)" on )
-@@ -313,6 +314,11 @@ else ( enable-pulseaudio )
- unset_pkg_config ( PULSE )
- endif ( enable-pulseaudio )
-+unset ( SNDIO_SUPPORT CACHE )
-+if ( enable-sndio )
-+ set ( SNDIO_SUPPORT 1 )
-+endif ( enable-sndio )
+ # Platform specific options
+@@ -358,6 +359,11 @@ else(NOT enable-pkgconfig)
+ unset_pkg_config ( PULSE )
+ endif ( enable-pulseaudio )
+
++ unset ( SNDIO_SUPPORT CACHE )
++ if ( enable-sndio )
++ set ( SNDIO_SUPPORT 1 )
++ endif ( enable-sndio )
+
- unset ( ALSA_SUPPORT CACHE )
- if ( enable-alsa )
- pkg_check_modules ( ALSA alsa>=0.9.1 )
+ unset ( ALSA_SUPPORT CACHE )
+ if ( enable-alsa )
+ pkg_check_modules ( ALSA alsa>=0.9.1 )
diff --git a/audio/fluidsynth/files/patch-src_drivers_fluid__adriver.c b/audio/fluidsynth/files/patch-src_drivers_fluid__adriver.c
index f2c6dc432db8..358b8d24827b 100644
--- a/audio/fluidsynth/files/patch-src_drivers_fluid__adriver.c
+++ b/audio/fluidsynth/files/patch-src_drivers_fluid__adriver.c
@@ -1,5 +1,4 @@
-$OpenBSD: patch-src_drivers_fluid_adriver_c,v 1.1 2013/03/29 12:37:43 sthen Exp $
---- src/drivers/fluid_adriver.c.orig 2012-08-16 04:01:13 UTC
+--- src/drivers/fluid_adriver.c.orig 2018-05-06 07:05:11 UTC
+++ src/drivers/fluid_adriver.c
@@ -64,6 +64,15 @@ int delete_fluid_oss_audio_driver(fluid_
void fluid_oss_audio_driver_settings(fluid_settings_t* settings);
@@ -7,9 +6,9 @@ $OpenBSD: patch-src_drivers_fluid_adriver_c,v 1.1 2013/03/29 12:37:43 sthen Exp
+#if SNDIO_SUPPORT
+fluid_audio_driver_t* new_fluid_sndio_audio_driver(fluid_settings_t* settings,
-+ fluid_synth_t* synth);
++ fluid_synth_t* synth);
+fluid_audio_driver_t* new_fluid_sndio_audio_driver2(fluid_settings_t* settings,
-+ fluid_audio_func_t func, void* data);
++ fluid_audio_func_t func, void* data);
+int delete_fluid_sndio_audio_driver(fluid_audio_driver_t* p);
+void fluid_sndio_audio_driver_settings(fluid_settings_t* settings);
+#endif
@@ -17,21 +16,22 @@ $OpenBSD: patch-src_drivers_fluid_adriver_c,v 1.1 2013/03/29 12:37:43 sthen Exp
#if COREAUDIO_SUPPORT
fluid_audio_driver_t* new_fluid_core_audio_driver(fluid_settings_t* settings,
fluid_synth_t* synth);
-@@ -120,6 +129,13 @@ int delete_fluid_file_audio_driver(fluid
-
+@@ -122,6 +131,14 @@ int delete_fluid_file_audio_driver(fluid
/* Available audio drivers, listed in order of preference */
- fluid_audriver_definition_t fluid_audio_drivers[] = {
+ static const fluid_audriver_definition_t fluid_audio_drivers[] =
+ {
+#if SNDIO_SUPPORT
-+ { "sndio",
-+ new_fluid_sndio_audio_driver,
-+ new_fluid_sndio_audio_driver2,
-+ delete_fluid_sndio_audio_driver,
-+ fluid_sndio_audio_driver_settings },
++ { "sndio",
++ new_fluid_sndio_audio_driver,
++ new_fluid_sndio_audio_driver2,
++ delete_fluid_sndio_audio_driver,
++ fluid_sndio_audio_driver_settings },
+#endif
++
#if JACK_SUPPORT
- { "jack",
- new_fluid_jack_audio_driver,
-@@ -223,7 +239,9 @@ void fluid_audio_driver_settings(fluid_s
+ { "jack",
+ new_fluid_jack_audio_driver,
+@@ -238,7 +255,9 @@ void fluid_audio_driver_settings(fluid_s
FLUID_DEFAULT_AUDIO_RT_PRIO, 0, 99, 0, NULL, NULL);
/* Set the default driver */
@@ -42,7 +42,7 @@ $OpenBSD: patch-src_drivers_fluid_adriver_c,v 1.1 2013/03/29 12:37:43 sthen Exp
fluid_settings_register_str(settings, "audio.driver", "jack", 0, NULL, NULL);
#elif ALSA_SUPPORT
fluid_settings_register_str(settings, "audio.driver", "alsa", 0, NULL, NULL);
-@@ -257,6 +275,9 @@ void fluid_audio_driver_settings(fluid_s
+@@ -272,6 +291,9 @@ void fluid_audio_driver_settings(fluid_s
#if OSS_SUPPORT
fluid_settings_add_option(settings, "audio.driver", "oss");
#endif
diff --git a/audio/fluidsynth/files/patch-src_drivers_fluid__alsa.c b/audio/fluidsynth/files/patch-src_drivers_fluid__alsa.c
deleted file mode 100644
index bfa0dfb93968..000000000000
--- a/audio/fluidsynth/files/patch-src_drivers_fluid__alsa.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/drivers/fluid_alsa.c.orig 2012-08-16 04:01:13 UTC
-+++ src/drivers/fluid_alsa.c
-@@ -347,14 +347,16 @@ static int fluid_alsa_handle_write_error
- case -EAGAIN:
- snd_pcm_wait(pcm, 1);
- break;
-- case -EPIPE:
- case -EBADFD:
- if (snd_pcm_prepare(pcm) != 0) {
- FLUID_LOG(FLUID_ERR, "Failed to prepare the audio device");
- return FLUID_FAILED;
- }
- break;
-+ case -EPIPE:
-+#if EPIPE != ESTRPIPE
- case -ESTRPIPE:
-+#endif
- if ((snd_pcm_resume(pcm) != 0) && (snd_pcm_prepare(pcm) != 0)) {
- FLUID_LOG(FLUID_ERR, "Failed to resume the audio device");
- return FLUID_FAILED;
diff --git a/audio/fluidsynth/files/patch-src_drivers_fluid__oss.c b/audio/fluidsynth/files/patch-src_drivers_fluid__oss.c
index dc5089f4b636..42e5d83a62e8 100644
--- a/audio/fluidsynth/files/patch-src_drivers_fluid__oss.c
+++ b/audio/fluidsynth/files/patch-src_drivers_fluid__oss.c
@@ -1,13 +1,13 @@
---- src/drivers/fluid_oss.c.orig 2012-08-16 04:01:13 UTC
+--- src/drivers/fluid_oss.c.orig 2018-05-06 07:05:11 UTC
+++ src/drivers/fluid_oss.c
@@ -45,9 +45,9 @@
#define BUFFER_LENGTH 512
// Build issue on some systems (OSS 4.0)?
--#ifdef SNDCTL_DSP_CHANNELS
+-#if !defined(SOUND_PCM_WRITE_CHANNELS) && defined(SNDCTL_DSP_CHANNELS)
- #define SOUND_PCM_WRITE_CHANNELS SNDCTL_DSP_CHANNELS
-#endif
-+// #ifdef SNDCTL_DSP_CHANNELS
++// #if !defined(SOUND_PCM_WRITE_CHANNELS) && defined(SNDCTL_DSP_CHANNELS)
+// #define SOUND_PCM_WRITE_CHANNELS SNDCTL_DSP_CHANNELS
+// #endif
diff --git a/audio/fluidsynth/pkg-plist b/audio/fluidsynth/pkg-plist
index 6220eec2be95..27c7c87fceea 100644
--- a/audio/fluidsynth/pkg-plist
+++ b/audio/fluidsynth/pkg-plist
@@ -19,6 +19,6 @@ include/fluidsynth/version.h
include/fluidsynth/voice.h
lib/libfluidsynth.so
lib/libfluidsynth.so.1
-lib/libfluidsynth.so.1.5.2
+lib/libfluidsynth.so.1.7.2
libdata/pkgconfig/fluidsynth.pc
man/man1/fluidsynth.1.gz