aboutsummaryrefslogtreecommitdiff
path: root/audio/fmit
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2007-09-08 18:28:13 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2007-09-08 18:28:13 +0000
commit25e8e16b8e4299be43f9df10be19311bbbf4e3b5 (patch)
treef462425097654608914cd753aee6ce16f12fd9ce /audio/fmit
parentcb7992852a2ab063bb05e3ac79c1f854f1d4b902 (diff)
downloadports-25e8e16b8e4299be43f9df10be19311bbbf4e3b5.tar.gz
ports-25e8e16b8e4299be43f9df10be19311bbbf4e3b5.zip
Notes
Diffstat (limited to 'audio/fmit')
-rw-r--r--audio/fmit/Makefile26
-rw-r--r--audio/fmit/distinfo3
-rw-r--r--audio/fmit/pkg-descr15
-rw-r--r--audio/fmit/pkg-plist9
4 files changed, 53 insertions, 0 deletions
diff --git a/audio/fmit/Makefile b/audio/fmit/Makefile
new file mode 100644
index 000000000000..e35a57655ccd
--- /dev/null
+++ b/audio/fmit/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: fmit
+# Date created: 2007-09-08
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fmit
+PORTVERSION= 0.97.6
+CATEGORIES= audio
+MASTER_SITES= http://download.gna.org/fmit/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Free Music Instrument Tuner
+
+LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
+ fftw3.4:${PORTSDIR}/math/fftw3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-alsa bnv_cv_qt_test_result=yes
+CONFIGURE_ENV+= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_QT_VER= 3
+USE_GL= glut glu gl
+
+.include <bsd.port.mk>
diff --git a/audio/fmit/distinfo b/audio/fmit/distinfo
new file mode 100644
index 000000000000..6ca86cc3fac2
--- /dev/null
+++ b/audio/fmit/distinfo
@@ -0,0 +1,3 @@
+MD5 (fmit-0.97.6.tar.gz) = d641fb7ee726daf0c81d8434348beaaf
+SHA256 (fmit-0.97.6.tar.gz) = 60c61c3e14b0b71e96eca8318fb61787f64b3c1c82f5c7893a09d364aed3293b
+SIZE (fmit-0.97.6.tar.gz) = 273122
diff --git a/audio/fmit/pkg-descr b/audio/fmit/pkg-descr
new file mode 100644
index 000000000000..9d5f6ac8e91c
--- /dev/null
+++ b/audio/fmit/pkg-descr
@@ -0,0 +1,15 @@
+Free Music Instrument Tuner.
+
+Current features:
+
+ - Error history
+ - Volume history
+ - Wave shape
+ - Harmonic ratios
+ - Statistics
+ - Microtonal tuning (with Scala file support)
+ - Discrete Fourier Transform view
+ - JACK, OSS, ALSA, Portaudio support
+ - Translations for: french
+
+WWW: http://home.gna.org/fmit/
diff --git a/audio/fmit/pkg-plist b/audio/fmit/pkg-plist
new file mode 100644
index 000000000000..940418032848
--- /dev/null
+++ b/audio/fmit/pkg-plist
@@ -0,0 +1,9 @@
+bin/fmit
+lib/libCppAddons.a
+lib/libMusic.a
+lib/libmodules.a
+share/fmit/tr/fmit_fr.qm
+@dirrm share/fmit/tr
+@dirrm share/fmit
+share/applications/fmit.desktop
+@dirrmtry share/applications