aboutsummaryrefslogtreecommitdiff
path: root/audio/funktrackergold/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-06 17:41:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-06 17:41:16 +0000
commit85feee963c412a77f36c3ee8b6b4d0e23fda9ec8 (patch)
tree19924732a97beea24aaea602ac15d375cd63d100 /audio/funktrackergold/Makefile
parentcc561bcda964ce8fee055f69efd117d52c7a4217 (diff)
downloadports-85feee963c412a77f36c3ee8b6b4d0e23fda9ec8.tar.gz
ports-85feee963c412a77f36c3ee8b6b4d0e23fda9ec8.zip
Notes
Diffstat (limited to 'audio/funktrackergold/Makefile')
-rw-r--r--audio/funktrackergold/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index ff9118890b1e..ce6b5cf7ab85 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -11,12 +11,13 @@ DISTNAME= funktrackergold-1.5-2
EXTRACT_SUFX= .tgz
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= A curses MOD/FNK music tracker
+COMMENT= Curses MOD/FNK music tracker
+
+OPTIONS_DEFINE= DOCS
LICENSE= GPLv2
-USE_GCC= any
-NO_STAGE= yes
+USES= compiler:nestedfct
WRKSRC= ${WRKDIR}/funkgold
MAKE_ARGS= EXTRA_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -27,15 +28,11 @@ PLIST_FILES= bin/funkgold
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/funkgold ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/funkgold ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>