aboutsummaryrefslogtreecommitdiff
path: root/audio/gai-album/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-15 21:37:29 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-15 21:37:29 +0000
commit02eda50bf08732083fb333cb9e2e663e8937216b (patch)
tree3b82c912e26e4742014a18324a77da7659d0f651 /audio/gai-album/Makefile
parent2a2571afa11361f81fee43e139d35f5ed2755a9e (diff)
Notes
Diffstat (limited to 'audio/gai-album/Makefile')
-rw-r--r--audio/gai-album/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/gai-album/Makefile b/audio/gai-album/Makefile
new file mode 100644
index 000000000000..9b69fda8048a
--- /dev/null
+++ b/audio/gai-album/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gai-album
+# Date created: 2005-02-10
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gai-album
+PORTVERSION= 0.7
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gai
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A GAI dockapp for viewing xmms visualizations
+
+LIB_DEPENDS= gai:${PORTSDIR}/x11-toolkits/gai \
+ xmms:${PORTSDIR}/multimedia/xmms
+
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|\(GNOMEDIR=\).*|\1"${PREFIX}"|; \
+ s|share\(/pixmaps\)|share/gnome\1|; \
+ s|:GNOME_|:GAI-|g; \
+ s|\(@APPLET_NAME@\)\(Applet\)|\1-\2|g; \
+ s|\(Applet\)_\(Factory\)|\1-\2|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|lib\(/bonobo\)|libdata\1|; \
+ s|share\(/pixmaps\)|share/gnome\1|; \
+ s|-O3||' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>