aboutsummaryrefslogtreecommitdiff
path: root/audio/gbsplay
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-28 18:11:44 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-28 18:11:44 +0000
commit71d63a1a04ac9cb2f7e2bddf4517ac4c7a404141 (patch)
treed4352f60c5017bf8f7ac6f9034e0899eb15a2196 /audio/gbsplay
parent97188e3aaaf4b950cfd0611c52b932b8aaa85c74 (diff)
downloadports-71d63a1a04ac9cb2f7e2bddf4517ac4c7a404141.tar.gz
ports-71d63a1a04ac9cb2f7e2bddf4517ac4c7a404141.zip
Notes
Diffstat (limited to 'audio/gbsplay')
-rw-r--r--audio/gbsplay/Makefile93
-rw-r--r--audio/gbsplay/distinfo2
-rw-r--r--audio/gbsplay/pkg-descr8
-rw-r--r--audio/gbsplay/pkg-plist9
4 files changed, 112 insertions, 0 deletions
diff --git a/audio/gbsplay/Makefile b/audio/gbsplay/Makefile
new file mode 100644
index 000000000000..387369efb812
--- /dev/null
+++ b/audio/gbsplay/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: gbsplay
+# Date created: 25 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbsplay
+PORTVERSION= 0.0.7
+CATEGORIES= audio
+MASTER_SITES= http://download.berlios.de/gbsplay/
+PKGNAMEPREFIX?=
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT?= Emulates the sound hardware of the Nintendo Game Boy(TM)
+
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+
+.if ${PKGNAMEPREFIX} == ""
+
+CONFIGURE_ARGS+= --without-xmmsplugin
+
+MAN1= gbsplay.1 gbsinfo.1
+MAN5= gbsplayrc.5
+PORTDOCS= COPYRIGHT HISTORY README
+
+OPTIONS= NAS "NAS sound output" on
+
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PKGNAMEPREFIX} == ""
+
+.if defined(WITH_NAS)
+LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+.else
+CONFIGURE_ARGS+= --disable-nas
+.endif
+
+.endif
+
+post-patch: gbsplay-post-patch
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/include|${LOCALBASE}/include|; \
+ s|/usr/local/lib|${LOCALBASE}/lib|; \
+ s|/usr/X11R6/include|${X11BASE}/include|; \
+ s|/usr/X11R6/lib|${X11BASE}/lib|; \
+ s|-Os||; s|-pipe||; s|-fomit-frame-pointer||; \
+ s|-march=$$ARCH||' ${WRKSRC}/configure
+
+.if ${PKGNAMEPREFIX} == ""
+
+gbsplay-post-patch:
+ @${REINPLACE_CMD} -e 's|/\(etc/gbsplayrc\)|${PREFIX}/\1|' \
+ ${WRKSRC}/gbsplay.c \
+ ${WRKSRC}/gbsplay.in.1 \
+ ${WRKSRC}/gbsplayrc.in.5
+
+do-install:
+.for f in ${PORTNAME} gbsinfo
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+.for f in ${MAN1} ${MAN5}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${MAN${f:E}PREFIX}/man/man${f:E}
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/nightmode.gbs ${EXAMPLESDIR}
+
+ ${INSTALL_DATA} ${WRKSRC}/examples/gbsplayrc_sample ${PREFIX}/etc/gbsplayrc.default
+.if !exists(${PREFIX}/etc/gbsplayrc)
+ ${INSTALL_DATA} ${WRKSRC}/examples/gbsplayrc_sample ${PREFIX}/etc/gbsplayrc
+.endif
+
+.for l in de en
+ ${INSTALL_DATA} ${WRKSRC}/po/${l}.mo ${PREFIX}/share/locale/${l}/LC_MESSAGES/gbsplay.mo
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/gbsplay/distinfo b/audio/gbsplay/distinfo
new file mode 100644
index 000000000000..42fbdd5fec15
--- /dev/null
+++ b/audio/gbsplay/distinfo
@@ -0,0 +1,2 @@
+MD5 (gbsplay-0.0.7.tar.gz) = bdd9143422c52d00a8aeeda171621cec
+SIZE (gbsplay-0.0.7.tar.gz) = 50466
diff --git a/audio/gbsplay/pkg-descr b/audio/gbsplay/pkg-descr
new file mode 100644
index 000000000000..332ee01c2ac8
--- /dev/null
+++ b/audio/gbsplay/pkg-descr
@@ -0,0 +1,8 @@
+gbsplay emulates the sound hardware of the Nintendo Game Boy(TM). It is able
+to play the sounds from a Game Boy(TM) module dump (.GBS format) through
+/dev/dsp, standard output or NAS.
+
+WWW: http://gbsplay.berlios.de/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/gbsplay/pkg-plist b/audio/gbsplay/pkg-plist
new file mode 100644
index 000000000000..de029cbef667
--- /dev/null
+++ b/audio/gbsplay/pkg-plist
@@ -0,0 +1,9 @@
+bin/gbsplay
+bin/gbsinfo
+@unexec if cmp -s %D/etc/gbsplayrc %D/etc/gbsplayrc.default; then rm -f %D/etc/gbsplayrc; fi
+etc/gbsplayrc.default
+@exec [ -f %B/gbsplayrc ] || cp %B/%f %B/gbsplayrc
+share/locale/de/LC_MESSAGES/gbsplay.mo
+share/locale/en/LC_MESSAGES/gbsplay.mo
+%%EXAMPLESDIR%%/nightmode.gbs
+@dirrm %%EXAMPLESDIR%%