aboutsummaryrefslogtreecommitdiff
path: root/audio/gbsplay
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-07 18:15:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-07 18:15:56 +0000
commit765a7924bf181362bb97e4d7beee3cd50e2064dd (patch)
treeb2abd2ef170fee28b1de9294d22ef8a4a0e7b0f1 /audio/gbsplay
parent3a6394696035025f43c57f8c4dfdcc7335777cd8 (diff)
downloadports-765a7924bf181362bb97e4d7beee3cd50e2064dd.tar.gz
ports-765a7924bf181362bb97e4d7beee3cd50e2064dd.zip
Notes
Diffstat (limited to 'audio/gbsplay')
-rw-r--r--audio/gbsplay/Makefile42
-rw-r--r--audio/gbsplay/distinfo5
-rw-r--r--audio/gbsplay/pkg-descr2
-rw-r--r--audio/gbsplay/pkg-plist4
4 files changed, 27 insertions, 26 deletions
diff --git a/audio/gbsplay/Makefile b/audio/gbsplay/Makefile
index 2b7b03b13d16..950ec01be39f 100644
--- a/audio/gbsplay/Makefile
+++ b/audio/gbsplay/Makefile
@@ -2,42 +2,45 @@
# $FreeBSD$
PORTNAME= gbsplay
-PORTVERSION= 0.0.8
-PORTREVISION= 7
+PORTVERSION= 0.0.93
CATEGORIES= audio
-MASTER_SITES= LOCAL/ehaupt
-PKGNAMEPREFIX?=
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT?= Emulates the sound hardware of the Nintendo Game Boy(TM)
+COMMENT= Emulates the sound hardware of the Nintendo Game Boy(TM)
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= mmitch
HAS_CONFIGURE= yes
-USES= gettext gmake
+USES= gmake compiler:gcc-c++11-lib
USE_CSTD= gnu89
CONFIGURE_ARGS+= --prefix=${PREFIX}
-.if ${PKGNAMEPREFIX} == ""
-
CONFIGURE_ARGS+= --without-xmmsplugin
MANPAGE1= gbsplay.1 gbsinfo.1
MANPAGE5= gbsplayrc.5
PORTDOCS= COPYRIGHT HISTORY README
-OPTIONS_DEFINE= NAS DOCS
-
-.endif
-
-.if ${PKGNAMEPREFIX} == ""
+OPTIONS_DEFINE= DOCS NAS NLS
+OPTIONS_SUB= yes
NAS_LIB_DEPENDS= libaudio.so:audio/nas
NAS_CONFIGURE_ENABLE= nas
+NLS_CONFIGURE_OFF= --disable-i18n
+NLS_USES= gettext
+NLS_LDFLAGS= -lintl
-.endif
+.include <bsd.port.options.mk>
-post-patch: gbsplay-post-patch
- @${REINPLACE_CMD} -e 's|^\(default.*\)test|\1|' ${WRKSRC}/${MAKEFILE}
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|^\(default.*\)test|\1|' \
+ -e 's#md5sum | cut -f1 -d..#md5 -q#' \
+ ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e \
'/^need_include\ /d; \
468s|char argc|int argc|; \
@@ -50,10 +53,6 @@ post-patch: gbsplay-post-patch
s|-Os||; s|-pipe||; s|-fomit-frame-pointer||; \
s|-march=$$ARCH||' \
${WRKSRC}/configure
-
-.if ${PKGNAMEPREFIX} == ""
-
-gbsplay-post-patch:
@${REINPLACE_CMD} -e 's|/\(etc/gbsplayrc\)|${PREFIX}/\1|' \
${WRKSRC}/gbsplay.c \
${WRKSRC}/gbsplay.in.1 \
@@ -79,14 +78,15 @@ do-install:
${STAGEDIR}${PREFIX}/etc/gbsplayrc
.endif
+.if ${PORT_OPTIONS:MNLS}
.for l in de en
${INSTALL_DATA} ${WRKSRC}/po/${l}.mo \
${STAGEDIR}${PREFIX}/share/locale/${l}/LC_MESSAGES/gbsplay.mo
.endfor
+.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/audio/gbsplay/distinfo b/audio/gbsplay/distinfo
index 2233d046b1d1..4a97a69424ac 100644
--- a/audio/gbsplay/distinfo
+++ b/audio/gbsplay/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gbsplay-0.0.8.tar.gz) = 9bd95118741315e991dfe4f5108128817725c924ba81bb4938de45290e8f0926
-SIZE (gbsplay-0.0.8.tar.gz) = 57033
+TIMESTAMP = 1475758315
+SHA256 (mmitch-gbsplay-0.0.93_GH0.tar.gz) = 49a4545b51b91d3c01100b7f99d7c00f981f60d2bade7389255076078deef4ef
+SIZE (mmitch-gbsplay-0.0.93_GH0.tar.gz) = 66683
diff --git a/audio/gbsplay/pkg-descr b/audio/gbsplay/pkg-descr
index 27b31b2d8639..0a873b457f19 100644
--- a/audio/gbsplay/pkg-descr
+++ b/audio/gbsplay/pkg-descr
@@ -2,4 +2,4 @@ gbsplay emulates the sound hardware of the Nintendo Game Boy(TM). It is able
to play the sounds from a Game Boy(TM) module dump (.GBS format) through
/dev/dsp, standard output or NAS.
-WWW: http://gbsplay.berlios.de/
+WWW: https://github.com/mmitch/gbsplay
diff --git a/audio/gbsplay/pkg-plist b/audio/gbsplay/pkg-plist
index 9ef8fc43b5c7..455da5c47327 100644
--- a/audio/gbsplay/pkg-plist
+++ b/audio/gbsplay/pkg-plist
@@ -1,8 +1,8 @@
bin/gbsplay
bin/gbsinfo
@sample etc/gbsplayrc.sample
-share/locale/de/LC_MESSAGES/gbsplay.mo
-share/locale/en/LC_MESSAGES/gbsplay.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gbsplay.mo
+%%NLS%%share/locale/en/LC_MESSAGES/gbsplay.mo
man/man1/gbsinfo.1.gz
man/man1/gbsplay.1.gz
man/man5/gbsplayrc.5.gz