aboutsummaryrefslogtreecommitdiff
path: root/audio/ghostess/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
commite9f205222ad644e2ee8148e9c1c57c414d14f8c3 (patch)
treec756bf9bc8f15a1ed85677502327ca9567637499 /audio/ghostess/Makefile
parentd56155d47cd7288475e19a7644cedc23b1b4f7ea (diff)
Notes
Diffstat (limited to 'audio/ghostess/Makefile')
-rw-r--r--audio/ghostess/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
new file mode 100644
index 000000000000..24e4330ddd2c
--- /dev/null
+++ b/audio/ghostess/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ghostess
+# Date created: 2007-01-13
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghostess
+PORTVERSION= 20061127
+CATEGORIES= audio
+MASTER_SITES= http://home.jps.net/~musound/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Graphical DSSI host with JACK MIDI support
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jackmidi
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
+
+.include <bsd.port.mk>