aboutsummaryrefslogtreecommitdiff
path: root/audio/ghostess
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
commite9f205222ad644e2ee8148e9c1c57c414d14f8c3 (patch)
treec756bf9bc8f15a1ed85677502327ca9567637499 /audio/ghostess
parentd56155d47cd7288475e19a7644cedc23b1b4f7ea (diff)
downloadports-e9f205222ad644e2ee8148e9c1c57c414d14f8c3.tar.gz
ports-e9f205222ad644e2ee8148e9c1c57c414d14f8c3.zip
Notes
Diffstat (limited to 'audio/ghostess')
-rw-r--r--audio/ghostess/Makefile28
-rw-r--r--audio/ghostess/distinfo3
-rw-r--r--audio/ghostess/files/patch-configure18
-rw-r--r--audio/ghostess/files/patch-src-Makefile.in12
-rw-r--r--audio/ghostess/files/patch-src-ghostess.c10
-rw-r--r--audio/ghostess/pkg-descr11
6 files changed, 82 insertions, 0 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
new file mode 100644
index 000000000000..24e4330ddd2c
--- /dev/null
+++ b/audio/ghostess/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ghostess
+# Date created: 2007-01-13
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghostess
+PORTVERSION= 20061127
+CATEGORIES= audio
+MASTER_SITES= http://home.jps.net/~musound/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Graphical DSSI host with JACK MIDI support
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jackmidi
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
+
+.include <bsd.port.mk>
diff --git a/audio/ghostess/distinfo b/audio/ghostess/distinfo
new file mode 100644
index 000000000000..f0fc9e2a418a
--- /dev/null
+++ b/audio/ghostess/distinfo
@@ -0,0 +1,3 @@
+MD5 (ghostess-20061127.tar.gz) = 74c6ee39a0ed1ac9ec0015fe7b45ffe6
+SHA256 (ghostess-20061127.tar.gz) = a557ecfecc85654cb2f86110485e8c5dcea602143d1a0666dd486aeacb2475fb
+SIZE (ghostess-20061127.tar.gz) = 375161
diff --git a/audio/ghostess/files/patch-configure b/audio/ghostess/files/patch-configure
new file mode 100644
index 000000000000..7d0d56e769e5
--- /dev/null
+++ b/audio/ghostess/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure.orig Tue Nov 28 17:09:13 2006
++++ configure Sat Jan 13 20:08:31 2007
+@@ -21405,14 +21405,9 @@
+ echo "GTK support: $with_gtk"
+
+ case "${host_os}" in
+-darwin*)
++darwin* | freebsd*)
+ darwin=yes
+
+-cat >>confdefs.h <<\_ACEOF
+-#define MIDI_COREMIDI 1
+-_ACEOF
+-
+-
+ succeeded=no
+
+ if test -z "$PKG_CONFIG"; then
diff --git a/audio/ghostess/files/patch-src-Makefile.in b/audio/ghostess/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..32c554e3d5f4
--- /dev/null
+++ b/audio/ghostess/files/patch-src-Makefile.in
@@ -0,0 +1,12 @@
+--- src/Makefile.in.orig Fri Jan 19 00:40:57 2007
++++ src/Makefile.in Fri Jan 19 00:42:05 2007
+@@ -207,9 +207,7 @@
+ @DARWIN_TRUE@@MIDI_JACK_TRUE@MIDI_SRCS = midi-jack.c
+ @DARWIN_FALSE@DARWIN_LD_FLAGS =
+ @DARWIN_TRUE@@MIDI_JACK_FALSE@DARWIN_LD_FLAGS = -framework CoreFoundation -framework CoreMIDI
+-@DARWIN_TRUE@@MIDI_JACK_TRUE@DARWIN_LD_FLAGS = -framework CoreFoundation
+ @DARWIN_FALSE@DARWIN_LD_ADD =
+-@DARWIN_TRUE@DARWIN_LD_ADD = -lmx
+ ghostess_SOURCES = \
+ ghostess.c \
+ ghostess.h \
diff --git a/audio/ghostess/files/patch-src-ghostess.c b/audio/ghostess/files/patch-src-ghostess.c
new file mode 100644
index 000000000000..3f50304bc872
--- /dev/null
+++ b/audio/ghostess/files/patch-src-ghostess.c
@@ -0,0 +1,10 @@
+--- src/ghostess.c.orig Sat Jan 13 19:36:01 2007
++++ src/ghostess.c Sat Jan 13 19:36:18 2007
+@@ -56,6 +56,7 @@
+ #include <dirent.h>
+ #include <pthread.h>
+ #include <math.h>
++#include <errno.h>
+
+ #include <gtk/gtk.h>
+
diff --git a/audio/ghostess/pkg-descr b/audio/ghostess/pkg-descr
new file mode 100644
index 000000000000..6836bc92f5cb
--- /dev/null
+++ b/audio/ghostess/pkg-descr
@@ -0,0 +1,11 @@
+Ghostess is a a graphical DSSI host, based on jack-dssi-host, but
+capable of saving and restoring plugin configuration, as well as
+specifying MIDI channels and layering synths. ghostess includes
+three MIDI drivers: an ALSA sequencer MIDI driver, a (clumsy but
+functional) CoreMIDI driver (which allows ghostess to be used on
+Mac OS X), and a JACK MIDI driver for use with the MIDI transport
+in recent versions (>=0.102.27) of JACK. ghostess also comes with
+a universal DSSI GUI, which attempts to provide GUI services for
+any DSSI or LADSPA plugin, and may be used with any DSSI host.
+
+WWW: http://home.jps.net/~musound/