aboutsummaryrefslogtreecommitdiff
path: root/audio/glame/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-26 18:42:25 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-26 18:42:25 +0000
commitefeff8ab953ffc7d89ddb33694f1fcfc4ce137f9 (patch)
tree91b18938a106b7d70600ce3a17bb9c86997c9cfa /audio/glame/Makefile
parent8c324aad36d686e4c4874de42ff4fbdecaa1e57d (diff)
Notes
Diffstat (limited to 'audio/glame/Makefile')
-rw-r--r--audio/glame/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
index 4e03094674c0..e38ef58e24c7 100644
--- a/audio/glame/Makefile
+++ b/audio/glame/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glame
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,30 +15,28 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful, fast, stable, and easily extensible sound editor for GNOME
-LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
+ ltdl.4:${PORTSDIR}/devel/libltdl
-USE_GNOME= gnomeprefix gnomehack libglade
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget libglade
USE_GMAKE= yes
USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lltdl ${PTHREAD_LIBS}"
+ LDFLAGS="-L${LOCALBASE}/lib -lltdl ${PTHREAD_LIBS}" \
+ MAKEINFO="makeinfo --no-split"
+INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
+INFO= glame glame-dev
+
+post-extract:
+ @cd ${WRKSRC}/doc && ${RM} -f *.info*
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
- @find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
- 's|<values[.]h>|<limits.h>|'
-
-post-install:
- @install-info ${PREFIX}/info/glame.info \
- --section="Audio Processing" \
- --entry="* glame: (glame). audio processing tool for GNOME" \
- ${PREFIX}/info/dir
+ @${GREP} -lR "<values\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<values\.h>|<limits.h>|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>