aboutsummaryrefslogtreecommitdiff
path: root/audio/glame
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-26 17:37:39 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-26 17:37:39 +0000
commit8f5e97d79ba6daea3cfbc349ec68d42fcb4044b1 (patch)
treeda6137439b215f4408dfed850df2fc75d26e1808 /audio/glame
parent22374b041c73ddf25a9f559adac5aaab5c2f03ad (diff)
downloadports-8f5e97d79ba6daea3cfbc349ec68d42fcb4044b1.tar.gz
ports-8f5e97d79ba6daea3cfbc349ec68d42fcb4044b1.zip
Notes
Diffstat (limited to 'audio/glame')
-rw-r--r--audio/glame/Makefile49
-rw-r--r--audio/glame/distinfo1
-rw-r--r--audio/glame/files/patch-aa11
-rw-r--r--audio/glame/files/patch-ab7
-rw-r--r--audio/glame/pkg-comment1
-rw-r--r--audio/glame/pkg-descr18
-rw-r--r--audio/glame/pkg-plist52
7 files changed, 139 insertions, 0 deletions
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
new file mode 100644
index 000000000000..814b1cdfb3f6
--- /dev/null
+++ b/audio/glame/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: glame
+# Date created: 26 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glame
+PORTVERSION= 0.2.0
+CATEGORIES= audio gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ guile.9:${PORTSDIR}/lang/guile
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|-lpthread|-pthread|g'
+
+post-install:
+ @install-info ${PREFIX}/info/glame.info \
+ --section="Audio Processing" \
+ --entry="* glame: (glame). audio processing tool for GNOME" \
+ ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/audio/glame/distinfo b/audio/glame/distinfo
new file mode 100644
index 000000000000..50e69af14c40
--- /dev/null
+++ b/audio/glame/distinfo
@@ -0,0 +1 @@
+MD5 (glame-0.2.0.tar.gz) = 4f76ec8fae2cac761dae2cf8b58f6c7e
diff --git a/audio/glame/files/patch-aa b/audio/glame/files/patch-aa
new file mode 100644
index 000000000000..15716c14d48f
--- /dev/null
+++ b/audio/glame/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/include/sem.h 2000/09/26 17:00:35 1.1
++++ src/include/sem.h 2000/09/26 17:01:08
+@@ -35,7 +35,7 @@
+ #if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)
+ /* union semun is defined by including <sys/sem.h> */
+ #else
+-#if !defined(_NO_XOPEN4)
++#if !defined(_NO_XOPEN4) && !defined(__FreeBSD__)
+ /* according to X/OPEN we have to define it ourselves */
+ union semun {
+ int val; /* value for SETVAL */
diff --git a/audio/glame/files/patch-ab b/audio/glame/files/patch-ab
new file mode 100644
index 000000000000..dbaa7423ec1f
--- /dev/null
+++ b/audio/glame/files/patch-ab
@@ -0,0 +1,7 @@
+--- config.h.in 2000/09/26 17:02:50 1.1
++++ config.h.in 2000/09/26 17:03:16
+@@ -127,3 +127,4 @@
+ /* Version number of package */
+ #undef VERSION
+
++#define ulong unsigned long
diff --git a/audio/glame/pkg-comment b/audio/glame/pkg-comment
new file mode 100644
index 000000000000..3c87ef7c2daa
--- /dev/null
+++ b/audio/glame/pkg-comment
@@ -0,0 +1 @@
+A powerful, fast, stable, and easily extensible sound editor for GNOME
diff --git a/audio/glame/pkg-descr b/audio/glame/pkg-descr
new file mode 100644
index 000000000000..ee23caf0f9ef
--- /dev/null
+++ b/audio/glame/pkg-descr
@@ -0,0 +1,18 @@
+GLAME is meant to be the GIMP of audio processing. It is designed to be
+a powerful, fast, stable, and easily extensible sound editor for GNOME
+desktop.
+
+Current Status (as of version 0.2.0):
+==========================================
+- usable filternetwork GUI - src/gui/glame
+- usable console UI - src/cglame
+- the glame midlayer which supports
+ * plugins
+ * scripting (using guile)
+- the filternetwork backend which supports
+ * threading, i.e. pipelined processing of all data
+ * feedback inside the network does work
+ * zero-copy operation inside and between filters
+- the swapfile backing store
+
+WWW: http://glame.sourceforge.net/
diff --git a/audio/glame/pkg-plist b/audio/glame/pkg-plist
new file mode 100644
index 000000000000..73fab29ac34d
--- /dev/null
+++ b/audio/glame/pkg-plist
@@ -0,0 +1,52 @@
+bin/cglame
+bin/glame
+bin/gmkswap
+@unexec install-info --delete %D/info/glame.info %D/info/dir
+info/glame.info
+info/glame.info-1
+info/glame.info-2
+info/glame.info-3
+@exec install-info --section="Audio Processing" --entry="* glame: (glame). audio processing tool for GNOME" %D/info/glame.info %D/info/dir
+lib/glame/debug.a
+lib/glame/debug.so
+lib/glame/debug.so.0
+lib/glame/echo.a
+lib/glame/echo.so
+lib/glame/echo.so.0
+lib/glame/garrison.a
+lib/glame/garrison.so
+lib/glame/garrison.so.0
+lib/glame/iir.a
+lib/glame/iir.so
+lib/glame/iir.so.0
+lib/glame/maggy.a
+lib/glame/maggy.so
+lib/glame/maggy.so.0
+lib/glame/noisegate.a
+lib/glame/noisegate.so
+lib/glame/noisegate.so.0
+lib/glame/nold.a
+lib/glame/nold.so
+lib/glame/nold.so.0
+lib/glame/pan.a
+lib/glame/pan.so
+lib/glame/pan.so.0
+lib/glame/pipe.a
+lib/glame/pipe.so
+lib/glame/pipe.so.0
+lib/glame/tutorial.a
+lib/glame/tutorial.so
+lib/glame/tutorial.so.0
+lib/libglame.a
+lib/libglame.so
+lib/libglame.so.0
+lib/libglamebuiltins.a
+lib/libglamebuiltins.so
+lib/libglamebuiltins.so.0
+share/gnome/glame/default.png
+share/gnome/glame/glame-logo.jpg
+share/gnome/glame/glame.scm
+share/gnome/glame/mix1.png
+share/gnome/glame/mix2.png
+@dirrm share/gnome/glame
+@dirrm lib/glame